Samsung HT-x20 Protection Problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 11 Old 02-06-2012, 06:36 AM - Thread Starter
Newbie
 
DjKrish's Avatar
 
Join Date: Dec 2010
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello guys, i have this home theater unit which is as stated above having this problem of going protected mode after about 20 to 30 minutes. It works fine when cooling period, when it gets warmed up around 20 mins plus, it shuts down by itself saying goodbye. The fan is working fine and i have already re soldered all the cold joint components. The set works perfectly fine except for this problem. Can anyone assist me in regards to this issue? Assistance highly appreciated.

I have already checked all capacitors for damage, all looks fine to me. No bloated caps, no burned out resistors. However, the IC 5Q1265RF is overheating extremely. Could that be the cause for the unit to go on protection mode? One more thing, i have inspected the power board during operation, the voltages are haywire. I checked one of the legs, suppose to be 12v, my meter shows 46v. One of the legs should show 5v, it shows 10v. The voltages seems to be higher than what it suppose to be like its stated on the board itself. Any ideas guys?



BTW, i have searched for the schematic diagram all over the net, no luck
DjKrish is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 02-09-2012, 06:43 AM - Thread Starter
Newbie
 
DjKrish's Avatar
 
Join Date: Dec 2010
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Guess i wont be getting help in here anyway after all. Ive solved the issue myself and repaired it. Closing thread
DjKrish is offline  
post #3 of 11 Old 02-09-2012, 07:45 AM
Senior Member
 
tlalotoani's Avatar
 
Join Date: Feb 2011
Posts: 294
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 23
How did you repaired? could be useful for others with same problem
tlalotoani is offline  
post #4 of 11 Old 02-09-2012, 04:05 PM - Thread Starter
Newbie
 
DjKrish's Avatar
 
Join Date: Dec 2010
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by tlalotoani View Post

How did you repaired? could be useful for others with same problem

Hi there, of course i can be helpful to assist. I replaced the 5Q1265RF 5 leg IC, DM0365R 4 leg IC. Its the protection and regulating IC. Thats what was faulty. Turning off by itself after half an hour. After replacing it, i tested for 2 days nonstop, still running fine.
DjKrish is offline  
post #5 of 11 Old 05-07-2012, 11:27 PM
Newbie
 
Sensle's Avatar
 
Join Date: May 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey, i have the same problem with my samsung htx20. I need a manual. How i get from 5 leg's to 4 leg's? Sry, i'm not so good in english. Have you pictures? ^^
Sensle is offline  
post #6 of 11 Old 05-08-2012, 07:14 AM
Newbie
 
Sensle's Avatar
 
Join Date: May 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
i have the same problem with my samsung htx20. I need a manual. How i get from 5 leg's to 4 leg's? Sry, i'm not so good in english. Have you pictures? ^^


Quote:
Originally Posted by DjKrish View Post

Hi there, of course i can be helpful to assist. I replaced the 5Q1265RF 5 leg IC, DM0365R 4 leg IC. Its the protection and regulating IC. Thats what was faulty. Turning off by itself after half an hour. After replacing it, i tested for 2 days nonstop, still running fine.

Sensle is offline  
post #7 of 11 Old 06-23-2012, 11:12 AM
Newbie
 
thtcpa's Avatar
 
Join Date: Jun 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I see where the 5Q1265RF 5 leg IC, but cannot fine where the DM0365R 4 leg IC goes, or find one to buy. The only thing I find on ebay is an 8 pin (four on each side) power switch.
thtcpa is offline  
post #8 of 11 Old 06-29-2012, 02:34 AM
Newbie
 
jeriah's Avatar
 
Join Date: Jun 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have encountered a problem like this. Malfunctioning component inside the unit. It will go into protection mode and I immediately shut down to protect the system from any further damage. Unfortunately, I would have to bring to a dealer or repair shop to diagnose the exact malfunction.
jeriah is offline  
post #9 of 11 Old 07-09-2012, 03:43 PM
Newbie
 
William Henry G's Avatar
 
Join Date: Jul 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
La verdad, no entiendo bien lo que has hecho, dices que has sustituido el IC 5Q1265RF en el pin 5, (ya que el pin 5 es el sincronismo), y el IC DM0365R en el pin 4 dice: Ajusta la corriente limite de sensibilidad el FET con una realimentación de 0.9mA, de corriente en paralelo.... pero mi pregunta es a donde los has conectado o los desconectaste o que ha pasado con la regulación de estos Circuitos ?
no tengo claro tu arreglo.

Seria que me puedes explicar un poco mejor. De antemano, Gracias
William Henry G is offline  
post #10 of 11 Old 03-18-2013, 07:19 AM
Newbie
 
mgun's Avatar
 
Join Date: Mar 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi where to get this IC ? How much it cost ?
mgun is offline  
post #11 of 11 Old 11-15-2013, 06:40 AM
Newbie
 
arset's Avatar
 
Join Date: Nov 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

Hi, 

 

I can send you detailed repair manual. My e-mail is arset@abv.bg

 

If you know the exact model of DVD player or at least the laser pickup optic block it will be useful for me...

 

Aram

arset is offline  
Reply Home Theater In A Box

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off