Onkyo TX-SR606 HTIB receiver problems whats the best option?? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 09-03-2012, 09:41 AM - Thread Starter
Newbie
 
essg88's Avatar
 
Join Date: Sep 2012
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello,

Long time reader first post...I have an Onkyo TX-SR606 HTIB system and I believe the daughter board on the receiver is busted. I can not turn the system off cause then it takes an incredibly long time for a signal to even be seen and that is just for one of the inputs. On the other inputs, it is almost impossible to get a signal without constantly restarting the system over and over again or waiting a really long time. It has become pretty much unusable.

I dont know how much it might cost to fix this, would it be worth looking into a new/better receiver? If so, what do I do about the existing speakers? I'm not sure which other receiver would be best compatible. Thanks for the input.
essg88 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-03-2012, 07:27 PM
AVS Special Member
 
robnix's Avatar
 
Join Date: Dec 2003
Posts: 1,603
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 51 Post(s)
Liked: 251
Quote:
Originally Posted by essg88 View Post

Hello,
Long time reader first post...I have an Onkyo TX-SR606 HTIB system and I believe the daughter board on the receiver is busted. I can not turn the system off cause then it takes an incredibly long time for a signal to even be seen and that is just for one of the inputs. On the other inputs, it is almost impossible to get a signal without constantly restarting the system over and over again or waiting a really long time. It has become pretty much unusable.
I dont know how much it might cost to fix this, would it be worth looking into a new/better receiver? If so, what do I do about the existing speakers? I'm not sure which other receiver would be best compatible. Thanks for the input.

Sounds like your HDMI board. This is a known issue with this receiver, bad caps on the board. Call Onkyo, AFAIK, they're still replacing them for free.
essg88 likes this.

Looky here!
robnix is online now  
post #3 of 3 Old 09-03-2012, 07:49 PM - Thread Starter
Newbie
 
essg88's Avatar
 
Join Date: Sep 2012
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by robnix View Post

Sounds like your HDMI board. This is a known issue with this receiver, bad caps on the board. Call Onkyo, AFAIK, they're still replacing them for free.
Oh wow, that would be great. I will give them a call tomorrow. Thanks for the info, I'll update with their response.
essg88 is offline  
Reply Home Theater In A Box

Tags
Onkyo , Onkyo Tx Sr606 Receiver , Receivers Amplifiers
Gear in this thread

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off