Sony HT-SS380 and Dolby TrueHD not showing in the display - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 12-28-2012, 04:24 AM - Thread Starter
Newbie
 
nikpharmd's Avatar
 
Join Date: Dec 2012
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I received a Sony HT-SS380 for Christmas. I have tested out a plethora of movies on my new HT-SS380. However, every movie that I try that says it has Dolby TrueHD, it never shows up on the display panel of the HT-SS380. If I hit display on the remote for my PS3 model CECHK01 or my Sony 3D Blu-ray BDP-S590 it says English Dolby True HD 5.1 ch 48kHz on the TV screen. But on the display of the HT-SS380 it always has Dolby Pro Logic (PL) lit not Dolby TrueHD. Why is this? Both the PS3 and the 3D Blu-ray player are connected via an HDMI cable to the receiver. Should I also connect them to the receiver using an optical cable? Furthermore, what should I set the Audio Output settings on the PS3 to? Should I check all of the boxes? I primarily use the PS3 for everything. Any help would be greatly appreciated. I am newbie when it comes to home theater equipment, but I want to get the most from my equipment.
nikpharmd is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-28-2012, 05:43 AM
Advanced Member
 
Dropkick Murphy's Avatar
 
Join Date: Dec 2008
Posts: 601
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Liked: 63
http://www.engadget.com/2009/04/21/hd-101-how-to-use-dolby-truehd-and-dts-hd-with-your-ps3/

Dropkick Murphy is offline  
post #3 of 5 Old 12-28-2012, 09:05 AM
AVS Special Member
 
BIslander's Avatar
 
Join Date: Jul 2005
Posts: 8,569
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 74 Post(s)
Liked: 130
If your receiver says PLII, that means the PS3 is outputting stereo instead of a multichannel track. You will need to change the output setup of the PS3. I cannot help with that. But, there are threads for the PS3 in the Blu-ray players forum. Newer PS3s can be set to bitstream, which sends the encoded TrueHD track to the sound system for decoding. Older PS3s need to be set to output multichannel PCM because they cannot output lossless bitstreams.
BIslander is online now  
post #4 of 5 Old 12-30-2012, 01:21 AM
AVS Special Member
 
JChin's Avatar
 
Join Date: Oct 2008
Location: Mesquite Tx
Posts: 8,530
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Liked: 134
Hi nikpharmd, the PS3 CECHK01 is an earlier model which can't bitstream (settings: Video Settings > BD/DVD Audio Output (HDMI) - Linear PCM, Sound Settings > Audio Multi Output - Off) so display of the HT-SS380 should have LPCM lid. The Sony BD-S590 can bitstream (settings: HDMI Audio - Auto, BD Audio Mix - Off) so display of the HT-SS380 should have Dolby TrueHD lid.

Note on some BD movies HD audio is not set as default so you will need to go into audio or language track to select TrueHD audio.

If you still having problem then try going into the HT-SS380 menu and turn HDMI Control to Off.
JChin is offline  
post #5 of 5 Old 05-13-2013, 11:20 AM
Newbie
 
Larry1453's Avatar
 
Join Date: May 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
JChin,
I was having a similar problem, although my source was a Panasonic Blu-ray player. I tried turning off HDMI Control in the Sony receiver and all of a sudden, it started working correctly and displaying DTS processing and other audio types besides Dolby ProLogic through LPCM. It even appears to continue working after I switch HDMI Control back on.
My questions are, how did you know that would work and why does it work?
I don't actually use HDMI Control, but in order to access the pass-through-always-on feature in the receiver, you have to have HDMI Control turned on.
Thanks!
Larry1453 is offline  
Reply Home Theater In A Box

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off