Volume is low on my surround sound system, please help - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 05-07-2013, 11:20 AM - Thread Starter
Member
 
indy197905's Avatar
 
Join Date: Nov 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a Insignia model:NS-HTIB51A htib that I bought about 2-3 years ago. Recently I noticed that my overall sound is lower than it used to be. I raised the overall volume setting and it's still low. Also my center speaker volume is lower than the others. Do I need a new receiver or maybe new speakers or is there some way to adjust it?
indy197905 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-02-2013, 04:31 PM - Thread Starter
Member
 
indy197905's Avatar
 
Join Date: Nov 2008
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Does anyone have an answer?
indy197905 is offline  
post #3 of 3 Old 10-02-2013, 05:56 PM
AVS Special Member
 
Otto Pylot's Avatar
 
Join Date: May 2004
Location: San Jose, CA
Posts: 7,199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 129 Post(s)
Liked: 238
Have you called Insignia? Maybe it's a volume controller (for want of a better term) or something like that that can be repaired/replaced. I doubt if better speakers would help if you're not getting signal to them. But it sounds like you might want to start looking around for a new receiver/system.
Otto Pylot is online now  
Reply Home Theater In A Box

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off