Onkyo ht-r390 - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 08-22-2013, 08:47 AM - Thread Starter
bk627's Avatar
Join Date: Aug 2013
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have an onkyo ht-r390. I love the system. But I'm having trouble with one of the hdmi inputs. Everything was working fine until one day one of the hdmi inputs stopped working. I tried switching hdmi wires and still no picture. I just get a blue screen. The other 3 hdmi ports work fine. I tried resetting the system and still no luck. Any suggestions?
bk627 is offline  
Sponsored Links
Old 08-23-2013, 06:03 AM
AVS Special Member
flickhtguru's Avatar
Join Date: Mar 2008
Location: Lebanon, PA
Posts: 2,458
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 105
I'm an Onkyo fan and I have an Onkyo TX NR808 AVR and I have owned a few Onkyo HTIB's... I have never had any trouble with any of my equipment, but probably the biggest problem Onkyo has is their HDMI boards are known to fail quite often. I'm guessing that is what happened to you. If you don't use all 4 HDMI ports just use one that is working, if your system is still under warranty call Onkyo and see what to do to have it repaired. If those options don't suit your situation then I guess its time for you to get upgraditus and start with a quality AVR.

flickhtguru is offline  
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off