BIC America F12 sub anyone ? - Page 100 - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 38Likes
Reply
Thread Tools
post #2971 of 2981 Old 06-10-2015, 06:09 PM
AVS Addicted Member
 
Bond 007's Avatar
 
Join Date: Jun 2012
Location: Cincinnati, OH
Posts: 13,333
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 779 Post(s)
Liked: 1093
Quote:
Originally Posted by Dom Di Stroia View Post
Does he regret his decision?

If not, why break what isn't broken?
His decision isn't the only concern. Don't want potential buyers to expect things to shake in a 25x30 room with a kitchen and hallway attached.
Dom Di Stroia likes this.
Bond 007 is online now  
Sponsored Links
Advertisement
 
post #2972 of 2981 Old 06-10-2015, 06:15 PM
Senior Member
 
Dom Di Stroia's Avatar
 
Join Date: Mar 2013
Location: The Right Side of Left Behind
Posts: 251
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Liked: 78
Quote:
Originally Posted by Bond 007 View Post
His decision isn't the only concern. Don't want potential buyers to expect things to shake in a 25x30 room with a kitchen and hallway attached.
Understood.

(Maybe he has some really loose fixtures.)
Dom Di Stroia is offline  
post #2973 of 2981 Old 06-10-2015, 08:21 PM
AVS Special Member
 
Augerhandle's Avatar
 
Join Date: Jan 2009
Location: About 19" away from my computer screen
Posts: 3,381
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 347 Post(s)
Liked: 294
Quote:
Originally Posted by Dom Di Stroia View Post
No question.

But, not everyone needs a sports car.

(In some jurisdictions, the maximum highway speed is only ~60 mph.)

I don't need a sports car. My point should have been obvious in that respect. (and BTW, I have the most fun in mine well under 60 MPH, especially on twisty mountain roads.)


No one needs a subwoofer either. (Any subwoofer, not just good ones) Your argument about need is the straw man here. The OP's comments were about desire, not need, and how sometimes you don't really understand something until you experience it.


Quote:
Originally Posted by MIX_MASTER_ICE View Post
Word of advice that will save you lots of $$$ in the future......never audition or even go near a true subwoofer, one that can deliver down to 20Hz or lower. You will likely have a strong desire to upgrade.
Dom Di Stroia likes this.

"The wise understand by themselves; fools follow the reports of others"-Tibetan Proverb
_________________________________________________
 
Augerhandle is offline  
post #2974 of 2981 Old 07-02-2015, 07:36 AM
Member
 
Coxis's Avatar
 
Join Date: Oct 2012
Location: Mexico
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Hey guys, so I've had this sub for about 4 years now and I couldn't be happier. The one thing though, is that it is a little boomy for music. Would getting a second one, placed on the wall behind my couch (The other one is in front) and switching the phase of each to a different position help with this boomyness? I would calibrate them with my SPL meter beforehand.
Coxis is offline  
post #2975 of 2981 Old 07-09-2015, 03:47 PM
Newbie
 
tagrat's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Just received my BIC F12 from Parts-Express today. Was super excited to hook it up and test it out. Unfortunately, I think it is broken. It powers on, but I am not able to get any sound out of it at all. I have it hooked up to the sub out on my Yamaha receiver, have tried multiple cables, made sure the sub was enabled and set all of my other speakers to small. Crossover is set super high on the receiver and the sub, the switch is set to the LFE/Digital side. I have also tried hooking up my iPhone directly to it to see if it was the receiver. Still nothing. One thing I noticed was that in the Auto position, the light is always green as if it is detecting a signal, even with nothing plugged in to the input. Any suggestions to try before I start an exchange with Parts-Express?

My HT Gear:
Samsung PN50C550
Yamaha RX-V465
KLH 9912 Floor Standing Speakers
Playstation 3
tagrat is online now  
post #2976 of 2981 Old 07-09-2015, 06:54 PM
AVS Addicted Member
 
Bond 007's Avatar
 
Join Date: Jun 2012
Location: Cincinnati, OH
Posts: 13,333
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 779 Post(s)
Liked: 1093
Quote:
Originally Posted by tagrat View Post
Just received my BIC F12 from Parts-Express today. Was super excited to hook it up and test it out. Unfortunately, I think it is broken. It powers on, but I am not able to get any sound out of it at all. I have it hooked up to the sub out on my Yamaha receiver, have tried multiple cables, made sure the sub was enabled and set all of my other speakers to small. Crossover is set super high on the receiver and the sub, the switch is set to the LFE/Digital side. I have also tried hooking up my iPhone directly to it to see if it was the receiver. Still nothing. One thing I noticed was that in the Auto position, the light is always green as if it is detecting a signal, even with nothing plugged in to the input. Any suggestions to try before I start an exchange with Parts-Express?
Tried the test tone in your Yamaha?
What happens when you run YPAO?
Bond 007 is online now  
post #2977 of 2981 Old 07-09-2015, 06:59 PM
Newbie
 
tagrat's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Quote:
Originally Posted by Bond 007 View Post
Tried the test tone in your Yamaha?
What happens when you run YPAO?
I did both. No response either way. I tried the high level inputs with another amp I have and that didn't work either. I think it is a bad unit. I will contact Parts-Express tomorrow about an exchange I think.

My HT Gear:
Samsung PN50C550
Yamaha RX-V465
KLH 9912 Floor Standing Speakers
Playstation 3
tagrat is online now  
post #2978 of 2981 Old 07-09-2015, 07:03 PM
AVS Addicted Member
 
Bond 007's Avatar
 
Join Date: Jun 2012
Location: Cincinnati, OH
Posts: 13,333
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 779 Post(s)
Liked: 1093
Quote:
Originally Posted by tagrat View Post
I think it is a bad unit. I will contact Parts-Express tomorrow about an exchange I think.
Agreed.
Bond 007 is online now  
post #2979 of 2981 Old Today, 03:27 AM
Member
 
Ketnis's Avatar
 
Join Date: Dec 2012
Posts: 81
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 13
Quote:
Originally Posted by tagrat View Post
Just received my BIC F12 from Parts-Express today. Was super excited to hook it up and test it out. Unfortunately, I think it is broken. It powers on, but I am not able to get any sound out of it at all. I have it hooked up to the sub out on my Yamaha receiver, have tried multiple cables, made sure the sub was enabled and set all of my other speakers to small. Crossover is set super high on the receiver and the sub, the switch is set to the LFE/Digital side. I have also tried hooking up my iPhone directly to it to see if it was the receiver. Still nothing. One thing I noticed was that in the Auto position, the light is always green as if it is detecting a signal, even with nothing plugged in to the input. Any suggestions to try before I start an exchange with Parts-Express?
Do you have another sub that worked previously with that receiver? I ask because there are countless threads about Yamaha receivers and failing pre-outs. I know on my Yamaha, the pre-out voltage is abysmal, though even if yours is just low it should still be able to send max signal for that sub.
Ketnis is offline  
post #2980 of 2981 Old Today, 03:03 PM
Newbie
 
tagrat's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Quote:
Originally Posted by Ketnis View Post
Do you have another sub that worked previously with that receiver? I ask because there are countless threads about Yamaha receivers and failing pre-outs. I know on my Yamaha, the pre-out voltage is abysmal, though even if yours is just low it should still be able to send max signal for that sub.
Tried it with my phone and also another amp. Don't have another sub to test with. It is on its way back to Ohio.

My HT Gear:
Samsung PN50C550
Yamaha RX-V465
KLH 9912 Floor Standing Speakers
Playstation 3
tagrat is online now  
post #2981 of 2981 Unread Today, 04:17 PM
AVS Special Member
 
Augerhandle's Avatar
 
Join Date: Jan 2009
Location: About 19" away from my computer screen
Posts: 3,381
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 347 Post(s)
Liked: 294
Quote:
Originally Posted by tagrat View Post
Tried it with my phone and also another amp. Don't have another sub to test with. It is on its way back to Ohio.
These speakers sometimes have a wire wiggle loose inside during shipping. Not a big deal, but it can be a pain.

"The wise understand by themselves; fools follow the reports of others"-Tibetan Proverb
_________________________________________________
 
Augerhandle is offline  
Sponsored Links
Advertisement
 
Reply Subwoofers, Bass, and Transducers



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off