BIC America F12 sub anyone ? - Page 34 - AVS Forum
Forum Jump: 
 1Likes
Reply
 
Thread Tools
post #991 of 2862 Old 03-01-2010, 09:11 PM
AVS Special Member
 
tingham's Avatar
 
Join Date: Nov 2005
Location: Bucks County, PA
Posts: 2,671
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 18
According to that chart, no. But you should check the official Audyssey thread to make sure there is no difference in the sub filters for sure. Chris (Audyssey founder) is very active in that thread and you can ask the question if you do not find an answer by searching for it.

Keep in mind that most AVR's equipped with XT will have better components in them also.

Go Phillies! Go Eagles! Go Sixers! Go Flyers!
tingham is offline  
Sponsored Links
Advertisement
 
post #992 of 2862 Old 03-01-2010, 09:24 PM
AVS Special Member
 
tingham's Avatar
 
Join Date: Nov 2005
Location: Bucks County, PA
Posts: 2,671
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 18
Quote:
Originally Posted by Todd Lee View Post

Edit: The rattling isn't coming from where we thought it was. The grill fabric isn't glued on to the back of the grill in a small area. The noise is the cloth vibrating back and forth, flapping in the wind, if you will. He is going to call BIC, see what they recommend doing. If nothing, then he'll try glueing it himself.

(if anybody cares)

Thanks for the update. I always like to read members thoughts and concerns. That's what this forum is all about.

And BIC should take care of your bro, no problem. They are known for great customer service.

Go Phillies! Go Eagles! Go Sixers! Go Flyers!
tingham is offline  
post #993 of 2862 Old 03-02-2010, 07:17 AM
AVS Special Member
 
mphfrom77's Avatar
 
Join Date: Jan 2010
Location: northern KY
Posts: 3,784
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
Liked: 222
Thanks Tingham. Yeah, I had already forgot about the better components anyways. Yeah, I guess I have to do some reading in the audyssey thread. By the way the F12 started shipping to us yesterday!
mphfrom77 is offline  
post #994 of 2862 Old 03-02-2010, 07:34 AM
Senior Member
 
Todd Lee's Avatar
 
Join Date: May 2005
Location: Kaysville, UT
Posts: 317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by tingham View Post

Thanks for the update. I always like to read members thoughts and concerns. That's what this forum is all about.

And BIC should take care of your bro, no problem. They are known for great customer service.

You're welcome, and that's what I told my BIL, BIC should fix him up.
Todd Lee is offline  
post #995 of 2862 Old 03-02-2010, 02:08 PM
Member
 
RaginBajin's Avatar
 
Join Date: Mar 2009
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I'm on the 3/9 shipment. I'm hoping mine get shipped out then. I can't wait.
RaginBajin is offline  
post #996 of 2862 Old 03-02-2010, 07:45 PM
Senior Member
 
zippo775's Avatar
 
Join Date: Nov 2008
Posts: 202
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
Quote:
Originally Posted by RaginBajin View Post

I'm on the 3/9 shipment. I'm hoping mine get shipped out then. I can't wait.

Let us know what you think when you get it. I was impressed when I got this sub months ago. My theater sound is impressive with this sub as an addition to the passive subs I have. Gave me that extra Ump I needed.
zippo775 is offline  
post #997 of 2862 Old 03-02-2010, 10:49 PM
Senior Member
 
texraider's Avatar
 
Join Date: Dec 2008
Posts: 291
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
My F-12 finally shipped today from California via Fed-Ex. I expect delivery on the 4th of this month. I ordered mine on 1/23 (so if you ordered around this date, hopefully you will be getting yours soon too.

This is my second F-12 and this one is going in a smaller HT, I expect to use it quite a bit so I can't wait for it to get here.
texraider is offline  
post #998 of 2862 Old 03-03-2010, 07:43 AM
Senior Member
 
slopokdave's Avatar
 
Join Date: Sep 2008
Location: Jacksonville, FL
Posts: 229
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Do any of you run dual F12s? What are your thoughts versus going with a single, more expensive sub in the ~$500+ range?
slopokdave is offline  
post #999 of 2862 Old 03-03-2010, 10:02 AM
Senior Member
 
imblind's Avatar
 
Join Date: Mar 2007
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
well i think this sub sounds fantastic.

my only gripe is that i'm having issues with the sub waking up when it's on auto mode. i have to flip the switch to ON, otherwise the sub will stay asleep.
imblind is offline  
post #1000 of 2862 Old 03-03-2010, 11:26 AM
Newbie
 
willjs7's Avatar
 
Join Date: Oct 2008
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ordered on 2/23, was pushed back to a ship date of 3/9 from Penn.
willjs7 is offline  
post #1001 of 2862 Old 03-03-2010, 11:59 AM
AVS Special Member
 
JChin's Avatar
 
Join Date: Oct 2008
Location: Mesquite Tx
Posts: 8,572
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 137
Quote:
Originally Posted by imblind View Post

well i think this sub sounds fantastic.

my only gripe is that i'm having issues with the sub waking up when it's on auto mode. i have to flip the switch to ON, otherwise the sub will stay asleep.

May try a Y-splitter connect at the sub as I heard that helps waking up the sub.
JChin is offline  
post #1002 of 2862 Old 03-03-2010, 12:19 PM
Member
 
JonM33's Avatar
 
Join Date: Feb 2010
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Mine is supposed to ship from BLT on 3/9 as well. I ordered on 2/16. I hope to get it soon! Been dying to replace the 8-inch Polk subwoofer that I have.
JonM33 is offline  
post #1003 of 2862 Old 03-03-2010, 06:04 PM
Member
 
zamac_man's Avatar
 
Join Date: Jun 2007
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by JonM33 View Post

Mine is supposed to ship from BLT on 3/9 as well. I ordered on 2/16. I hope to get it soon! Been dying to replace the 8-inch Polk subwoofer that I have.

Ordered 2/11, pushed back to 3/9 from PA. Replacing my 8" onkyo.
zamac_man is offline  
post #1004 of 2862 Old 03-04-2010, 02:45 PM
Member
 
audioscience's Avatar
 
Join Date: Dec 2009
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have been see-sawing on this for a while and finally placed an order for one with BLT.

I'm looking forward to it if the shipment comes through.
audioscience is offline  
post #1005 of 2862 Old 03-05-2010, 08:09 AM
Newbie
 
jdwksu's Avatar
 
Join Date: Jul 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Current system:
Onkyo 606
Fronts: Polk RTi8's
Rear Sur: Polk M40's
Center: Polk A6
Sub Bic F12

I got my F12 the other night. I connected it using a sub cable. I set the gain to 4, phase 0, crossover on the back of the sub to highest setting. And it is switched to digital 5.1,6.1, 7.1 I ran audyusy(sp)lol. Well it came back with my center and fronts set to Full band. it pegged my sub at 10 ft which is correct but put it at -13db. Most of my other speakers are at -4 to -5 db.
I increased the sub to -4db. After listening to it I can tell it is making noise but my towers seem to be putting out more bass than the subwoofer. The sub sounds very quiet. I am in a apartment which is somewhat small.

Do I need to abandon the audussy setup and do it manually so I can set my mains to small? Or do I have some other problem?
jdwksu is offline  
post #1006 of 2862 Old 03-05-2010, 08:30 AM
AVS Special Member
 
JChin's Avatar
 
Join Date: Oct 2008
Location: Mesquite Tx
Posts: 8,572
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 137
Quote:
Originally Posted by jdwksu View Post

Current system:
Onkyo 606
Fronts: Polk RTi8's
Rear Sur: Polk M40's
Center: Polk A6
Sub Bic F12

I got my F12 the other night. I connected it using a sub cable. I set the gain to 4, phase 0, crossover on the back of the sub to highest setting. And it is switched to digital 5.1,6.1, 7.1 I ran audyusy(sp)lol. Well it came back with my center and fronts set to Full band. it pegged my sub at 10 ft which is correct but put it at -13db. Most of my other speakers are at -4 to -5 db.
I increased the sub to -4db. After listening to it I can tell it is making noise but my towers seem to be putting out more bass than the subwoofer. The sub sounds very quiet. I am in a apartment which is somewhat small.

Do I need to abandon the audussy setup and do it manually so I can set my mains to small? Or do I have some other problem?


When set to full band the front and center are getting double bass.
Suggest to lower the subwoofer gain to 3 and reun audyssey.
Then manually set fronts and other speakers to small.
Set crossover to 80Hz and LPF of LFE: 120hz
JChin is offline  
post #1007 of 2862 Old 03-05-2010, 08:42 AM
Newbie
 
jdwksu's Avatar
 
Join Date: Jul 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by JChin View Post

When set to full band the front and center are getting double bass.
Suggest to lower the subwoofer gain to 3 and reun audyssey.
Then manually set fronts and other speakers to small.
Set crossover to 80Hz and LPF of LFE: 120hz


I will give that a try this afternoon. Thanks for the reply. I will update later on outcome.

Also on a side note... After I had set everything up and I was rechecking the cable connections to make sure the sub had a good connection to the reciever I forgot to turn the reciever off. I am laying there on the ground with the sub about 3 ft from me looking at the back of the reciever and I unplug the sub out cable and try to plug it back in and the plug hit the side of the sub out terminal and the sub went boom it scared the crap out of me. I know I didn't damage the sub but it sure did scare the crap out of me almost hit my head on my tv stand. LOL funny....
jdwksu is offline  
post #1008 of 2862 Old 03-05-2010, 09:02 AM
Senior Member
 
zippo775's Avatar
 
Join Date: Nov 2008
Posts: 202
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
And make sure after you run audussy you manually set the speakers to small, most times the receiver has them at large. That should help with your bass getting directed to the sub.
zippo775 is offline  
post #1009 of 2862 Old 03-05-2010, 09:31 AM
Senior Member
 
Todd Lee's Avatar
 
Join Date: May 2005
Location: Kaysville, UT
Posts: 317
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by imblind View Post

well i think this sub sounds fantastic.

my only gripe is that i'm having issues with the sub waking up when it's on auto mode. i have to flip the switch to ON, otherwise the sub will stay asleep.

If you haven't solved this already, try turning the lfe-out gain up on your receiver, and compensate by turning the sub gain down. (on the back of the sub)

This will send a stronger signal from your receiver, which should in-turn trigger your sub to turn on.
Todd Lee is offline  
post #1010 of 2862 Old 03-05-2010, 12:54 PM
Member
 
zikronix's Avatar
 
Join Date: Aug 2004
Posts: 121
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Todd Lee View Post

If you haven't solved this already, try turning the lfe-out gain up on your receiver, and compensate by turning the sub gain down. (on the back of the sub)

This will send a stronger signal from your receiver, which should in-turn trigger your sub to turn on.

AH! (light bulb goes click!)

btw got mine two days ago...replaced a sub from the cerwin vega 5.1 avs sets...very nice indeed.
zikronix is offline  
post #1011 of 2862 Old 03-05-2010, 03:16 PM
Newbie
 
jdwksu's Avatar
 
Join Date: Jul 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by zippo775 View Post

And make sure after you run audussy you manually set the speakers to small, most times the receiver has them at large. That should help with your bass getting directed to the sub.

The Onkyo 606 does not have settings for small or large in the setup menu. I figured this out after a while of looking around. Full band = large, and anything other than full band = small on the set up menu.

I ran audussy and it once again set everything to full band. I went and changed my fronts/surround/ center to 80hz. Set the lpe/fte thing to 120hz
I changed the sub gain to 3 on the back, and level db to -5 in the receiver.

The sub now has life, a bit too much life... It is more boomy than I had anticipated. I watched a few scenes of transformers 2 the end fight scene and it seemed like the sub was putting out a almost constant rumble due to various explosions all the time. Maybe it is suppose to be that way and I just simply wasn't getting those 25-35hz levels from my tower speakers...

Don't get me wrong, I like the sub but I guess I will just have to listen to it for a while to get use to the difference. It can play way louder than I need it to. It puts out more bass than my wife allows

Is it normal or am I just being picky.
jdwksu is offline  
post #1012 of 2862 Old 03-05-2010, 03:22 PM
AVS Special Member
 
Pete7874's Avatar
 
Join Date: Sep 2005
Location: Illinoistan
Posts: 1,597
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Quote:
Originally Posted by jdwksu View Post

I ran audussy and it once again set everything to full band. I went and changed my fronts/surround/ center to 80hz. Set the lpe/fte thing to 120hz
I changed the sub gain to 3 on the back, and level db to -5 in the receiver.

The sub now has life, a bit too much life... It is more boomy than I had anticipated. I watched a few scenes of transformers 2 the end fight scene and it seemed like the sub was putting out a almost constant rumble due to various explosions all the time.

Play around with the frequencies some more... for example, reduce the front x-over to 60 Hz and see what happens.

Also, pull out an old trusty SPL meter and play some test tones to ensure you're not running the sub too hot compared to all your other speakers. I mean, it's OK if it's a couple of dB hotter than the rest, but probably not more than that.

"The problem with quotes on the Internet is that you never know if they're real." - Abraham Lincoln

Pete7874 is offline  
post #1013 of 2862 Old 03-05-2010, 03:57 PM
Member
 
tmiw's Avatar
 
Join Date: Aug 2009
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by zamac_man View Post

Ordered 2/11, pushed back to 3/9 from PA. Replacing my 8" onkyo.

How do you guys know what warehouse it's going to ship from? I'm assuming CA for mine because their inventory checker says "Past Due" for PA and 3/9 for CA.
tmiw is offline  
post #1014 of 2862 Old 03-05-2010, 07:55 PM
AVS Special Member
 
mphfrom77's Avatar
 
Join Date: Jan 2010
Location: northern KY
Posts: 3,784
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
Liked: 222
I found out with the email that they sent when it shipped.

By the way we received the F12 from blt.com today (shipped on Monday from CA and arrived here in KY on Friday). We paid the extra $2 for the signature, but they just left it on the porch anyways (I think that's what I was hoping would happen so I could check it out later as opposed to having to do it right there with the delivery guy). It's for someone I am helping. I will go look at it later, and it won't be another month or two before I set the system up, so I will give my initial review then.
mphfrom77 is offline  
post #1015 of 2862 Old 03-06-2010, 06:41 AM
Member
 
bigwheels1's Avatar
 
Join Date: Dec 2009
Posts: 118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ordering an F-12 from BLT gets you a decent price but expect a delay of around 30-days before you receive your F-12.

Current F-12 backorder schedule:
California warehouse: 4/19
Pennsylvania warehouse: 4/11
bigwheels1 is offline  
post #1016 of 2862 Old 03-06-2010, 07:34 AM
SRR
AVS Special Member
 
SRR's Avatar
 
Join Date: Jan 2002
Location: Wisconsin
Posts: 1,939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Has anyone tried running one of these in a sealed configuration? Like ummm, well putting a sock it, literally. Put a sock or two in the port, bunch them up, roll them up, whatever it takes to block the port so little or no air is coming out of the port when there is a good amount of bass. I did this to a old DIY sub that originally had a 8 inch driver that the Lion King on VHS blew up, and I went with a 12inch JBL driver, and well I think the box and port are to small for the JBL and about two years ago I put a sock it, and man totally changed the subs performance. I have never measured it but it sure seems smoother to me.

ANYWAYS, try it with the F-12, if you hate it de-sock it, lol. Oh and has anyone used REW on the F-12 in their room? I couldn't find any plots.
SRR is offline  
post #1017 of 2862 Old 03-06-2010, 11:41 AM
Newbie
 
jdwksu's Avatar
 
Join Date: Jul 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Pete7874 View Post

Play around with the frequencies some more... for example, reduce the front x-over to 60 Hz and see what happens.

Also, pull out an old trusty SPL meter and play some test tones to ensure you're not running the sub too hot compared to all your other speakers. I mean, it's OK if it's a couple of dB hotter than the rest, but probably not more than that.


I don't have a SPL meter and I don't really want to drive to the shack and pick one up

I am sure I can never get it perfect without one but right now it sounds pretty damn good in my small space. I can make it shake the walls if I want to...but I try to limit the disapproving glances from my wife when possible. I think it is blended in pretty well to my fronts. I changed the front to 60hz crossover and I think that has helped. I will continue to switch it back and forth occasionally to test if I am crazy or there really is a difference.

Thanks for the help.
jdwksu is offline  
post #1018 of 2862 Old 03-06-2010, 01:18 PM
AVS Special Member
 
JChin's Avatar
 
Join Date: Oct 2008
Location: Mesquite Tx
Posts: 8,572
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Liked: 137
Quote:
Originally Posted by jdwksu View Post

I don't have a SPL meter and I don't really want to drive to the shack and pick one up

I am sure I can never get it perfect without one but right now it sounds pretty damn good in my small space. I can make it shake the walls if I want to...but I try to limit the disapproving glances from my wife when possible. I think it is blended in pretty well to my fronts. I changed the front to 60hz crossover and I think that has helped. I will continue to switch it back and forth occasionally to test if I am crazy or there really is a difference.

Thanks for the help.

jdwksu, I heard you can get better bass response by raising the subwoofer, maybe give that a try. There is a product call Gramma and Subdude you can check on.
JChin is offline  
post #1019 of 2862 Old 03-06-2010, 07:41 PM
Newbie
 
jtrane25's Avatar
 
Join Date: Jan 2010
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by bigwheels1 View Post

Ordering an F-12 from BLT gets you a decent price but expect a delay of around 30-days before you receive your F-12.

Current F-12 backorder schedule:
California warehouse: 4/19
Pennsylvania warehouse: 4/11

I ordered mine on 2/10 and just saw the ETA's listed at 4/9 as well. Is this accurate? It's been almost two months. Thinking I might just cancel and get the V1220 from parts express. Anyone have any thoughts on this?
jtrane25 is offline  
post #1020 of 2862 Old 03-06-2010, 07:57 PM
AVS Special Member
 
Jim McC's Avatar
 
Join Date: Feb 2004
Location: Oconomowoc, WI.
Posts: 5,914
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Liked: 33
What's the problem with keeping this in stock? Is it that popular? Is it just BLT?
Jim McC is offline  
Reply Subwoofers, Bass, and Transducers



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off