The Official Artison Support Thread - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 04-01-2009, 03:25 PM - Thread Starter
Member
 
ARTISON's Avatar
 
Join Date: Mar 2009
Location: MINDEN , NV
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello AVS Forum!

This is the Official Support Thread for Artison subwoofers. Please use this thread to ask any questions about our subwoofer products. Cary Christie, the CEO of Artison, and myself will be available to answer your questions.

Cheers,

Matthew LaBruzzo
Manager, Engineering & Customer Service
ARTISON is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-08-2010, 05:24 PM
Member
 
davahad's Avatar
 
Join Date: Nov 2001
Location: San Jose, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
In February 2008 I purchased the RCC 600 Freestanding Sub and for the last month I have had a problem with the Amplifier that is making a loud clicking noise intermittently (like when you turn the Amplifier off and on). I emailed a short video to support and never received a reply. I then called support and left message and received no reply.

Then a day or two later I called back again and spoke to the operator who explained that their tech person was out-of-the-office for the week and she wasn't sure when they could get back to me. A day or so later Mr. Christie called me back and had me try replacing the power cord as well as disconnecting the receiver from the Amp. I did and unfortunately I am still having the clicking noise.

Now a month later the amp is still making the intermittent clicking noise and when I called for support on Wednesday this week I am told everyone is at CES so not sure when anyone can get back to me. I explained to the lady answering the phone I just need an RMA # to return as I had done everything Mr. Christie had suggested and it was still failing. She said she couldn't help and that my messages have been passed on and that I would need to wait for whenever someone could respond.

Unfortunately I paid a lot of money for the Aritson Masterpiece speakers and the RCC 600 Sub and to date the support has been poor at best. For such a supposedly high end product I was expecting better reliability and much better support. In fact, I'm wondering how Artison can afford not to provide support for a week-at-a-time? Maybe they never have problems or they only get back to you when it is convenient for them.

It will be interesting to see how long it takes for someone at Artison to stand behind their product and I will report back here when and if they do.
davahad is offline  
post #3 of 6 Old 01-11-2010, 08:22 PM
Member
 
davahad's Avatar
 
Join Date: Nov 2001
Location: San Jose, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Still no word from support. However did get a call back from operator apologizing for the delay and that to go ahead and ship back but it wouldn't be covered under warranty as the electronics are only covered for 1 year.

Guess the FS600 is going to cost a lot more than the $2,000 + I already paid.
davahad is offline  
post #4 of 6 Old 09-17-2012, 02:39 PM
Member
 
davahad's Avatar
 
Join Date: Nov 2001
Location: San Jose, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Here is an update on the Artison RCC 600 FS Sub Amp popping noise
http://awp1.com/RCC600%20Amplifier%20Popping.mov (Video of Problem)


Jan 2010 - Artison replaces Power Supply Circuit Board out of warranty
$60 - Power Supply PCB
$150 - Labor

October 2011 - Artison Amp popping noise is back again. Artison Amplifier has the same popping noise again.
October 2011 - Artison decides that they want to replace the Amp with a new one.
December 2011 - Finally receive new Artison replacement Amp.
January 2012 - New Problem - Artison RCC 600 will not power off. I unplug from the wall and plug back in and there is a red circle light around the Movie Button and it will no longer power up.
January 2012 - Two Weeks later after reporting this new Artison Amp problem Artison finally contacts me and advises the Amp needs to be returned for reprogramming.
February 2012 - Artison could not reprogram Amp and sends a new replacement that has been burned in for approx 10 hours.
June 2012 - Artison Amp failed again. Tried to turn it on and wouldn't turn on at all. Artison admits that they have been having a higher than normal failure rate and that they are currently redesigning the Amp and expect the new Amp to be out in September 2012 and they will replace with that Amp when available at no cost to me.
June 2012 - Return failed Amp and awaiting the release of the new redesigned AMP (September 2012).
September 7, 2012 - Email Artison for update on replacement Amp.
September 11, 2012 - Artison advises that someone will contact me by 9-14-2012 with an update.
September 17, 2012 - I called Artison today and she apologizes and says she will have someone contact me today with an update as she has no idea on the status.

This has been one of the worst purchases I have ever made at $2,000+ for a subwoofer as it has had nothing but problems.
Also, the sub has barely been used even though now it is 4+ yrs old as it only gets turned on manually when watching a movie or concert video.

My setup is as follows:
Pioneer 50" Plasma
Denon 4308CI
DTV HR-24/500
Artison Masterpiece LCR
Artison RCC600FS
APC S15 Power Conditioner w/Battery Backup
Dedicated 20 AMP Circuit for above equipment. With everything powered up the APC reports 500-600 watts being used.

The Artison Masterpiece LCR's have performed every day for 4 years with no problems and I would recommend their speakers. Unfortunately I would not be
able to recommend their Sub based on the above and the fact that they are replacing the Amp with a redesigned Amp to resolve issues.
davahad is offline  
post #5 of 6 Old 09-18-2012, 12:47 AM
AVS Addicted Member
 
Chu Gai's Avatar
 
Join Date: Sep 2002
Location: NYC area
Posts: 14,685
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 379
In view of their comments regarding the questionable quality of their sub amps, they should refund the monies spent earlier - $210 - in addition to absorbing any shipping costs you've incurred.

"I've found that when you want to know the truth about someone that someone is probably the last person you should ask." - Gregory House
Chu Gai is online now  
post #6 of 6 Old 09-20-2012, 08:12 PM
Member
 
davahad's Avatar
 
Join Date: Nov 2001
Location: San Jose, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Here's a final update.....

After contacting Artison several times from Sept 7th to Sept 17th I never received a response on the status of the replacement Sub Amp that was supposed to be out in September 2012.
I can only guess that there isn't a replacement sub coming from Artison anytime soon. If there was you would think they would have thought to reply to one of my emails or phone calls
regarding the status during those 10 days from Sept 7th - Sept 17th.

However, after my post on this forum on 9/17/2012 documenting the history of my Artison Sub I did get a phone call from someone whom I would guess is one of the owner's of the company.
Instead of a status update that I had been trying to get for 10 days, she seemed very upset about my post on AVS Forum and implied that I was the only one that was having these issues.
Funny, I told her, because I personally spoke on the phone with both Matthew LaBruzzo and Cary Christie during June 2012 and both said
that the Sub Amp has known probs and that they would have a new improved version out in September 2012 that would take care of the issues I was seeing.

Anyways, she wasn't interested in hearing this and then proceeded to offer me a refund for the purchase price (refund not including the repairs I paid for) to which I agreed.
Again, my guess would be that Artison isn't close to having a replacement amp and thus the reason for the refund.

Hopefully one day Artison's Sub Amp will be as good as Artison's Speakers.
davahad is offline  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off