Is my sub, sub-par. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 7 Old 07-04-2009, 11:33 PM - Thread Starter
Member
 
offgasser's Avatar
 
Join Date: Jan 2009
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a JBL PSW1200. My father gave me his, which had a blown amp, and JBL replaced it for a reasonable price. I am using a speaker setup which requires a sub.

Room: 16'Wx7.5'H the room is 13' deep but the back wall is open to another room. The rear speakers will be about 16' from the front wall.

I listen to music at a fairly loud level when my wife is not grabbing the remote and use this setup for HT also. I would say 60% HT 40% music.

I am more concerned with performance than cabinet size.

The JBL specs say: Freq. response is 23Hz to(90-150Hz)

My question is this, Is this sub adequate for the room, listening demands etc. If it is crap, tell me, I can take it. Also which is the best way to wire it, I have a current model Denon receiver.

Thanks

Tom
offgasser is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-04-2009, 11:44 PM
Advanced Member
 
_Noah_'s Avatar
 
Join Date: Jan 2007
Location: Auburn Hills, MI
Posts: 525
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It's a decent sub, but probably inadequate for 99% of people active on this forum. What do you think about it though? Does it sound good and is it loud enough for you? That's what really matters. As with most hobbies, you can always upgrade to something bigger and better if you're willing to part with the cash.
_Noah_ is offline  
post #3 of 7 Old 07-05-2009, 12:05 AM - Thread Starter
Member
 
offgasser's Avatar
 
Join Date: Jan 2009
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yeah I know what you mean. I look at upgrading while I'm waiting for the UPS truck to deliver my last upgrade.

The sub is loud enough that I have turned it down. I really don't understand how to set it up correctly because Denon and JBL apparently use different lingo and assume I know something.

Tom

BTW unless I heard a great sounding sub in my house I don't know if I can tell how good this sounds. I know I would like to have music as close to real as possible and movies as close to theater.
offgasser is offline  
post #4 of 7 Old 07-05-2009, 07:01 PM
AVS Special Member
 
ransac's Avatar
 
Join Date: Feb 2006
Location: Tryon, NC
Posts: 4,599
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 26
I had the PSW-1200 as my first sub. Bought it in the mid 90s for about $350. 12" driver with 120Watt amp and a single 3" (IIRC) port in a small box (compared to some subs of today).

It was really good to begin with, but it was my first sub. I had little to compare it to. When I upgraded in 2006, I expected to pay $500 but wound up buying a sub that cost $1,400. I just couldn't find anything in the stores that were better than the PSW-1200 in the $500 range. To make this short, my new sub made the JBL seem such a weak performer that I never regretted replacing it or paying as much as I did to replace it. I gave it to my neighbor as I no longer had a use for it. If you can get a good sub, you will know what I speak of as the impact, clean volume, overall sound quality of better, but more expensive, subs will impress you.

As far as setting it up, on the JBL put the phase switch to 0, the gain to around the 10:00 position, and the crossover to max. Then follow the Denon instructions to complete the set up.

Randy
ransac is offline  
post #5 of 7 Old 07-05-2009, 07:32 PM - Thread Starter
Member
 
offgasser's Avatar
 
Join Date: Jan 2009
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks Randy. The Denon set the crossover on the fronts at 80Hz so I set the sub at that but I don't know if that is correct. I just assumed it would pick up where they left off. I switched the phase to 0 like you said. The volume is at about 12:00 and that is loud enough and not boomy. There is no "gain" control on it. It sounds good to me so maybe it's money in the bank not to demo anything else. I am curious to know what you would think about this sub now, being a 2009 model. The changes in it may just be cosmetic but I don't know. Your specs are accurate as compared to the manual.

Thanks

Tom
offgasser is offline  
post #6 of 7 Old 07-05-2009, 08:06 PM
AVS Special Member
 
ransac's Avatar
 
Join Date: Feb 2006
Location: Tryon, NC
Posts: 4,599
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 26
Quote:
Originally Posted by offgasser View Post

Thanks Randy. The Denon set the crossover on the fronts at 80Hz so I set the sub at that but I don't know if that is correct. I just assumed it would pick up where they left off. I switched the phase to 0 like you said. The volume is at about 12:00 and that is loud enough and not boomy. There is no "gain" control on it. It sounds good to me so maybe it's money in the bank not to demo anything else. I am curious to know what you would think about this sub now, being a 2009 model. The changes in it may just be cosmetic but I don't know. Your specs are accurate as compared to the manual.

Thanks

Tom

Turn the crossover on the sub to max. Let the Denon handle the crossover. If you have surround speakers and a center channel, the Denon should have set them to 80 as well.

Volume and gain are the same thing.

I haven't seen nor heard the latest version. I would hope they have made improvements in the amp and driver in 10+ years.

If you don't know what your missing, you won't miss it. Ignorance is bliss and it's free.

Randy
ransac is offline  
post #7 of 7 Old 07-05-2009, 08:12 PM - Thread Starter
Member
 
offgasser's Avatar
 
Join Date: Jan 2009
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
10/4
offgasser is offline  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off