Need help diagnosing/repairing Eosone 910 sub - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 07-09-2009, 07:35 PM - Thread Starter
Member
 
dlp3719's Avatar
 
Join Date: Jan 2005
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So my FIL had a Eosone RSP910 Subwoofer sitting in his garage that he gave me. Said it worked fine 2 years ago. I thought I would add a second sub to my HT for fun.

First, I unplugged my Infinity sub and plugged in the new Eosone. NOTHING. The standby light is red. It seems to have power but I can not get it to make ANY sound (crackles, hums, nothing). Tried both RCA jacks and a Y splitter into both.

Of course, I am having a tough time finding ANY manuals online. Does anyone have an owner's manual for this thing? I would like to check the fuses if there are any. Cosmetically the sub looks in great shape.
dlp3719 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-10-2009, 03:35 AM
Member
 
jac86's Avatar
 
Join Date: Jul 2009
Location: VA, USA
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I'm not that good in this area, but, bad fuse or blown capacitor. Or water damage from humidity. Open it up if you can and look for anything odd.

Where did all my money go?
jac86 is offline  
post #3 of 5 Old 07-10-2009, 06:15 AM - Thread Starter
Member
 
dlp3719's Avatar
 
Join Date: Jan 2005
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Plan to open it up this weekend.

He didn't have the power cord for it. Volts on the sub says 115V. I found a Max 125V power cord that fit it. I assume this is ok?
dlp3719 is offline  
post #4 of 5 Old 07-10-2009, 06:23 AM
Member
 
jac86's Avatar
 
Join Date: Jul 2009
Location: VA, USA
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yes. No problems there.

Could also be the plate amp?

Where did all my money go?
jac86 is offline  
post #5 of 5 Old 07-10-2009, 06:37 AM - Thread Starter
Member
 
dlp3719's Avatar
 
Join Date: Jan 2005
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I called Polk Audio. They were helpful. They suggested I pull the speaker and test it first with direct connection. If it's bad a guy is liquidating Eosone parts on ebay.
dlp3719 is offline  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off