MFW-15 w/ new July 2009 amps <absolutely NO AV123 or MLS bashing/negativity!!> - Page 3 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #61 of 2801 Old 07-15-2009, 08:44 AM
Member
 
CaseyGT's Avatar
 
Join Date: Aug 2005
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
the amp in my MFW-15 died last weekend. I talked to MLS on Monday and he said 2-3 weeks for more amp replacements.

I got my ELT525 5.0 setup running for the time being. I can't wait to get my amp back!
CaseyGT is offline  
Sponsored Links
Advertisement
 
post #62 of 2801 Old 07-15-2009, 08:56 AM
Senior Member
 
StimpsonJCat's Avatar
 
Join Date: May 2002
Location: Texas
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Anyone get a tracking number for a new sub order?
StimpsonJCat is offline  
post #63 of 2801 Old 07-15-2009, 09:26 AM
Member
 
busahaya's Avatar
 
Join Date: Apr 2007
Location: South Central Los Angeles
Posts: 166
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the info KH

PSN: BusaHaya03

http://*******.com
busahaya is offline  
post #64 of 2801 Old 07-15-2009, 09:42 AM
AVS Special Member
 
spyboy's Avatar
 
Join Date: Feb 2002
Posts: 7,089
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 41
You guys are so beaten down by all the waiting you don't even mind having to buy fans to cool your problem free new amps.
spyboy is offline  
post #65 of 2801 Old 07-15-2009, 09:44 AM
AVS Addicted Member
 
Chu Gai's Avatar
 
Join Date: Sep 2002
Location: NYC area
Posts: 14,756
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 146 Post(s)
Liked: 441
Out of curiousity, are the old amps being sent back and if so, at whose expense?

"I've found that when you want to know the truth about someone that someone is probably the last person you should ask." - Gregory House
Chu Gai is offline  
post #66 of 2801 Old 07-15-2009, 09:44 AM
AVS Special Member
 
KlipschHead281's Avatar
 
Join Date: Feb 2009
Posts: 1,040
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by spyboy View Post

You guys are so beaten down by all the waiting you don't even mind having to buy fans to cool your problem free new amps.

You seek out ways to be negative don't you. My new one doesn't run hot, it runs warm, my Klipsch KSW-300 runs warmer, lets start a thread bashing Klipsch now because I bought a fan for that one too.

Good grief man.


EDIT: Just checked my Dayton sub amp, that thing is HOT, lets start a bashing Dayton amplifiers thread Spyboy! Woohoo we'll get all them suckers who bought fans to cool down their POS sub amps! Wait, my Samsung Plasma TV is hotter than hell, lets bash that too!

I contend that for a nation to try to tax itself into prosperity is like a man standing in a bucket and trying to lift himself up by the handle. -- Winston Churchill
KlipschHead281 is offline  
post #67 of 2801 Old 07-15-2009, 09:47 AM
AVS Special Member
 
KlipschHead281's Avatar
 
Join Date: Feb 2009
Posts: 1,040
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by Chu Gai View Post

Out of curiousity, are the old amps being sent back and if so, at whose expense?

The note included with mine states to discard them, I wouldn't mind buying the parts needed to bring the old ones to new specs so I have backups for the future, I can't see a reason to toss them.

I contend that for a nation to try to tax itself into prosperity is like a man standing in a bucket and trying to lift himself up by the handle. -- Winston Churchill
KlipschHead281 is offline  
post #68 of 2801 Old 07-15-2009, 10:20 AM
AVS Special Member
 
graphicguy's Avatar
 
Join Date: Jun 2002
Location: Ohio Valley
Posts: 3,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
Quote:
Originally Posted by KlipschHead281 View Post

The note included with mine states to discard them, I wouldn't mind buying the parts needed to bring the old ones to new specs so I have backups for the future, I can't see a reason to toss them.

KH....considering how handy you've been, I'd be interested in seeing if you could bring them back to life, and what you did to accomplish that.

As far as amps, they're going to give off heat. Someone earlier mentioned that the MFW amps measured 115 degrees. Not unusual for amps, of any sort....and about 6-7 degrees warmer than a healthy person's temperature.

I thought this thread was supposed to be devoid of those types of posts.

In all frankness spyboy....I have yet to see any of your posts that have added anything remotely useful to these threads. It's clear you do not own, never have owned, any piece of AV123 gear. So, do you have anything....anything at all worthwhile to add?

Music so high you can't get over it....music so low you can't get under it!
graphicguy is offline  
post #69 of 2801 Old 07-15-2009, 10:37 AM
AVS Special Member
 
jephdood's Avatar
 
Join Date: Feb 2004
Location: Auburn, WA
Posts: 1,124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 47
Quote:
Originally Posted by graphicguy View Post

As far as amps, they're going to give off heat. Someone earlier mentioned that the MFW amps measured 115 degrees. Not unusual for amps, of any sort....and about 6-7 degrees warmer than a healthy person's temperature.

Only if this healthy person was on fire and recently extinguished..
jephdood is offline  
post #70 of 2801 Old 07-15-2009, 10:39 AM
AVS Special Member
 
KlipschHead281's Avatar
 
Join Date: Feb 2009
Posts: 1,040
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by graphicguy View Post

KH....considering how handy you've been, I'd be interested in seeing if you could bring them back to life, and what you did to accomplish that.

The one that died didn't really die, one of the cables came off of the amplifier module. I assumed it died simply because others have died so when it stopped I made an assumption. While working on my replacement I decided to crack that one open too. I plugged it back in and reseated the other cables as well and then fired it back up and it worked fine except for the over-heating issue when pushing it hard.

If no other part is replaced on these amps then tossing them to me is a waste of money, all that should be needed is the new module and I have offered to buy one of these modules to try it out when they have enough in stock to sell one, if they don't want to sell one then not sure what to do with it, I just can't bring myself to throw it away.

Quote:


As far as amps, they're going to give off heat. Someone earlier mentioned that the MFW amps measured 115 degrees. Not unusual for amps, of any sort....and about 6-7 degrees warmer than a healthy person's temperature.

I'm an anti-heat freak with my electronics, keep it cool and it lasts longer so whats warmer than normal for me might be very acceptable to others.

I contend that for a nation to try to tax itself into prosperity is like a man standing in a bucket and trying to lift himself up by the handle. -- Winston Churchill
KlipschHead281 is offline  
post #71 of 2801 Old 07-15-2009, 11:37 AM
Senior Member
 
StimpsonJCat's Avatar
 
Join Date: May 2002
Location: Texas
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by spyboy View Post

You guys are so beaten down by all the waiting you don't even mind having to buy fans to cool your problem free new amps.

This bold statement is true.
StimpsonJCat is offline  
post #72 of 2801 Old 07-15-2009, 12:02 PM
Senior Member
 
Jed M's Avatar
 
Join Date: Sep 2002
Posts: 382
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by StimpsonJCat View Post

I'm going to speculate you are not receiving a warranty replacement amp or getting a new MFW-15. I don't have any facts on this, but I'm guessing this is the case. Maybe there would be some facts on the AV123 forums about this, but they are closed. Did you know that?

The bold part is correct for some of the people in this threads view of defending all things Mark and AV123.

I hope this doesn't come off as negative but I figured you wouldn't have a problem with this type of posting since you did it yourself.
Jed M is offline  
post #73 of 2801 Old 07-15-2009, 12:14 PM
Senior Member
 
StimpsonJCat's Avatar
 
Join Date: May 2002
Location: Texas
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Jed M View Post

The bold part is correct in your view of defending all things Mark and AV123.

I hope this doesn't come off as negative but I figured you wouldn't have a problem with this type of posting since you did it yourself.

I've never defended Mark or AV123....ever. But nice job with the bolding.
StimpsonJCat is offline  
post #74 of 2801 Old 07-15-2009, 12:29 PM
Senior Member
 
Jed M's Avatar
 
Join Date: Sep 2002
Posts: 382
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by StimpsonJCat View Post

I've never defended Mark or AV123....ever. But nice job with the bolding.

I know I was just pointing out the "no negativity" clause seems to be a one way street. Sorry, back to your scheduled love in. And thanks for the compliment. My first bold came out kind of messed up because I initially put the [b] in front of the quote so it split the entire message. Preview post is a life saver sometimes.

Edit: Wayne, since I do feel badly about castigating you off as a fanboy (I was honestly just using one of your posts just to show the hypocrisy of the no negativity clause), I will edit my first post to more accurately reflect reality, but hopefully my point is the same. Enjoy your MFW-15.

And for the record, I installed my parent's replacement amp and the fit is snug and honestly I tried but there is no way to get it to sit completely flush. It seems air tight and I don't notice any leaking so it seems fine, just the bottom part sticks out a teeny bit. Honestly, that is not trying to be negative, just what is. It works so that much I am glad for. So to be really, really positive I will say I am really glad that I only have 1 thing left owed to me from AV123.
Jed M is offline  
post #75 of 2801 Old 07-15-2009, 12:40 PM
Senior Member
 
StimpsonJCat's Avatar
 
Join Date: May 2002
Location: Texas
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Jed M View Post

I know I was just pointing out the "no negativity" clause seems to be a one way street. Sorry, back to your scheduled love in. And thanks for the compliment. My first bold came out kind of messed up because I initially put the [b] in front of the quote so it split the entire message. Preview post is a life saver sometimes.

You are right. Being negative about people coming to a "no negativity" thread and posting negative comments is a negative thing.

I'm gonna speculate on the OP's original idea behind this thread and say that it is more of a place for actual MFW-15 owners (past ones getting the replacement amps and new ones getting new subs with the new amp) to discuss things. Just a guess though...it may have been a big "love in" to sing praises for MLS and AV123. Nope, I think it was the first one.

My ONLY experience with AV123 is ordering a MFW-15 in late may and getting updates on its status from AV123 folk. I have no experience with MLS. I do feel sorry for those screwed over in one way or another by MLS and/or AV123. I just don't want to hear it over and over again through long drawn out diatribes or even little jabs in every freaking MFW015 thread. Why? Because I have ordered a MFW-15 and would like to read some reports about the new amp and hear updates from others who have ordered subs without all the BS. Is this really too much to ask?
StimpsonJCat is offline  
post #76 of 2801 Old 07-15-2009, 12:43 PM
Senior Member
 
seagul's Avatar
 
Join Date: Feb 2007
Posts: 283
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey sorry to interrupt your argument but I just got off the phone with Kyle and he said that they will be letting people know the status of the Hotrod by the end of the week. He says they are close but I don't know if that's my version of close or Av123's version of close. Kind of like how they were close to opening up the forum four weeks ago.
seagul is offline  
post #77 of 2801 Old 07-15-2009, 12:54 PM
Senior Member
 
StimpsonJCat's Avatar
 
Join Date: May 2002
Location: Texas
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Jed M View Post

Edit: Wayne, since I do feel badly about castigating you off as a fanboy (I was honestly just using one of your posts just to show the hypocrisy of the no negativity clause), I will edit my first post to more accurately reflect reality, but hopefully my point is the same. Enjoy your MFW-15.

And for the record, I installed my parent's replacement amp and the fit is snug and honestly I tried but there is no way to get it to sit completely flush. It seems air tight and I don't notice any leaking so it seems fine, just the bottom part sticks out a teeny bit. Honestly, that is not trying to be negative, just what is. It works so that much I am glad for. So to be really, really positive I will say I am really glad that I only have 1 thing left owed to me from AV123.

Hey, thats good news about getting your parent's sub back up and running. Bummer it won't fit flush. I don't find issues with the new amps (even if it is somewhat less important stuff like the amp fitting flush) from MFW-15 owners negative. I want to hear little details of things (positive and negative) about the new amp (or the sub itself) from true owners. I hope you get whatever else AV123 owes you soon.
StimpsonJCat is offline  
post #78 of 2801 Old 07-15-2009, 12:55 PM
Senior Member
 
Jed M's Avatar
 
Join Date: Sep 2002
Posts: 382
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by StimpsonJCat View Post

Because I have ordered a MFW-15 and would like to read some reports about the new amp and hear updates from others who have ordered subs without all the BS. Is this really too much to ask?

In all seriousness, and I know you don't want to go there in this thread, but the reality is we are dealing with a company that has admitted to defrauding its customers on two occasions, and more that they haven't yet admitted to for tens of thousands, possibly hundreds of thousands of dollars, so I would say that, yes, you are asking too much. More especially when you knew going in you were dealing with a company that many of its most loyal customers felt like the company had stolen from them. I will stay out of this thread, but considering the nature of what they have committed against their friends I will predict there is no way this isn't going to follow Mark and AV123 for the rest of their existence, however long that will be. Sorry for the cold dose of reality.
Jed M is offline  
post #79 of 2801 Old 07-15-2009, 01:05 PM
Senior Member
 
StimpsonJCat's Avatar
 
Join Date: May 2002
Location: Texas
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Jed M View Post

In all seriousness, and I know you don't want to go there in this thread, but the reality is we are dealing with a company that has admitted to defrauding its customers on two occasions, and more that they haven't yet admitted to for tens of thousands, possibly hundreds of thousands of dollars, so I would say that, yes, you are asking too much. More especially when you knew going in you were dealing with a company that many of its most loyal customers felt like the company had stolen from them. I will stay out of this thread, but considering the nature of what they have committed against their friends I will predict there is no way this isn't going to follow Mark and AV123 for the rest of their existence, however long that will be. Sorry for the cold dose of reality.

This is probably true. I guess a company that lives by the NET can die by the NET. But to be honest I just care that I get my sub and it works (and if it dies the company is still around to fix it). I do feel for those screwed over, but anyone giving a large amount of money with no actual product in stock (this is specific to those who put money down on the LS speakers) took the risk of waiting for a product that may never come. The only reason I ordered the MFW-15 now is they were not going to charge me until it shipped.

If those who have a dog in this fight feel the need to discuss it in every single AV123 thread then who can stop them. I probably wouldn't even care. But, I get the feeling most of the AV123 thread trolls haven't ever ordered or owned a single AV123 product. I guess I feel it is my duty as a sarcastic bastard to give them a hard time for being such tools.
StimpsonJCat is offline  
post #80 of 2801 Old 07-15-2009, 01:13 PM
 
crOwcaine's Avatar
 
Join Date: Mar 2007
Posts: 554
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Jed M View Post

In all seriousness, and I know you don't want to go there in this thread, but the reality is we are dealing with a company that has admitted to defrauding its customers on two occasions, and more that they haven't yet admitted to for tens of thousands, possibly hundreds of thousands of dollars, so I would say that, yes, you are asking too much. More especially when you knew going in you were dealing with a company that many of its most loyal customers felt like the company had stolen from them. I will stay out of this thread, but considering the nature of what they have committed against their friends I will predict there is no way this isn't going to follow Mark and AV123 for the rest of their existence, however long that will be. Sorry for the cold dose of reality.

Another satisfied customer. It's great to hear that you got your replacement amps up and running and enjoying your HT again. Good for you man, good for you. I can't wait for my Diamond black to arrive. What finish is yours again?
crOwcaine is offline  
post #81 of 2801 Old 07-15-2009, 01:20 PM
Member
 
DaveNagy's Avatar
 
Join Date: Aug 2000
Location: Canton, GA USA
Posts: 147
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
This forum's 'Ignore' feature works quite well. Just saying...

Has anyone received a new MFW-15 yet? I'm anxiously awaiting my rosewood B-stock.
DaveNagy is offline  
post #82 of 2801 Old 07-15-2009, 01:30 PM
 
crOwcaine's Avatar
 
Join Date: Mar 2007
Posts: 554
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Seagul, I have dual Palisander Rosa Diamonds up front and they are stunning. I got the Diamond Black for the back wall and from what I've seen they are beauties. Oh and I heard from Kyle that he was hoping to start sending out ship alerts by the 17th for new MFW's orders. With an original ETA of June 30th I consider by the end of July a success for AV123.
crOwcaine is offline  
post #83 of 2801 Old 07-15-2009, 01:33 PM
Senior Member
 
StimpsonJCat's Avatar
 
Join Date: May 2002
Location: Texas
Posts: 375
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by DaveNagy View Post

This forum's 'Ignore' feature works quite well. Just saying...

Has anyone received a new MFW-15 yet? I'm anxiously awaiting my rosewood B-stock.

I don't know if it was B-stock or not, but Cory made it sound like some Rosewoods would be some of the first new orders to go out last time I talked with him.
StimpsonJCat is offline  
post #84 of 2801 Old 07-15-2009, 01:54 PM
AVS Special Member
 
KlipschHead281's Avatar
 
Join Date: Feb 2009
Posts: 1,040
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by DaveNagy View Post

This forum's 'Ignore' feature works quite well. Just saying...

Has anyone received a new MFW-15 yet? I'm anxiously awaiting my rosewood B-stock.

Post a picture of that thing when you get it, Rosewood is the nicest of the veneers.

I contend that for a nation to try to tax itself into prosperity is like a man standing in a bucket and trying to lift himself up by the handle. -- Winston Churchill
KlipschHead281 is offline  
post #85 of 2801 Old 07-15-2009, 02:11 PM
AVS Special Member
 
Snowmanick's Avatar
 
Join Date: Nov 2007
Posts: 1,561
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 119
Quote:
Originally Posted by KlipschHead281 View Post

Post a picture of that thing when you get it, Rosewood is the nicest of the veneers.

Yes it is, and I am selling mine if anyone is interested. I have a brand new one, unopened, that I picked up from A V123 yesterday. If interested I have a listing on A V123's website and TCA.

~Nick

 

Augustine's Law: "The last 10% of performance generates one-third of the cost and two-thirds of the problems."

Snowmanick is offline  
post #86 of 2801 Old 07-15-2009, 03:47 PM
Senior Member
 
bmrowe's Avatar
 
Join Date: Jan 2006
Posts: 465
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Just received my new MFW-15, with a very nice card. Got it up and running and I am noticing some hum. The hum occurs only when the subwoofer input cable is connected -- and it increases as I increase gain on the sub. Ideas? This isn't a ground loop problem right? I assumed ground loop problems could be heard even without an input cable connected.


Edit -- I think I've found the culprit. If I pull the HDMI from the DirecTv box out of my receiver, the humming is cut down by 90%. What is the best way to resolve this?
Thanks.
bmrowe is offline  
post #87 of 2801 Old 07-15-2009, 04:11 PM
AVS Special Member
 
KlipschHead281's Avatar
 
Join Date: Feb 2009
Posts: 1,040
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by bmrowe View Post

Just received my new MFW-15, with a very nice card. Got it up and running and I am noticing some hum. The hum occurs only when the subwoofer input cable is connected -- and it increases as I increase gain on the sub. Ideas? This isn't a ground loop problem right? I assumed ground loop problems could be heard even without an input cable connected.


Edit -- I think I've found the culprit. If I pull the HDMI from the DirecTv box out of my receiver, the humming is cut down by 90%. What is the best way to resolve this?
Thanks.

Keep it unplugged.... Just kidding!

Check the ground for the Dish, I have never used a Dish but imagine they require proper grounding like anything else. Unplug the feed cable from the back of the DirecTV box and see if it goes away completely. Is there another cable coming from the Dish box to the AVR?

I contend that for a nation to try to tax itself into prosperity is like a man standing in a bucket and trying to lift himself up by the handle. -- Winston Churchill
KlipschHead281 is offline  
post #88 of 2801 Old 07-15-2009, 04:41 PM
AVS Special Member
 
Snowmanick's Avatar
 
Join Date: Nov 2007
Posts: 1,561
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 119
Quote:
Originally Posted by bmrowe View Post

Just received my new MFW-15, with a very nice card. Got it up and running and I am noticing some hum. The hum occurs only when the subwoofer input cable is connected -- and it increases as I increase gain on the sub. Ideas? This isn't a ground loop problem right? I assumed ground loop problems could be heard even without an input cable connected.


Edit -- I think I've found the culprit. If I pull the HDMI from the DirecTv box out of my receiver, the humming is cut down by 90%. What is the best way to resolve this?
Thanks.

Doesn't hurt to try a cheater plug just to verify, the things cost about 50 cents. At the very least it can help to start eliminating possibilities.

~Nick

 

Augustine's Law: "The last 10% of performance generates one-third of the cost and two-thirds of the problems."

Snowmanick is offline  
post #89 of 2801 Old 07-15-2009, 05:24 PM
AVS Addicted Member
 
Chu Gai's Avatar
 
Join Date: Sep 2002
Location: NYC area
Posts: 14,756
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 146 Post(s)
Liked: 441
Sounds like the ground from your satellite dish doesn't tie in to the grounding rod outside your home. Hence, ground loops. If you can't get them to do it right, you need a ground loop isolator that's suitable for satellite. For example this product on ebay is capable of passing signals from 5-2400 MHz. However there's no returns on this one. I'd check with DirectTV to see what frequencies they're running.
So anyways, you see what they look like and you can scout around the web (Ram Electronics, Parts Express, Calrad, etc.) to see if anyone is carrying something similar with a better return policy. Your local Radio Shack may even have something and they're great on returns. Products from Jensen are also highly regarded but they're pricey.

"I've found that when you want to know the truth about someone that someone is probably the last person you should ask." - Gregory House
Chu Gai is offline  
post #90 of 2801 Old 07-15-2009, 06:00 PM
Member
 
alages's Avatar
 
Join Date: Nov 2008
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by seagul View Post

.... I don't know if that's my version of close or Av123's version of close. Kind of like how they were close to opening up the forum four weeks ago.

The AV123 Forums are still closed? Wow! How long has it been? I wonder what the problem could be.
alages is offline  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off