MFW-15 w/ new July 2009 amps <absolutely NO AV123 or MLS bashing/negativity!!> - Page 94 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #2791 of 2801 Old 08-22-2010, 07:23 PM
Advanced Member
 
dasanii19's Avatar
 
Join Date: Sep 2006
Posts: 851
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 19
August 16, 2010

Dear Friends:

It is with profound sadness that we are announcing the closing of AV123/Perpetual Technologies effective today.

We join in sending all of you our sincerest thanks and deepest appreciation for your support through these last 11+ years. Our history is rich with wonderful products and happy moments, all in the name of making great music affordable for all of you.

Sadly, recent events have cast a very unfavorable light on AV123 and have effectively sealed our collective fate. We hope that over time, we will be able to offer more information.

No amount of thanks on our part would ever be adequate enough in exchange for your past support.

Shortly we hope to be able to offer you more information about how to obtain MFW15 amplifiers should you require one. Please stay tuned to this page for updates. We hope to have this in place within the next few weeks.

In the meantime while we orderly wind down our business - allow us to once again thank you for your patronage and support through all of the times both good and bad.

Respectfully yours,

The Team at AV123

MY NAME IS SUE!!! HOW DO YOU DO!!!

"I started out with nothing, and I still have most of it."
dasanii19 is offline  
Sponsored Links
Advertisement
 
post #2792 of 2801 Old 08-22-2010, 08:47 PM
Senior Member
 
jarablue's Avatar
 
Join Date: Dec 2007
Posts: 259
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well. There goes my warranty.
jarablue is offline  
post #2793 of 2801 Old 08-22-2010, 09:19 PM
AVS Special Member
 
Pure-Evil's Avatar
 
Join Date: Jul 2002
Location: Windsor, Ontario, Canada
Posts: 3,804
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 139
Quote:
Originally Posted by jarablue View Post

Well. There goes my warranty.

Lol you thought otherwise?
Pure-Evil is offline  
post #2794 of 2801 Old 08-22-2010, 09:22 PM
AVS Special Member
 
monomer's Avatar
 
Join Date: Apr 2002
Location: up north
Posts: 1,767
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Hey now remember the instructions in the title of this thread..."absolutely NO AV123 or MLS bashing/negativity!!"
Guess that means this thread is finally dead! Hah! 'bout time.

"For deep bass, the listener is not really listening to the speaker, but rather, is listening to the room as it is being played by the speaker."
Juicy
Doggie Jabber
monomer is offline  
post #2795 of 2801 Old 08-23-2010, 07:13 AM
AVS Special Member
 
gonk's Avatar
 
Join Date: Apr 2004
Location: Memphis, TN
Posts: 3,308
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It didn't occur to me until just today, as I've noticed more and more folks showing up in forums saying that they'd gone to AV123's site to look for help and found them closed, but after a year and a half of firing off a steady stream of sales emails they neglected to send an email announcing their closure. They had the letter written - it's on both the web site and the forum - but unless you go to the site you'll never see it...

gonk
Beta tester: BDP-83 / BDP-80
gonk is offline  
post #2796 of 2801 Old 08-23-2010, 04:41 PM
AVS Addicted Member
 
cschang's Avatar
 
Join Date: Mar 2003
Location: Manhattan Beach, CA
Posts: 14,730
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 70
If you need a spare driver for your MFW....
http://www.audiocircle.com/index.php?topic=84989.0

-curtis

Owner of Wave Crest Audio
Volunteer Mod at the Ascend Acoustics Forum
Like all things on the Internet, do your research, as forums have a good amount of misinformation.
Help beat breast cancer!

cschang is offline  
post #2797 of 2801 Old 10-15-2010, 05:50 PM
Senior Member
 
bmrowe's Avatar
 
Join Date: Jan 2006
Posts: 465
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So today I noticed that my dual mfw setup sounded kinda weak on Iron Man 2. I investigated to find out that my 2nd MFW is showing a green light when it receives signal, but makes zero sound. I tried swapping cables etc, to no avail.

I remember reading people posting about having a situation like this when they first received their new amps, and they had to some resoldering while talking to Kyle on the phone. Does anyone have images or some type of instructions to follow if I want to try this? The fact that the sub knows that it is receiving signal, and the amp gets warm, but no sound comes out -- makes me think of a loose cable or something inside. Another option would be if I took it apart, is there some type of diagram to match it up to? I could also take a few pictures of the amp and post them on here, and maybe people would be able to advise me then?

Thanks!
bmrowe is offline  
post #2798 of 2801 Old 10-16-2010, 12:36 PM
Senior Member
 
MTAtech's Avatar
 
Join Date: Nov 2006
Posts: 227
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Today I noticed mine giving a hum.

Regarding the closing of AV123, maybe it had something to do with AV123's owner, Mark L. Schifter, pleading guilty to charity fraud earlier this year.

Can't say that I'm surprised, I offered to write the manual for the MFW and Mark Schifter accepted my offer and we agreed on a price, but after I spent lots of time on the project, Schifter reneged and I never saw a dime. Kind of just deserts if you ask me but I feel bad for the customers he's shafting.
MTAtech is offline  
post #2799 of 2801 Old 04-04-2012, 01:23 PM
Newbie
 
USlivingCanuck's Avatar
 
Join Date: Aug 2010
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by deepstang View Post

Ok audio people....I am tired of reading multiple threads on the new amps for the MFW-15 and or the MFW-15s sold with the new amps. I am even more tired of people ranting and cursing AV123 and de-railing EVERY thread that has anything to do with an AV123 product.
I want this thread to be ONLY for people that have received the new MFW amps that were to ship at the end of June 09, or for those that bought a new MFW-15 that have these newer amps installed.

Thank you! I also have no axe to grind with AV123... I had nothing but excellent service from them.

I have however had the curse of the MFW15 amp problem. Which I was warned about by Kyle at AV123 back in 2009. He said that a part of the amp was not properly made in China and that was the driving (excuse the pun) factor to them moving manufacturing back to the USA.

Anyways, I could take the hour or two and read through this whole forum to find the answer... but I don't have the time. Could someone point me in the direction of a replacement amp. A link for the love of God, a link!

USlivingCanuck is offline  
post #2800 of 2801 Old 04-04-2012, 02:01 PM
AVS Special Member
 
HuskerHarley's Avatar
 
Join Date: Aug 2001
Location: Lincoln,Neb
Posts: 1,461
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by USlivingCanuck View Post

Thank you! I also have no axe to grind with AV123... I had nothing but excellent service from them.

I have however had the curse of the MFW15 amp problem. Which I was warned about by Kyle at AV123 back in 2009. He said that a part of the amp was not properly made in China and that was the driving (excuse the pun) factor to them moving manufacturing back to the USA.

Anyways, I could take the hour or two and read through this whole forum to find the answer... but I don't have the time. Could someone point me in the direction of a replacement amp. A link for the love of God, a link!

V3's are sold out ,but you may find a solution.

MFW-15 V3
HuskerHarley is offline  
post #2801 of 2801 Old 04-04-2012, 02:22 PM
Senior Member
 
murrel's Avatar
 
Join Date: Aug 2009
Location: Longmont, Colorado
Posts: 399
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
USlivingCanuck

HH is correct. I do not plan on building anymore V3 amps. Some of the parts needed for the build are just to expensive to buy in small quantities.

You are more than welcome to contact me if you like.

simplysound@msn.com or search around and I am sure you can find my web site where you will find my number.

Murrel

Murrel J Gray
 

murrel is offline  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off