Need help repairing TSS-1100 Amp board - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 08-16-2011, 05:58 AM - Thread Starter
Newbie
 
phaze82's Avatar
 
Join Date: Feb 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have an infinity TSS-1100 subwoofer that the amp has started to fry and is almost dead. This is apparently pretty common and is the 2nd time it has happened to my sub. The first time I got it repaired under warranty. However it is now long out of warranty.

Basically the board is getting pretty burnt in a particular spot and the capacitor around that area is starting to bulge. My soldering skills are decent and I want to repair it myself rather than have to pay the repair shop $300 to fix it they quoted me.

I could probably just replace the parts that are the problem with identical ones but I'd rather repair this properly since it seems this is some sort of design flaw. I'm hoping someone can give me advice on the proper components to replace with so this won't happen again.

I've ordered a new sub to replace this one but I'd like to get this fixed as a spare or to use in another room. Can anyone help out here?
phaze82 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-23-2011, 08:50 AM
Newbie
 
JerqFase's Avatar
 
Join Date: Aug 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just picked one of these up for free and I am going to call and yell at Infinity to try and get a free replacement, but this is what infinity wants people to do to fix the problem for good.

harmanserviceforums. yuku. com/reply/954/ts1100-fix#reply-954

Remove the spaces in link above. Can't post URLs because this is first post.

Good luck
JerqFase is offline  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off