Is my sub blown or is this tinsel slap? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 8 Old 01-20-2012, 10:13 PM - Thread Starter
Senior Member
 
macming's Avatar
 
Join Date: Feb 2005
Posts: 339
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have two identical Exudos Audio Maelstrom Xl 18" drivers in custom made boxes, and I'm feeding them a Crown CE4000 each (roughly 2500 watts).

When the bass hits, one of the two drivers sounds like there is something loose. I put my ear closer to the box, and it sounds like there is something metallic shaking around INSIDE the box. The other driver doesn't have this problem.

Do you think the driver is blown? The sound is coming from INSIDE the box, and I notice it's definitely getting worse

If so, I wonder if the dealer will offer a rebuild on the driver.

Thanks!

Ming
macming is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-21-2012, 06:49 AM
AVS Special Member
 
brandonnash's Avatar
 
Join Date: Jul 2003
Location: murfreesboro, tn
Posts: 3,942
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 24
First do a quick test of the drivers. Push in and out on each of the cones one at a time when nothing is being played. Listen closely. Do you hear any scratchy noises? If so you may have a bad driver. If you hear nothing go on to step two which is removing the drivers to see if there is something loose in the box. If nothing then repeat the first test but with the drivers out paying close attention to every bit on the driver (spider, former, etc). With those steps you should be able to identify the problem. My money is on you hearing scratching meaning possibly something wrong with the voice coil.
brandonnash is offline  
post #3 of 8 Old 01-21-2012, 02:44 PM - Thread Starter
Senior Member
 
macming's Avatar
 
Join Date: Feb 2005
Posts: 339
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by brandonnash View Post

First do a quick test of the drivers. Push in and out on each of the cones one at a time when nothing is being played. Listen closely. Do you hear any scratchy noises? If so you may have a bad driver. If you hear nothing go on to step two which is removing the drivers to see if there is something loose in the box. If nothing then repeat the first test but with the drivers out paying close attention to every bit on the driver (spider, former, etc). With those steps you should be able to identify the problem. My money is on you hearing scratching meaning possibly something wrong with the voice coil.

I took the driver out of the box, and it's smooth with no scratchy noises. BUT, I just noticed this problem last night, and I have a feeling that it's going to get worse.

I took a video clip of the driver playing in free air, and I think it sounds like something is loose inside, and crashing into the sidewalls.

To make matters worse, DIYAudiocable no longer sells the Maelstorms. Hopefully he can rebuild it for me as a favour.

http://www.youtube.com/watch?v=drh3H...6fWpi5G1v3GN-V
macming is offline  
post #4 of 8 Old 01-21-2012, 02:49 PM
AVS Special Member
 
brandonnash's Avatar
 
Join Date: Jul 2003
Location: murfreesboro, tn
Posts: 3,942
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 24
Good video, but I'm stumped. Yes it does sound like something is loose. Have you shook the driver a bit to see if anything makes a noise?
brandonnash is offline  
post #5 of 8 Old 01-21-2012, 03:36 PM
AVS Special Member
 
croseiv's Avatar
 
Join Date: Aug 2007
Posts: 2,654
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Look around the basket and see if anything is loose. Also, it's possible the spider is damaged. It seems to be happening at pretty low volume. Have you looked at the speaker surround?

Too bad the video is in such low light. Maybe you could make another, but shine a light on the lower part of the speaker and examine what's happening.
croseiv is offline  
post #6 of 8 Old 01-21-2012, 04:53 PM - Thread Starter
Senior Member
 
macming's Avatar
 
Join Date: Feb 2005
Posts: 339
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by brandonnash View Post

Good video, but I'm stumped. Yes it does sound like something is loose. Have you shook the driver a bit to see if anything makes a noise?

http://www.youtube.com/watch?v=t1tyU...2aAUAAAAAAAAAA

I shook the driver around, and it's solid. The surrounds a perfect. Eitherway, it doesn't sound good

What would be a good replacement driver for a Mal-X? I have a 4 ft^3 sealed box, and a Crown CE4000 for the driver.


Quote:
Originally Posted by croseiv View Post

Look around the basket and see if anything is loose. Also, it's possible the spider is damaged. It seems to be happening at pretty low volume. Have you looked at the speaker surround?

Too bad the video is in such low light. Maybe you could make another, but shine a light on the lower part of the speaker and examine what's happening.

The volume is -15dB. Not exactly cranked, but when mounted in the box, it's moderately loud. I don't have a good feeling about this driver's health
macming is offline  
post #7 of 8 Old 01-21-2012, 05:31 PM
AVS Special Member
 
croseiv's Avatar
 
Join Date: Aug 2007
Posts: 2,654
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
It doesn't really sound blown, but more like something is loose(as was said earlier). Is there any space under the spider where some debris could have fallen into? I'd be inclined to inspect as much of the driver as possible.
croseiv is offline  
post #8 of 8 Old 01-21-2012, 05:40 PM
AVS Special Member
 
digital desire's Avatar
 
Join Date: Oct 2006
Location: Syracuse
Posts: 1,082
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Before you throw it out, remove the dust cap and make sure there is not a piece of glue or schmeg floating around in there.

Lot's of low rent stuff stacked up into a medium rent pile.
digital desire is offline  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off