Klipsch RW-12d on sale for $299 at Newegg.com again today! - Page 76 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #2251 of 2776 Old 06-21-2013, 08:27 AM
AVS Special Member
 
ousooner2's Avatar
 
Join Date: Oct 2007
Location: Oklahoma City
Posts: 2,135
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Liked: 95
Quote:
Originally Posted by basshead81 View Post

just go to the TOP of the subs and turn the gains up some and see if it sounds better...its not rocket science lol. tongue.gif

fixed. biggrin.gif

I'll just wait until I pick up another spl meter and see where I'm at
Quote:
Originally Posted by LastButNotLeast View Post

Have you checked to make sure you have the right OUTPUT on the AVR?
wink.gif

lol...yes.

Panny 65st60 / Denon X1000 / EMP e55ti / EMP e56ci / EMP e5bi / (2) e1010i
ousooner2 is offline  
Sponsored Links
Advertisement
 
post #2252 of 2776 Old 06-21-2013, 11:16 AM
AVS Special Member
 
lovinthehd's Avatar
 
Join Date: Dec 2007
Location: OROR
Posts: 7,347
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 514 Post(s)
Liked: 1028
If you really need a meter I'd think about a calibrated usb mic and REW software on a laptop....portable, more uses and more accurate than a rat shack meter and not much difference in cost

"I realize that somebody playing free music isn't as commercial as a hamburger stand. But is it because you can eat a hamburger and hold it in your hand and you can't do that with music? Is it too free to control?" - Don Van Vliet (aka Captain Beefheart) discussing commercial success in the music biz


lovinthehd is online now  
post #2253 of 2776 Old 06-21-2013, 12:08 PM
AVS Special Member
 
basshead81's Avatar
 
Join Date: Mar 2013
Location: Fort Wayne, IN
Posts: 6,435
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 1704
again Inwould just turn the sub amp gains slightly and see if the sound is better. that will determine if its a calibration issue or something else is amiss.
SanchoPanza likes this.
basshead81 is offline  
post #2254 of 2776 Old 06-24-2013, 04:41 PM
AVS Special Member
 
ousooner2's Avatar
 
Join Date: Oct 2007
Location: Oklahoma City
Posts: 2,135
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Liked: 95
Just realized, and maybe it's gotten louder and that's why I'm realizing it now, but one of the amps on the rw-12d has a very high pitched whine to it. It's constant and does not change with gain (8db either way at least). My other one is silent and turns on and off completely silent, meanwhile ONE of them turns on with a small thud/pop and turns off with some crackling/quick popping,etc. Something is obviously wrong with the amp on this one..

I was set to put an SPL meter on them, etc...but I'll reserve judgment until this is fixed, replaced or if I just return them. frown.gif

Panny 65st60 / Denon X1000 / EMP e55ti / EMP e56ci / EMP e5bi / (2) e1010i
ousooner2 is offline  
post #2255 of 2776 Old 06-24-2013, 05:11 PM
AVS Special Member
 
ousooner2's Avatar
 
Join Date: Oct 2007
Location: Oklahoma City
Posts: 2,135
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Liked: 95
I will say that it sounds louder in the lower frequencies... And maybe up into 60-80hz too with just one playing. Must have some cancellations going on. Ugh

On the other hand, the sub with the amp problem wasn't even playing. While the other was showing a good amount of excursion, the bad one wasn't doin aanything.I can feel it "on" and playing, but not anywhere near the spl what it should be. Damn. Guess I'll wait for a new one
SanchoPanza likes this.

Panny 65st60 / Denon X1000 / EMP e55ti / EMP e56ci / EMP e5bi / (2) e1010i
ousooner2 is offline  
post #2256 of 2776 Old 06-24-2013, 06:25 PM
AVS Addicted Member
 
Bond 007's Avatar
 
Join Date: Jun 2012
Location: Cincinnati, OH
Posts: 12,456
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 419 Post(s)
Liked: 879
Quote:
Originally Posted by ousooner2 View Post

Just realized, and maybe it's gotten louder and that's why I'm realizing it now, but one of the amps on the rw-12d has a very high pitched whine to it. It's constant and does not change with gain (8db either way at least). My other one is silent and turns on and off completely silent, meanwhile ONE of them turns on with a small thud/pop and turns off with some crackling/quick popping,etc. Something is obviously wrong with the amp on this one..

I was set to put an SPL meter on them, etc...but I'll reserve judgment until this is fixed, replaced or if I just return them. frown.gif
Sometimes the outlet can cause symptoms of that sort. Try plugging it into a different outlet just for the heck of it.
SanchoPanza likes this.

No, Mr. Bond. I expect you to die!
Bond 007 is online now  
post #2257 of 2776 Old 06-24-2013, 10:34 PM
Advanced Member
 
shpitz's Avatar
 
Join Date: May 2004
Location: Geneva, IL, USA
Posts: 555
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 36
HOLY SHIZNIT, so I finally got the UMIK-1 so I can test with REW.

Did a comparison sampling with the original Onkyo SKW-530 sub (from an old HTIB) vs the R12d.



Testing over HDMI to Onkyo TX-NR1010, Audyssey is off, crossover set to OFF on the R12d.

Forget about the numbers, the sound difference is incredible, I'm ecstatic!

Sample 15-400Hz, exact same location of sub and mic, same RCA cable used, same sub orientation, smoothing of 1/6 octave.

shpitz is offline  
post #2258 of 2776 Old 06-25-2013, 03:19 AM
AVS Special Member
 
steve nn's Avatar
 
Join Date: Aug 2003
Posts: 6,207
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 428
THE klipsch is back on again.

http://www.newegg.com/Product/Product.aspx?Item=N82E16882780078

Klipsch RB-75
Klipsch C-7
Klipsch RB-35
On-going SW management class
Denon
PS3
steve nn is offline  
post #2259 of 2776 Old 06-25-2013, 07:44 AM
 
BeeMan458's Avatar
 
Join Date: Jun 2012
Location: Magalia, CA
Posts: 8,374
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 801
Quote:
Originally Posted by steve nn View Post

THE klipsch is back on again.

http://www.newegg.com/Product/Product.aspx?Item=N82E16882780078

The discontinued subwoofer that just keeps on giving, and giving and giving and giv....... tongue.gif
BeeMan458 is offline  
post #2260 of 2776 Old 06-25-2013, 07:49 AM
AVS Special Member
 
steve nn's Avatar
 
Join Date: Aug 2003
Posts: 6,207
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 428
Ha ha..Next time I hear it's discontinued this is what I have to say>


Klipsch RB-75
Klipsch C-7
Klipsch RB-35
On-going SW management class
Denon
PS3
steve nn is offline  
post #2261 of 2776 Old 06-25-2013, 07:54 AM
Advanced Member
 
shpitz's Avatar
 
Join Date: May 2004
Location: Geneva, IL, USA
Posts: 555
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 36
Quote:
Originally Posted by steve nn View Post

Ha ha..Next time I hear it's discontinued this is what I have to say>
Quote:
Originally Posted by BeeMan458 View Post

The discontinued subwoofer that just keeps on giving, and giving and giving and giv....... tongue.gif

Nice one!

There's no coupon yet, but the price is still awesome.

shpitz is offline  
post #2262 of 2776 Old 06-25-2013, 07:58 AM
AVS Special Member
 
ousooner2's Avatar
 
Join Date: Oct 2007
Location: Oklahoma City
Posts: 2,135
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Liked: 95
Quote:
Originally Posted by Bond 007 View Post

Sometimes the outlet can cause symptoms of that sort. Try plugging it into a different outlet just for the heck of it.

Agreed, but it was working in the same outlet the few days before. I packed it all up and then saw this. DOH! Didn't even think about trying a different outlet, but I figure if it worked in the same outlet and then all the sudden didn't work it's likely not the outlet.

Hopefully Newegg has a quick turnaround for me. I'm impatient lol.

Panny 65st60 / Denon X1000 / EMP e55ti / EMP e56ci / EMP e5bi / (2) e1010i
ousooner2 is offline  
post #2263 of 2776 Old 06-25-2013, 08:04 AM
AVS Special Member
 
steve nn's Avatar
 
Join Date: Aug 2003
Posts: 6,207
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 428
Quote:
There's no coupon yet, but the price is still awesome. [/QUOTE

They did lastnight.

Klipsch RB-75
Klipsch C-7
Klipsch RB-35
On-going SW management class
Denon
PS3
steve nn is offline  
post #2264 of 2776 Old 06-25-2013, 08:06 AM
AVS Special Member
 
LastButNotLeast's Avatar
 
Join Date: Feb 2007
Location: 08077
Posts: 4,821
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 279 Post(s)
Liked: 287
Quote:
Originally Posted by BeeMan458 View Post

The discontinued subwoofer that just keeps on giving, and giving and giving and giv....... tongue.gif

And now it even comes with a price match guarantee:

 

"Buy with confidence.

This product qualifies for the Iron Egg guarantee. We’ll match any qualifying competitor’s price. Find Out More"

 

As though there are any other "qualifying competitors."

wink.gif


Downloadable FREE demo discs:
http://www.avsforum.com/t/1475769/de...ently-authored 

Did you really need to quote that entire post in your reply?
LastButNotLeast is offline  
post #2265 of 2776 Old 06-25-2013, 08:07 AM
AVS Special Member
 
steve nn's Avatar
 
Join Date: Aug 2003
Posts: 6,207
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 428
Ok I see, but it's still under $300 wink.gif

Klipsch RB-75
Klipsch C-7
Klipsch RB-35
On-going SW management class
Denon
PS3
steve nn is offline  
post #2266 of 2776 Old 06-25-2013, 10:00 AM
Member
 
ElectroMike's Avatar
 
Join Date: May 2013
Location: Exit 160, NJ
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
Quote:
Originally Posted by steve nn View Post

Ok I see, but it's still under $300 wink.gif

It's a gift that keeps on giving! biggrin.gif

TV Pan TC-P60GT50, Denon AVR-1713, Front towers BA A360, Center BA A225C, Surround BA XS Satellite, Sub Klipsch RW12D, Blu-ray player Sony BDP-S5100, Ethereal Power Manager 2000.
ElectroMike is offline  
post #2267 of 2776 Old 06-25-2013, 10:16 AM
AVS Special Member
 
ousooner2's Avatar
 
Join Date: Oct 2007
Location: Oklahoma City
Posts: 2,135
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Liked: 95

Panny 65st60 / Denon X1000 / EMP e55ti / EMP e56ci / EMP e5bi / (2) e1010i
ousooner2 is offline  
post #2268 of 2776 Old 06-25-2013, 10:37 AM
AVS Special Member
 
steve nn's Avatar
 
Join Date: Aug 2003
Posts: 6,207
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 428
Quote:
Originally Posted by ousooner2 View Post


Good pic, thank you biggrin.gif

Klipsch RB-75
Klipsch C-7
Klipsch RB-35
On-going SW management class
Denon
PS3
steve nn is offline  
post #2269 of 2776 Old 06-25-2013, 11:21 AM
AVS Special Member
 
SanchoPanza's Avatar
 
Join Date: Jan 2010
Location: Beauvoir, Mississippi
Posts: 3,010
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 132 Post(s)
Liked: 475
for those with Audyssey, what were your settings, prior to running Audyssey?

just 1 more pair of KLIPSCH Classic speakers...
RED AND BLUE=MAROON!

PANASONIC 60" PLASMA 3D, DENON AVR-3312CI, LG BD670 3D NETWORK BRD (iPhone APPs), TOSHIBA HD-XA2 HD DVD, SAMSUNG BD-UP5000 HD DVD/BRD, iPod 8 GB, 13.2: KLIPSCH La Scala 1980 (Crites Rebuilt Type AA Crossovers Sonicaps) FRONT, HERESY II "SIGNATURE EDITION" WIDE, HERESY II CENTER/SURROUND, kg2 SB, kg3/kg1 Front/Rear HEIGHT, RW-12d SW, km-rsw
SanchoPanza is offline  
post #2270 of 2776 Old 06-25-2013, 12:00 PM
Senior Member
 
jugger's Avatar
 
Join Date: Dec 2011
Location: Colorado
Posts: 217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 55
Has anyone found a good wirless transmitter for this sub? i would love to play with different location for the sub and even add another sub to the room some where. Klipsch sells one but it looks like it is only for the newer models.

Thanks

RC-64 Center, RF-7 Fronts, RF-82 Sides, RW-12D, QTY=2, RSW-15, RS-52ii Rears, Pioneer SC-1522-K, Panasonic 65VT60, 65"
jugger is offline  
post #2271 of 2776 Old 06-25-2013, 12:07 PM
AVS Addicted Member
 
cel4145's Avatar
 
Join Date: Mar 2009
Location: Grand Rapids, MI
Posts: 11,760
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 249 Post(s)
Liked: 781
Quote:
Originally Posted by jugger View Post

Has anyone found a good wirless transmitter for this sub? i would love to play with different location for the sub and even add another sub to the room some where. Klipsch sells one but it looks like it is only for the newer models.

Thanks

Outlaw Audio sells wireless transmitters to use with their subs. Should work fine with the RW-12d, too.

Your questions are answered: Speaker FAQ
HT: Energy RC-50, RC-LCR, Veritas VS Surrounds | Dual CHT SS 18.1s | Denon AVR-888 | modified Dayton SA1000 | Antimode 8033C
Desktop: CBM-170 SE | SVS SB-1000 | Audio-GD NFB-11 | HK 3390
Headphone & Portable HE-400 | K612 Pro | HP150 | DX50 | E12
cel4145 is offline  
post #2272 of 2776 Old 06-25-2013, 12:11 PM
AVS Special Member
 
LastButNotLeast's Avatar
 
Join Date: Feb 2007
Location: 08077
Posts: 4,821
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 279 Post(s)
Liked: 287

Can't get by with just a couple of these?

http://www.monoprice.com/products/product.asp?c_id=102&cp_id=10218&cs_id=1021810&p_id=658&seq=1&format=2

wink.gif


Downloadable FREE demo discs:
http://www.avsforum.com/t/1475769/de...ently-authored 

Did you really need to quote that entire post in your reply?
LastButNotLeast is offline  
post #2273 of 2776 Old 06-25-2013, 04:56 PM
AVS Special Member
 
ousooner2's Avatar
 
Join Date: Oct 2007
Location: Oklahoma City
Posts: 2,135
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 68 Post(s)
Liked: 95
Quote:
Originally Posted by Bond 007 View Post

Sometimes the outlet can cause symptoms of that sort. Try plugging it into a different outlet just for the heck of it.

I wanted to really find out if the outlet was the issue so I unboxed the rw-12d and tried it in the top outlet on the same plate... Same occurrence. Tried in another outlet in a different room and another in the living room.. All made the sub amp make high pitched noise and horrible distortion/crackling noise upon turn off

Panny 65st60 / Denon X1000 / EMP e55ti / EMP e56ci / EMP e5bi / (2) e1010i
ousooner2 is offline  
post #2274 of 2776 Old 06-25-2013, 04:58 PM
 
BeeMan458's Avatar
 
Join Date: Jun 2012
Location: Magalia, CA
Posts: 8,374
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 801
In my opinion, it reads as if your amplifier (the auto-on circuit) has a major malfunction.
BeeMan458 is offline  
post #2275 of 2776 Old 06-25-2013, 10:45 PM
Advanced Member
 
shpitz's Avatar
 
Join Date: May 2004
Location: Geneva, IL, USA
Posts: 555
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 36
Just ran Audyssey again, got the following results:

Sub: 2ch
Front: 40Hz
Center: 70Hz
Surround: 120Hz
S. Back: 120Hz
S. Back Ch: 2ch
LFE: Off
Sub Phase: 0

Odd that LFE is Off. I set LFE on both subs to Off prior to calibration.

In the 1st step of Audyssey where I need to tweak the sound level to 75db, the subs were set to 0db in the subs' panels, which resulted in ~92db reading, had to turn them down to -14db & -19db (right & left positions).

shpitz is offline  
post #2276 of 2776 Old 06-25-2013, 11:34 PM
AVS Special Member
 
lovinthehd's Avatar
 
Join Date: Dec 2007
Location: OROR
Posts: 7,347
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 514 Post(s)
Liked: 1028
Quote:
Originally Posted by shpitz View Post

Just ran Audyssey again, got the following results:

Sub: 2ch
Front: 40Hz
Center: 70Hz
Surround: 120Hz
S. Back: 120Hz
S. Back Ch: 2ch
LFE: Off
Sub Phase: 0

Odd that LFE is Off. I set LFE on both subs to Off prior to calibration.

In the 1st step of Audyssey where I need to tweak the sound level to 75db, the subs were set to 0db in the subs' panels, which resulted in ~92db reading, had to turn them down to -14db & -19db (right & left positions).

My avr doesn't report back a setting for LFE but it does report a setting for LPF (low pass filter) for LFE; if it's off it may just mean that is not set. What avr? Sorry, too lazy to look back further than this page. Also, remember, it's not Audyssey suggesting your crossovers, it's your avr/brand; Audyssey would start with 80hz as that's their preference. Not unusual to have to put the sub gain setting where you did, I mostly leave mine at -18/-19 but sometimes tweak it.

"I realize that somebody playing free music isn't as commercial as a hamburger stand. But is it because you can eat a hamburger and hold it in your hand and you can't do that with music? Is it too free to control?" - Don Van Vliet (aka Captain Beefheart) discussing commercial success in the music biz


lovinthehd is online now  
post #2277 of 2776 Old 06-26-2013, 06:50 AM
Senior Member
 
jugger's Avatar
 
Join Date: Dec 2011
Location: Colorado
Posts: 217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 55
Quote:
Originally Posted by cel4145 View Post

Outlaw Audio sells wireless transmitters to use with their subs. Should work fine with the RW-12d, too.

Thank you. That looks perfect

RC-64 Center, RF-7 Fronts, RF-82 Sides, RW-12D, QTY=2, RSW-15, RS-52ii Rears, Pioneer SC-1522-K, Panasonic 65VT60, 65"
jugger is offline  
post #2278 of 2776 Old 06-26-2013, 10:55 AM
Advanced Member
 
shpitz's Avatar
 
Join Date: May 2004
Location: Geneva, IL, USA
Posts: 555
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 36
Quote:
Originally Posted by lovinthehd View Post

My avr doesn't report back a setting for LFE but it does report a setting for LPF (low pass filter) for LFE; if it's off it may just mean that is not set. What avr?

Sorry, Onkyo TX-NR1010.

It reports LPF/LFE as a single value, which in my case it is OFF. So now I have crossover on the subs set to OFF, and the receiver chose OFF as well.

I did the full Audyssey (8 positions) calibration. I've done it late at night so couldn't really test movies/music at high volume.

I also need to rearrange the room, one sofa to the side is kinda blocking the left sub. I also need to hang the speakers up, currently looking for room setup tutorials on THX and DTS websites.

shpitz is offline  
post #2279 of 2776 Old 06-26-2013, 01:52 PM
AVS Special Member
 
lovinthehd's Avatar
 
Join Date: Dec 2007
Location: OROR
Posts: 7,347
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 514 Post(s)
Liked: 1028
Quote:
Originally Posted by shpitz View Post

Quote:
Originally Posted by lovinthehd View Post

My avr doesn't report back a setting for LFE but it does report a setting for LPF (low pass filter) for LFE; if it's off it may just mean that is not set. What avr?

Sorry, Onkyo TX-NR1010.

It reports LPF/LFE as a single value, which in my case it is OFF. So now I have crossover on the subs set to OFF, and the receiver chose OFF as well.

I did the full Audyssey (8 positions) calibration. I've done it late at night so couldn't really test movies/music at high volume.

I also need to rearrange the room, one sofa to the side is kinda blocking the left sub. I also need to hang the speakers up, currently looking for room setup tutorials on THX and DTS websites.

Mine's a lesser Onkyo, not sure it even has a reading of "off" available. It normally sets mine at 120Hz which is the extent of the LFE per THX if I recall correctly, but that Onkyo setting isn't from running the RW12d, but rather an Epik Empire. What does your manual indicate in this case?

For my RW12d lowpass setting is at "Off-LFE mode" but use that sub with an older Sony 5.1 avr that doesn't have any auto setup routine.

"I realize that somebody playing free music isn't as commercial as a hamburger stand. But is it because you can eat a hamburger and hold it in your hand and you can't do that with music? Is it too free to control?" - Don Van Vliet (aka Captain Beefheart) discussing commercial success in the music biz


lovinthehd is online now  
post #2280 of 2776 Old 06-26-2013, 02:15 PM
AVS Addicted Member
 
Bond 007's Avatar
 
Join Date: Jun 2012
Location: Cincinnati, OH
Posts: 12,456
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 419 Post(s)
Liked: 879
Confusing to me. I dont have an Onkyo but that doesnt make any sense. Why would it simply turn the xover "Off"?

No, Mr. Bond. I expect you to die!
Bond 007 is online now  
Reply Subwoofers, Bass, and Transducers

Tags
Klipsch Rw 12d 12 Subwoofer Each , Subwoofers , Speaker Systems

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off