PL200 sub with an H100 woofer inside? - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 01-13-2013, 03:41 AM - Thread Starter
Member
 
mcarbo's Avatar
 
Join Date: Dec 2012
Location: Massachusetts
Posts: 92
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 22
I recently purchased a PL200 sub and finally got around to removing the grille. The speaker coloring is gold like in the H100 pictured online. The PL200 is shown with a silver speaker. Did I end up with a mismatch or did BIC make a product change? Thanks in advance.
mcarbo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-13-2013, 01:15 PM
Senior Member
 
capricorn kid's Avatar
 
Join Date: Aug 2010
Location: Jonesboro, Georgia
Posts: 483
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 25
The color in the picture is not correct. The cone of the PL-200 has always been a brass looking penny color.

Klipsch Synergy 3 speakers
Dual Klipsch RW 12D subs
120" 16:9 screen
Sony STR-DG 720
Panasonic BDT 460 bluray player
Panasonic PT-AE 8000u projector
capricorn kid is offline  
post #3 of 3 Old 01-13-2013, 03:40 PM - Thread Starter
Member
 
mcarbo's Avatar
 
Join Date: Dec 2012
Location: Massachusetts
Posts: 92
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 22
I emailed BIC and was told the speaker is the same in either a PL200 or H100 other than color. They offered to exchange the speaker if I wanted. If they are truly the same I can't see messing with something that works fine...
mcarbo is offline  
Sponsored Links
Advertisement
 
Reply Subwoofers, Bass, and Transducers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off