Problem with Epik Empire - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 8 Old 10-04-2013, 05:02 PM - Thread Starter
Member
 
juridical's Avatar
 
Join Date: Nov 2009
Location: Central Ohio
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello all,
I have dual empires and was watching World War Z and one of my subs blew chunks. eek.gif

It shut down and smells of burnt electronics. I'm assuming the amp blew. I've had the set for a year and a half with no other issues. I love them.

I have sent three emails and left two voice mails to epik. No return email or call. Any ideas on how I can get help from Epik? I'm not looking for freebies just what's fair.

Thanks all,
Jeremy

Home theater:
Onkyo TX-NR807, Emotiva XPA300, PS4, XBox 360, Popcorn Hour
Ascend Acoustics Sierra Towers L/R, Sierra Horizon C, (4) HTM-200 SE Surrounds, Dual SVS PB12 Plus subwoofers, Harmony 900
Panasonic PT-AE4000 on a 106" 2,35:1 fixed screen
juridical is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 10-04-2013, 05:08 PM
AVS Special Member
 
XStanleyX's Avatar
 
Join Date: Nov 2004
Location: Seattle
Posts: 4,689
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 1262
The owner of Epic has been AWOL for at least 6 months so I'm afraid you're SOL. Look at the Epic thread. Good luck.

Denon AVR4311CI
Magnepan 2.7QR's w/ MGCC3 Center
(2) Polk RT15i
(2) Sonotube Subs with 18" Stereo Integrity D4 Drivers
Behringer NU3000 & NU4-6000 Amps
Panasonic DMP-BDP210 - Projector: BenQ W1070
Panamax M5400-PM
60" Samsung TV
WDTV Live & Minix Neo X7
Some audio history: https://skydrive.live.c...
XStanleyX is offline  
post #3 of 8 Old 10-04-2013, 05:09 PM
AVS Special Member
 
sputter1's Avatar
 
Join Date: Jan 2010
Location: Ontario
Posts: 1,372
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 41
He's just too hard at work making new stuff.
Keep trying man, a couple guys have said they've spoke to him if you take their word.
sputter1 is offline  
post #4 of 8 Old 10-04-2013, 05:31 PM - Thread Starter
Member
 
juridical's Avatar
 
Join Date: Nov 2009
Location: Central Ohio
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
If I can't get a hold of them, any suggestions on a replacement amp for my beloved empire?

Home theater:
Onkyo TX-NR807, Emotiva XPA300, PS4, XBox 360, Popcorn Hour
Ascend Acoustics Sierra Towers L/R, Sierra Horizon C, (4) HTM-200 SE Surrounds, Dual SVS PB12 Plus subwoofers, Harmony 900
Panasonic PT-AE4000 on a 106" 2,35:1 fixed screen
juridical is offline  
post #5 of 8 Old 10-04-2013, 05:51 PM
AVS Addicted Member
 
Chu Gai's Avatar
 
Join Date: Sep 2002
Location: NYC area
Posts: 14,740
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 131 Post(s)
Liked: 431
Speak with forum member Daveds50 who does repairs.

"I've found that when you want to know the truth about someone that someone is probably the last person you should ask." - Gregory House
Chu Gai is online now  
post #6 of 8 Old 10-05-2013, 09:43 AM - Thread Starter
Member
 
juridical's Avatar
 
Join Date: Nov 2009
Location: Central Ohio
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I pulled the amplifier. I can replace, it is pretty charred. Wish the Epik people would respond. Any ideas on what where I would buy a nice replacement amplifier that will fit the Empire??

Home theater:
Onkyo TX-NR807, Emotiva XPA300, PS4, XBox 360, Popcorn Hour
Ascend Acoustics Sierra Towers L/R, Sierra Horizon C, (4) HTM-200 SE Surrounds, Dual SVS PB12 Plus subwoofers, Harmony 900
Panasonic PT-AE4000 on a 106" 2,35:1 fixed screen
juridical is offline  
post #7 of 8 Old 10-05-2013, 12:51 PM
Gov
AVS Special Member
 
Gov's Avatar
 
Join Date: Mar 2003
Location: NW Burbs of Chgo, IL
Posts: 3,229
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 104
Quote:
Originally Posted by juridical View Post

I pulled the amplifier. I can replace, it is pretty charred. Wish the Epik people would respond. Any ideas on what where I would buy a nice replacement amplifier that will fit the Empire??

Keep trying to get ahold of Chad at Epik. It is a pain in the ass, but you should eventually get him and I would bet he will take care of you. His communication is god awful I know rolleyes.gif

Panny TC-P65VT60 (calibrated by Chad B), Denon AVR-4311, Comcast X1 DVR, Apple TV 3, Sony BDP-S5100,  Ascend Acoustics Sierra Towers (mains), Horizon (CC) and HTM-200's (Surr), Dual PSA XV15 Subwoofers!!
Gov is offline  
post #8 of 8 Old 10-05-2013, 03:35 PM
Senior Member
 
dannybenz's Avatar
 
Join Date: Feb 2010
Posts: 249
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 16
I also have dual Empires. I used them maybe once every two weeks. One of the amps just blew 2 minutes ago on turn on. It smells of burnt electronics as the OP stated, but the power light still turns on. While I'm at this, I'm thinking about the running one external pro amp for both the subs and covering up the part of the sub where the amps sat with some MDF...

Is there anyone who is running an external amp with the EMpire?

Main
Selah Prestigio Dual Epik Empires
Desk
GR Research N2x BIC F12 Ultrasone Pro 650 Velodyne vpulse
TV
Wharfedale 9.6
dannybenz is online now  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off