Seismic 12, hum at my house, but not at my dads - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 06-15-2014, 03:31 PM - Thread Starter
Senior Member
Heli Pilot's Avatar
Join Date: Jun 2009
Location: Texas
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Seismic 12, hum at my house, but not at my dads

So I just picked up a Paradigm Seismic 12, when I plugged it in where I bought it hum, when I took it to my dads and inserted it into his theater to test hum (just bone shaking low end), when I got home and plugged it in ...hum. Not real loud, but definitely annoying. It happens whether on "On", "Auto" with or without the line out to the amp. Is this the grounding in my house? Is there anything I can do, short of rewiring my house, to get rid of it? Something I can put in between the sub and the wall? I've tried different plugs, and different power cables too, same result.

Even more annoying, it doesn't hum in my office, unfortunately I don't think it would be a good idea to run an extension cord from the living room to the other side of the house

Last edited by Heli Pilot; 06-15-2014 at 04:05 PM.
Heli Pilot is offline  
Sponsored Links
Old 06-15-2014, 05:30 PM
AVS Addicted Member
Bill Fitzmaurice's Avatar
Join Date: Nov 2009
Location: New Hampshire
Posts: 11,967
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 2670
If it hums with nothing plugged into the input chances are the outlet wiring is faulty. Test it with one of these:

Bill Fitzmaurice Loudspeaker Design

The Laws of Physics aren't swayed by opinion.
Bill Fitzmaurice is offline  
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off