Official SVS Owners/Support Thread. - Page 566 - AVS Forum | Home Theater Discussions And Reviews

Forum Jump: 
 3513Likes
 
Thread Tools
Old 06-11-2014, 10:56 PM
AVS Forum Special Member
 
retro124's Avatar
 
Join Date: Dec 2013
Location: Charleston, SC
Posts: 2,482
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 981 Post(s)
Liked: 710
Quote:
Originally Posted by rana_kirti View Post
yes bro I have a 5.1 setup in my bedroom. my avr is only 6.1 so cant do a 7.1 setup with it.

I have desktop pc existing in the same room with a stereo amp and 2 speakers.

I hoped to use the pc12 nsd which is connected to my 5.1 avr with the stereo amplifier to make it 2.1

so I can enjoy the svs both for movies with my avr and music with my stereo amplifier.

Is that too much to ask for ???
Yes you can,no it is not too much to ask Ijust dont understand why you dont want to contact also SVS if you have a questions about for Sub, they have outstanding customer service. It is always nice to be sure before you set up something wrong and you don't want to damage your sub it is why taht guy and I told you also about contacted SVS.

Denon X6200W
Klipsch RF-7II's, RC-64II, RB-81II's, RS-62II's, RS-52II's
SVS 2x PC12-Pluses
Sony XBR65X850B
Emotiva XPA-200, UPA-7 Oppo 103D
Apple Mac mini, Sony PS3
retro124 is offline  
Sponsored Links
Advertisement
 
Old 06-12-2014, 06:55 AM
AVS Special Member
 
smurraybhm's Avatar
 
Join Date: Jul 2007
Location: Down South
Posts: 3,420
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 1354 Post(s)
Liked: 1596
^ what he said "bro."
When you talk to SVS let us know what they said.
smurraybhm is offline  
Old 06-12-2014, 09:40 AM
Senior Member
 
Rgdeuce's Avatar
 
Join Date: Jan 2014
Location: The desert
Posts: 337
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 128 Post(s)
Liked: 115
Will be a member of the second sub club (PB12-NSD's) when it arrives early next week. Just needed someone to tell, since my wife is past tired of me talking about home theater. Somehow I was able to stretch a $300 subwoofer budget (until I got sound advice here indicating I needed to do better) into nearly $1,200. She literally made me sign a promise agreement that this is the last piece of home theater equipment I buy for the next 5 years.
Tom Riddle and runcliffyrun like this.
Rgdeuce is offline  
Old 06-12-2014, 10:10 AM
AVS Forum Special Member
 
retro124's Avatar
 
Join Date: Dec 2013
Location: Charleston, SC
Posts: 2,482
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 981 Post(s)
Liked: 710
Congrats to your second sub, I'm sure you will like it. Just play same action scenes with one and then hook up both and your wife will hear different and I'm sure she will like it if she like watch movies or listen music. It is what I did with my wife and we tested dual Pses over single Ultra and she said also dual sounds the best !!!! 5 years is a long time, not sure if I want to sign something like this

Denon X6200W
Klipsch RF-7II's, RC-64II, RB-81II's, RS-62II's, RS-52II's
SVS 2x PC12-Pluses
Sony XBR65X850B
Emotiva XPA-200, UPA-7 Oppo 103D
Apple Mac mini, Sony PS3
retro124 is offline  
Old 06-12-2014, 10:58 AM
AVS Forum Special Member
 
cchunter's Avatar
 
Join Date: Feb 2011
Location: Wisconsin
Posts: 1,779
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 488 Post(s)
Liked: 766
Quote:
Originally Posted by Rgdeuce View Post
Will be a member of the second sub club (PB12-NSD's) when it arrives early next week. Just needed someone to tell, since my wife is past tired of me talking about home theater. Somehow I was able to stretch a $300 subwoofer budget (until I got sound advice here indicating I needed to do better) into nearly $1,200. She literally made me sign a promise agreement that this is the last piece of home theater equipment I buy for the next 5 years.
I also promised my wife I wouldn't buy anything HT related and well I found a great deal on some used Klipsch RF7II's and after telling her what retail price was and what I could get them for used she said what are you waiting for. Picking them up end of this month

Denon 4520
Klipsch RF-7II's, RC-64II, RS-62II's
SVS SB13 Ultra
Oppo 103D Sony PS4
Panamax 5300PM
Samsung UN60F7100 3D LED
cchunter is offline  
Old 06-12-2014, 11:05 AM
Senior Member
 
Rgdeuce's Avatar
 
Join Date: Jan 2014
Location: The desert
Posts: 337
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 128 Post(s)
Liked: 115
Quote:
Originally Posted by retro124 View Post
Congrats to your second sub, I'm sure you will like it. Just play same action scenes with one and then hook up both and your wife will hear different and I'm sure she will like it if she like watch movies or listen music. It is what I did with my wife and we tested dual Pses over single Ultra and she said also dual sounds the best !!!! 5 years is a long time, not sure if I want to sign something like this
Yea, it is a long time, but to go from having my mind set on the Energy Take Classic series, to moving up to the Energy Reference Connoiseur line, getting a better AVR than initially planned, and to top it off with two great subs, I can't really complain. I spent probably four times what I initially told her I was going to spend. I'm sure many wives would have said no a long time ago, so I will honor said agreement.
Rgdeuce is offline  
Old 06-12-2014, 04:11 PM
Senior Member
 
joseph10704's Avatar
 
Join Date: May 2011
Posts: 494
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 242 Post(s)
Liked: 96
Man this new look is all over the place.i AM TRYING MY BEST to find forums i am subed to svs beign one big one.I have to go into the fourms list just to find svs this really blow's.Before it saved in my list now that list is gone it's like they just got rid of it.IDK why they would do this.Every time with website's like this .I feel like i am on youtube and facebook once again not know what the hell to do becuase everything is messed up lol.
joseph10704 is offline  
Old 06-12-2014, 07:56 PM
 
cableguy301's Avatar
 
Join Date: Jan 2014
Posts: 452
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)
Liked: 64
Unhappy

Quote:
Originally Posted by joseph10704 View Post
Man this new look is all over the place.i AM TRYING MY BEST to find forums i am subed to svs beign one big one.I have to go into the fourms list just to find svs this really blow's.Before it saved in my list now that list is gone it's like they just got rid of it.IDK why they would do this.Every time with website's like this .I feel like i am on youtube and facebook once again not know what the hell to do becuase everything is messed up lol.
just click on tools at the top


then subscriptions.. that should help a lot..


yeah the site is not as user friendly as before..
cableguy301 is offline  
Old 06-12-2014, 08:02 PM
AVS Forum Special Member
 
retro124's Avatar
 
Join Date: Dec 2013
Location: Charleston, SC
Posts: 2,482
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 981 Post(s)
Liked: 710
Quote:
Originally Posted by joseph10704 View Post
Man this new look is all over the place.i AM TRYING MY BEST to find forums i am subed to svs beign one big one.I have to go into the fourms list just to find svs this really blow's.Before it saved in my list now that list is gone it's like they just got rid of it.IDK why they would do this.Every time with website's like this .I feel like i am on youtube and facebook once again not know what the hell to do becuase everything is messed up lol.
I'm with you little crazy changes but we will get use to it, no other option anyway

Denon X6200W
Klipsch RF-7II's, RC-64II, RB-81II's, RS-62II's, RS-52II's
SVS 2x PC12-Pluses
Sony XBR65X850B
Emotiva XPA-200, UPA-7 Oppo 103D
Apple Mac mini, Sony PS3
retro124 is offline  
Old 06-13-2014, 07:38 AM
Member
 
Rendermandan's Avatar
 
Join Date: May 2013
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 15
I've got a question. I received my PB-2000 yesterday. (Excellent shipping time by the way, only 3 days!!!). I got the sub setup last night and I seem to be having a hard time with a few things. I am using a Pioneer VSX-1022K receiver with a single LFE cable to the sub. My sub is placed in the corner of a 11'x35' room. Theater is at the end of the room where the sub is located.



1st. I can't seem to get the auto on feature to work. I can switch the sub to on, and it will power on. when its on Auto and there is a signal, it stays on. but when it shuts off after it doesn't detect the signal, it won't turn back on.



2nd. I ran the MCAA... calibration on the receiver. It barley picked up the sub. I checked the settings on the amp. LFE on the crossover, 0 phase and gain at 12:00 position.

the auto calibration put the AVR gains on all my other speakers at -7 to -10 db and the sub at +5. does this seem normal? For a sub this size, it should be the other way around I think.



I went with the settings that the auto calibration did, and I had virtually no sound out of the sub. I decided to turn the gain up on the sub and then it started to work. the gain is up around the 3:00 position. (Around 75%?) Does that seem right?



Next I proceeded to adjust the AVR settings. I bumped the sub out from +5 to +10. that made a huge difference. Now we are rattling the rafters!



Now I have read on multiple posts here that you should not turn the AVR setting into the positive, leave it at 0. If I do that, the sub simply doesn't work. even if the sub amp gain is up to 100%. Is this normal?



And this still doesn't explain why the auto-on features doesn't work...



Any help? Thanks!
Rendermandan is offline  
Old 06-13-2014, 07:46 AM
AVS Addicted Member
 
Bond 007's Avatar
 
Join Date: Jun 2012
Posts: 16,051
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 2091 Post(s)
Liked: 1750
It wont hurt anything to leave the sub On all the time.
Bond 007 is offline  
Old 06-13-2014, 07:50 AM
 
cableguy301's Avatar
 
Join Date: Jan 2014
Posts: 452
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)
Liked: 64
[QUOTE=Rendermandan;24932921]I've got a question. I received my PB-2000 yesterday. (Excellent shipping time by the way, only 3 days!!!). I got the sub setup last night and I seem to be having a hard time with a few things. I am using a Pioneer VSX-1022K receiver with a single LFE cable to the sub. My sub is placed in the corner of a 11'x35' room. Theater is at the end of the room where the sub is located.



1st. I can't seem to get the auto on feature to work. I can switch the sub to on, and it will power on. when its on Auto and there is a signal, it stays on. but when it shuts off after it doesn't detect the signal, it won't turn back on.



2nd. I ran the MCAA... calibration on the receiver. It barley picked up the sub. I checked the settings on the amp. LFE on the crossover, 0 phase and gain at 12:00 position.


re run the calibration with sub at 1 or 2 o'clock position till the avr trims it to the minus -10 to - 5 area...


not sure why the auto on is not working call svs..


good luck
cableguy301 is offline  
Old 06-13-2014, 07:55 AM
AVS Special Member
 
smurraybhm's Avatar
 
Join Date: Jul 2007
Location: Down South
Posts: 3,420
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 1354 Post(s)
Liked: 1596
^ True that, but give SVS a call to get their input just in case you've missed something or you've got an issue with your sub. This weekend I too thought I had an issue with the auto on function with my new PC12 Plus - when I re-ran Audyssey I had to boast the volume on the sub - but then had to quickly turn it down when it kicked on (literally). No issues after that when receiving a signal. Later when I would try to make some adjustments it didn't come back on, I even swapped out the surge protector. After going through all of that I read the manual (don't say it) and realized just how that feature works with the LED display and push button control - DUH!

By the way I got my replacement grill and the other part I needed to fix the damage to my new sub during shipping. Thanks SVS - great service as always.
smurraybhm is offline  
Old 06-13-2014, 08:56 AM
Senior Member
 
Rgdeuce's Avatar
 
Join Date: Jan 2014
Location: The desert
Posts: 337
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 128 Post(s)
Liked: 115
Did you run the calibration with the sub set to On, or was it on Auto when you ran it? You want it "On" before you run it
Rgdeuce is offline  
Old 06-14-2014, 12:21 AM
Senior Member
 
johnnyknoxsvill's Avatar
 
Join Date: Apr 2007
Location: Avondale, AZ
Posts: 418
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 63 Post(s)
Liked: 28
Also don't forget to turn up the Trim 3db in the standing wave section after running MCACC
johnnyknoxsvill is offline  
Old 06-14-2014, 08:09 AM
Member
 
Rendermandan's Avatar
 
Join Date: May 2013
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 15
Good news, I think I got it figured out. Last night I had some time to do some adjustments. Long story short, I had to turn down the gain on the sub and I boosted the avr sub up. What I think was happening was the avr was not sending a strong enough signal for the amp to pick up on. With the higher output from the avr, the auto turn on works now. I then proceeded to adjust the gain on the sub to my liking which is just past 12:00.

Then I noticed a new problem, I was able to here people talking through the sub... The crossover was still at LFE. Short story, the mcacc had changed my center channel to "small". Even though it's dual 6.5's and a horn tweeter. In the small setting, any frequencies from any speaker lower than 150hz are sent to the LFE channel... I manually changed it back to large, and the problem was solved!

Now, to enjoy some old movies all over again!
Rendermandan is offline  
Old 06-14-2014, 08:11 AM
 
fatbottom's Avatar
 
Join Date: May 2003
Location: UK
Posts: 5,916
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 1420 Post(s)
Liked: 518
Quote:
Short story, the mcacc had changed my center channel to "small". Even though it's dual 6.5's and a horn tweeter. In the small setting, any frequencies from any speaker lower than 150hz are sent to the LFE channel... I manually changed it back to large, and the problem was solved!
I'd still leave it as small. What is your center? Is it capable down to 20hz?
fatbottom is offline  
Old 06-14-2014, 08:11 AM
 
fatbottom's Avatar
 
Join Date: May 2003
Location: UK
Posts: 5,916
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 1420 Post(s)
Liked: 518
Quote:
Originally Posted by Rendermandan View Post
Good news, I think I got it figured out. Last night I had some time to do some adjustments. Long story short, I had to turn down the gain on the sub and I boosted the avr sub up. What I think was happening was the avr was not sending a strong enough signal for the amp to pick up on. With the higher output from the avr, the auto turn on works now. I then proceeded to adjust the gain on the sub to my liking which is just past 12:00.

Then I noticed a new problem, I was able to here people talking through the sub... The crossover was still at LFE. Short story, the mcacc had changed my center channel to "small". Even though it's dual 6.5's and a horn tweeter. In the small setting, any frequencies from any speaker lower than 150hz are sent to the LFE channel... I manually changed it back to large, and the problem was solved!

Now, to enjoy some old movies all over again!
I'd set it to small, is it capable down to 20hz?
fatbottom is offline  
Old 06-14-2014, 08:12 AM
AVS Forum Special Member
 
Mongo171's Avatar
 
Join Date: Mar 2013
Location: Buffalo, NY
Posts: 3,109
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 765 Post(s)
Liked: 1213
Quote:
Originally Posted by Rendermandan View Post
Good news, I think I got it figured out. Last night I had some time to do some adjustments. Long story short, I had to turn down the gain on the sub and I boosted the avr sub up. What I think was happening was the avr was not sending a strong enough signal for the amp to pick up on. With the higher output from the avr, the auto turn on works now. I then proceeded to adjust the gain on the sub to my liking which is just past 12:00.

Then I noticed a new problem, I was able to here people talking through the sub... The crossover was still at LFE. Short story, the mcacc had changed my center channel to "small". Even though it's dual 6.5's and a horn tweeter. In the small setting, any frequencies from any speaker lower than 150hz are sent to the LFE channel... I manually changed it back to large, and the problem was solved!

Now, to enjoy some old movies all over again!
Now, your center channel will be trying to reproduce frequencies it wasn't designed for.

Set it back to small and adjust the xo to a lower freq.

"I am a Meat Popsicle." - Korben Dallas, "The Fifth Element"
Mongo171 is offline  
Old 06-14-2014, 08:16 AM
Member
 
Rendermandan's Avatar
 
Join Date: May 2013
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 15
No, it's not capable of 20hz. My sub is located in the back corner of the room, distance from seated position is only 10ft. So when a lower voice is coming from the center channel, I can hear it from the sub, and it just messes up the soundstage. I'm sure it would not be as noticeable if the sub were up front with the other speakers, unfortunately the only place I have room for the PB-20000 is in the corner...
Rendermandan is offline  
Old 06-14-2014, 08:18 AM
 
fatbottom's Avatar
 
Join Date: May 2003
Location: UK
Posts: 5,916
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 1420 Post(s)
Liked: 518
Anyway the high frequency sounds from your sub is due to the high setting on your pioneer, if you can't adjust 150hz to a lower setting, I'd probably use the crossover on the sub. Not ideal as you're going through two crossovers..but 150hz is way too high (in fact I don't like 120hz either)
fatbottom is offline  
Old 06-14-2014, 08:20 AM
Member
 
Rendermandan's Avatar
 
Join Date: May 2013
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 15
Yes, there is a crossover setting. I think it goes, 80, 100, 120, 150.

So what you are suggesting is to change the center back to small, and set the crossover at 80 or 100.


Edit: to clarify, the crossover on the avr, not the sub.

Last edited by Rendermandan; 06-14-2014 at 08:30 AM.
Rendermandan is offline  
Old 06-14-2014, 08:49 AM
AVS Addicted Member
 
Bond 007's Avatar
 
Join Date: Jun 2012
Posts: 16,051
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 2091 Post(s)
Liked: 1750
Quote:
Originally Posted by Rendermandan View Post
So what you are suggesting is to change the center back to small, and set the crossover at 80 or 100.
Edit: to clarify, the crossover on the avr, not the sub.
Yes
Bond 007 is offline  
Old 06-15-2014, 05:52 AM
mnc
AVS Forum Special Member
 
mnc's Avatar
 
Join Date: Mar 2003
Location: Dallas, GA
Posts: 2,413
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 509 Post(s)
Liked: 410
Looks like they lowered the price on most outlet subs by $50!
mnc is offline  
Old 06-15-2014, 11:48 AM
AVS Forum Special Member
 
retro124's Avatar
 
Join Date: Dec 2013
Location: Charleston, SC
Posts: 2,482
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 981 Post(s)
Liked: 710
Thumbs up

Quote:
Originally Posted by mnc View Post
Looks like they lowered the price on most outlet subs by $50!
Some went down $100, even better reason to get SVS subs guys !!!! Outstanding subs are cheaper in outlet great !!!

Denon X6200W
Klipsch RF-7II's, RC-64II, RB-81II's, RS-62II's, RS-52II's
SVS 2x PC12-Pluses
Sony XBR65X850B
Emotiva XPA-200, UPA-7 Oppo 103D
Apple Mac mini, Sony PS3
retro124 is offline  
Old 06-15-2014, 12:12 PM
 
cableguy301's Avatar
 
Join Date: Jan 2014
Posts: 452
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)
Liked: 64
cableguy301 is offline  
Old 06-15-2014, 12:41 PM
AVS Special Member
 
bear123's Avatar
 
Join Date: Dec 2013
Location: PA
Posts: 4,846
Mentioned: 26 Post(s)
Tagged: 0 Thread(s)
Quoted: 1630 Post(s)
Liked: 2369
You really like cables, eh? Don't get me wrong, I have BJC sub cables just for the quality, and I forget/don't care 12g copper speaker wire. HDMI is el cheapo mono price slim...just for the really short HDMI plug to gain clearance to the rear of my equipment.
bear123 is offline  
Old 06-15-2014, 12:50 PM
Member
 
Rendermandan's Avatar
 
Join Date: May 2013
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 15
[quote=retro124;24985978]
Quote:
Originally Posted by mnc View Post
Looks like they lowered the price on most outlet subs by $50!
Looks like I should have waited a week. I could have saved $50. Oh we'll.. On the bright side, I received a virgin sub, and we all know, how good a thing that is
Rendermandan is offline  
Old 06-15-2014, 02:43 PM
 
cableguy301's Avatar
 
Join Date: Jan 2014
Posts: 452
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)
Liked: 64
Quote:
Originally Posted by bear123 View Post
You really like cables, eh? Don't get me wrong, I have BJC sub cables just for the quality, and I forget/don't care 12g copper speaker wire. HDMI is el cheapo mono price slim...just for the really short HDMI plug to gain clearance to the rear of my equipment.
yeah I make those cables .. sorry I was just playing around with the site trying to figure out how to upload a picture... its more difficult to do now ..


some people like a nice looking set of cables... especially the thick stuff... much nicer than zip cord don't you think...


its is also a premium type cable with 350 strands in a 50 x 7 bundle formation.. with pure ofc!


cheers
cableguy301 is offline  
Old 06-15-2014, 04:51 PM
AVS Special Member
 
bear123's Avatar
 
Join Date: Dec 2013
Location: PA
Posts: 4,846
Mentioned: 26 Post(s)
Tagged: 0 Thread(s)
Quoted: 1630 Post(s)
Liked: 2369
Quote:
Originally Posted by cableguy301 View Post
Quote:
Originally Posted by bear123 View Post
You really like cables, eh? Don't get me wrong, I have BJC sub cables just for the quality, and I forget/don't care 12g copper speaker wire. HDMI is el cheapo mono price slim...just for the really short HDMI plug to gain clearance to the rear of my equipment.
yeah I make those cables .. sorry I was just playing around with the site trying to figure out how to upload a picture... its more difficult to do now ..


some people like a nice looking set of cables... especially the thick stuff... much nicer than zip cord don't you think...


its is also a premium type cable with 350 strands in a 50 x 7 bundle formation.. with pure ofc!


cheers
Nah, they aren't important to me...I prefer not to see them at all if possible, so what they look like does not matter at all to me personally. Basically, I want good quality while keeping the cost as low as possible. I have quite a lot tied up in my sub cables...almost $100 but I have three cables totaling over 50' length. And speaker cable is just inexpensive 12 gauge copper..even that is probably over kill.
bear123 is offline  
Sponsored Links
Advertisement
 
 

Tags
Speaker Systems , Svs , svs pb-2000 , Svs Pb1000 10 Inch 300 Watt Powered Subwoofer , Svs Pb12 Nsd Black Vinyl 12 Inch Powered Subwoofer , Svs Pb13 Ultra , Svs Pc12 Nsd 12 Inch 400 Watt Powered Cylinder Subwoofer , Svs Pc12 Ultra , Svs Sb1000 12 Inch 300 Watt Powered Subwoofer , Svs Sb12 Nsd Charcoal Black Vinyl 12 Inch 400 Watt Powered Subwoofer , Svs Sb13 Ultra Piano Gloss 13 Inch 1000 Watt Powered Subwoofer , Svs Sb2000
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off