Seaton Sound SubMersive1 - Page 25 - AVS Forum
Forum Jump: 
 35Likes
Reply
 
Thread Tools
post #721 of 9683 Old 02-19-2009, 11:21 AM
Member
 
kawika36's Avatar
 
Join Date: Jan 2004
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Adam-DiVine View Post

got my shipping notification today!!! The submersive should be here for this weekend. I will post some impressions as soon as I get it hooked up.

Sweet! Can't wait to hear some new impressions

When did you order? Trying to figure out where in line I am...
kawika36 is offline  
Sponsored Links
Advertisement
 
post #722 of 9683 Old 02-19-2009, 11:49 AM
Senior Member
 
Adam-DiVine's Avatar
 
Join Date: Jan 2004
Location: Belvidere, NJ
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
I paid on January 16th.
Adam-DiVine is offline  
post #723 of 9683 Old 02-19-2009, 07:14 PM
Member
 
Surge's Avatar
 
Join Date: Nov 2001
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by funlvr1965 View Post

Mark I know have been busy lately so I'm going to do you a favor and save you some time, since I will be seeing you at the GTG in Illinois on the 28th how about I drag down the Catalysts so you can update the DSPs?

Is the gtg public and will there be any Seaton products to listen to? Thanks Jon
Surge is offline  
post #724 of 9683 Old 02-19-2009, 07:44 PM
AVS Special Member
 
funlvr1965's Avatar
 
Join Date: Jan 2003
Location: MADISON wisconsin
Posts: 1,910
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 15
Here's what Marks says in the Feb 28th Illinois GTG thread
http://www.avsforum.com/avs-vb/showt...5#post15345785


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
funlvr1965 is offline  
post #725 of 9683 Old 02-20-2009, 07:43 AM
Senior Member
 
Adam-DiVine's Avatar
 
Join Date: Jan 2004
Location: Belvidere, NJ
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
My tracking updated and the submersive won't make it this weekend, it will be here on Monday. So I may not be able to post many impressions until next weekend.
Adam-DiVine is offline  
post #726 of 9683 Old 02-20-2009, 07:51 AM
Advanced Member
 
cubesys's Avatar
 
Join Date: Jun 2003
Location: MI
Posts: 667
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
be grateful you got Mark's "compact" sub. I remember the night we had to move two terraforms at 165lbs each down to the basement.

Itai

Did I mention we are flat to 11?
cubesys is offline  
post #727 of 9683 Old 02-21-2009, 04:42 AM
Member
 
duwdu's Avatar
 
Join Date: Sep 2003
Posts: 175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by cubesys View Post

Did I mention we are flat to 11?

Now, this is sweet.

My audio listening nirvana is best served rich ... with bass very well done.
duwdu is offline  
post #728 of 9683 Old 02-21-2009, 06:54 AM
AVS Addicted Member
 
Stereodude's Avatar
 
Join Date: Jan 2002
Location: Detroit Metro Area
Posts: 10,000
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 561 Post(s)
Liked: 554
Quote:
Originally Posted by cubesys View Post

be grateful you got Mark's "compact" sub. I remember the night we had to move two terraforms at 165lbs each down to the basement.

By "we" do you mean Mark and Kevin?
Stereodude is online now  
post #729 of 9683 Old 02-21-2009, 11:32 AM
Advanced Member
 
cubesys's Avatar
 
Join Date: Jun 2003
Location: MI
Posts: 667
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
YES! yes I do, and I even have picutres to prove it... I knew I was management material after all. All kidding aside, Kevin's help was great in getting these beasts into place.

Itai

Did I mention we are flat to 11?
cubesys is offline  
post #730 of 9683 Old 02-24-2009, 11:44 AM
Senior Member
 
Adam-DiVine's Avatar
 
Join Date: Jan 2004
Location: Belvidere, NJ
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
I just checked my email... apparently, I have a large package sitting on my doorstep!!
Adam-DiVine is offline  
post #731 of 9683 Old 02-24-2009, 11:50 AM
otk
AVS Special Member
 
otk's Avatar
 
Join Date: Jul 2006
Posts: 7,496
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 15
Quote:
Originally Posted by Adam-DiVine View Post

I just checked my email... apparently, I have a large package sitting on my doorstep!!

nice! i'm going to drive up 206 and look around for it

All this noise about noise.
♪♫♪♫♪♫♪♫♪♫♪♫♪♫♪♫♪♫♪♫♪♫♪♫

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
otk is offline  
post #732 of 9683 Old 02-24-2009, 12:31 PM
AVS Special Member
 
MIkeDuke's Avatar
 
Join Date: Dec 2004
Location: eastern PA
Posts: 6,275
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 115 Post(s)
Liked: 75
Quote:
Originally Posted by adam-divine View Post

i just checked my email... Apparently, i have a large package sitting on my doorstep!!


I am interested in how it was packaged. I think I was a testbed for Mark's shipping techniques. Just wondering how it was packaged and what kind of box it was.

It ain't easy being green.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
MIkeDuke is offline  
post #733 of 9683 Old 02-24-2009, 02:40 PM
Senior Member
 
Adam-DiVine's Avatar
 
Join Date: Jan 2004
Location: Belvidere, NJ
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
Mike,

As soon as I get home I will snap some pics of the packaging. I was really relieved that the package was sent FedEx. I am in the middle of a fight with UPS right now over an insurance claim on a receiver that I purchased. It has been over a month so far with no resolution. UPS suuuckkkkss!!

So even when I get the Submersive out of the package, I have no real good way to test it out. Right now, I am running my mains off of a really old Onkyo (~circa 1989) stereo receiver that I had laying around. It doesn't have a sub out. Does the submersive have a crossover in the amp? I didn't care before, but now it may allow me to try it out. I am thinking of maybe using the tape loop output on the receiver to give a signal to the sub. Will this work?Once I get things ironed out with UPS, I will have a B&K AVR507 to run things (which should be an improvement over the Onkyo!). Till then I just have to make due with what I have.
Adam-DiVine is offline  
post #734 of 9683 Old 02-24-2009, 03:02 PM
Senior Member
 
Adam-DiVine's Avatar
 
Join Date: Jan 2004
Location: Belvidere, NJ
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
I want to choke the guy from UPS for throwing my receiver on the ground. I guess I may have to look to for an ultra cheap temporary receiver to bridge the gap. Any suggestions?

It is just too much frustration to have to look at that wonderful sub with no way to use it!!!!!!!!
Adam-DiVine is offline  
post #735 of 9683 Old 02-24-2009, 03:24 PM
AVS Special Member
 
croseiv's Avatar
 
Join Date: Aug 2007
Posts: 2,654
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by Adam-DiVine View Post

I want to choke the guy from UPS for throwing my receiver on the ground. I guess I may have to look to for an ultra cheap temporary receiver to bridge the gap. Any suggestions?

It is just too much frustration to have to look at that wonderful sub with no way to use it!!!!!!!!

Wow!! It would drive me NUTS looking at that awesome sub and not being able to use it.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
croseiv is offline  
post #736 of 9683 Old 02-24-2009, 03:34 PM
AVS Special Member
 
MIkeDuke's Avatar
 
Join Date: Dec 2004
Location: eastern PA
Posts: 6,275
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 115 Post(s)
Liked: 75
Thanks for the pictures Mark. It does look nice and snug. For me, there was an extra test. Mark had to roll it UP about 12-14 steps. Even with that it emerged in perfect condition.
Adam, sorry to hear about your receiver issue. My first dolby digital receiver, after my Yamaha Prologic one, was a denon. They are probably still very good and they should have a few that are pretty reasonable.

It ain't easy being green.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
MIkeDuke is offline  
post #737 of 9683 Old 02-24-2009, 03:44 PM
AVS Special Member
 
goonstopher's Avatar
 
Join Date: Dec 2008
Location: NJ near NYC
Posts: 4,169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
In the past 2 months UPS has destroyed my:

Studio 60 v3's (2)
Definitive Technology clr 2500

Fedex:

Totalled my AV rack

Everything that gets delivered in my area gets destroyed...
goonstopher is offline  
post #738 of 9683 Old 02-25-2009, 06:42 AM
AVS Special Member
 
Mark Seaton's Avatar
 
Join Date: Jul 2000
Location: Chicago, IL, USA
Posts: 6,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 270
Quote:
Originally Posted by Adam-DiVine View Post

Mike,

As soon as I get home I will snap some pics of the packaging. I was really relieved that the package was sent FedEx. I am in the middle of a fight with UPS right now over an insurance claim on a receiver that I purchased. It has been over a month so far with no resolution. UPS suuuckkkkss!!

So even when I get the Submersive out of the package, I have no real good way to test it out. Right now, I am running my mains off of a really old Onkyo (~circa 1989) stereo receiver that I had laying around. It doesn't have a sub out. Does the submersive have a crossover in the amp? I didn't care before, but now it may allow me to try it out. I am thinking of maybe using the tape loop output on the receiver to give a signal to the sub. Will this work?Once I get things ironed out with UPS, I will have a B&K AVR507 to run things (which should be an improvement over the Onkyo!). Till then I just have to make due with what I have.

Hi Adam,


The SubMersive has no variable low pass other than an upper limit of about 200Hz. It needs a line level connection (not speaker), so an inexpensive receiver might be a better stopgap solution.

Mark Seaton
Seaton Sound, Inc.
"Make no little plans; they have no magic to stir men's blood..." Daniel H. Burnham
Mark Seaton is offline  
post #739 of 9683 Old 02-25-2009, 06:57 AM
AVS Special Member
 
Mark Seaton's Avatar
 
Join Date: Jul 2000
Location: Chicago, IL, USA
Posts: 6,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 270
Quote:
Originally Posted by MIkeDuke View Post


I am interested in how it was packaged. I think I was a testbed for Mark's shipping techniques. Just wondering how it was packaged and what kind of box it was.

Hi Mike,

Current packaging has 2" or thicker full foam panels on all 6 sides with all 12 edges of the box backed by a very strong, L-shaped chipboard backer. This protects against both corner crushing and mid-edge impacts such as curbs or stairs. This packaging is rather time intensive and will be executed a bit differently in the coming months with equal or better protection while taking less time to assemble.

Here are two older pics of the current packaging from my forum:




Mark Seaton
Seaton Sound, Inc.
"Make no little plans; they have no magic to stir men's blood..." Daniel H. Burnham
Mark Seaton is offline  
post #740 of 9683 Old 02-25-2009, 06:58 AM
AVS Special Member
 
Mark Seaton's Avatar
 
Join Date: Jul 2000
Location: Chicago, IL, USA
Posts: 6,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 270
Quote:
Originally Posted by Stereodude View Post

By "we" do you mean Mark and Kevin?

Quote:
Originally Posted by cubesys View Post

YES! yes I do, and I even have picutres to prove it... I knew I was management material after all. All kidding aside, Kevin's help was great in getting these beasts into place.

Someone had to take the pictures!

Mark Seaton
Seaton Sound, Inc.
"Make no little plans; they have no magic to stir men's blood..." Daniel H. Burnham
Mark Seaton is offline  
post #741 of 9683 Old 02-25-2009, 07:41 AM
AVS Special Member
 
Johnsteph10's Avatar
 
Join Date: Aug 2004
Location: GA
Posts: 4,285
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 20
As my dad is fond of saying, you want friends who have strong backs and weak minds.


John
Johnsteph10 is offline  
post #742 of 9683 Old 02-25-2009, 04:51 PM
AVS Special Member
 
sean_w_smith's Avatar
 
Join Date: Jan 2005
Location: Los Altos, CA and Huntsville, UT
Posts: 4,292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
So Adam please tell....

mine arrived with perfect packaging and looked unmollested. Can't say that for the 6 MFW-15's I have received..... They look they had been through a war.

Mark inidicated UPS Sorts by hand and Fedex with conveyor belts and he designed his packaging to work well with the shipper he uses (fedex). The end result seems to work very well...

Sean
sean_w_smith is offline  
post #743 of 9683 Old 02-25-2009, 05:41 PM
AVS Special Member
 
Johnsteph10's Avatar
 
Join Date: Aug 2004
Location: GA
Posts: 4,285
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 20
Quote:
Originally Posted by cubesys View Post

be grateful you got Mark's "compact" sub. I remember the night we had to move two terraforms at 165lbs each down to the basement.

I'm waiting for my turn....

John
Johnsteph10 is offline  
post #744 of 9683 Old 02-25-2009, 05:50 PM
Senior Member
 
Adam-DiVine's Avatar
 
Join Date: Jan 2004
Location: Belvidere, NJ
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
The package is fine. I haven't had a chance to unpack it yet. I will definitely get to it this weekend. I guess I am just not as excited since I have no way to actually use the sub. I looked at some cheap receivers today, but I just don't know if I can justify the expense for such a short term need. I am really hoping that UPS will resolve my issue so I can use the receiver I already paid for!!.
Adam-DiVine is offline  
post #745 of 9683 Old 02-25-2009, 06:17 PM
AVS Special Member
 
goonstopher's Avatar
 
Join Date: Dec 2008
Location: NJ near NYC
Posts: 4,169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Quote:
Originally Posted by Adam-DiVine View Post

The package is fine. I haven't had a chance to unpack it yet. I will definitely get to it this weekend. I guess I am just not as excited since I have no way to actually use the sub. I looked at some cheap receivers today, but I just don't know if I can justify the expense for such a short term need. I am really hoping that UPS will resolve my issue so I can use the receiver I already paid for!!.

If you are waiting on UPS it might not be a short time, my situation is complex but i have been waiting 3 months for them to handle my claim.
goonstopher is offline  
post #746 of 9683 Old 02-25-2009, 10:04 PM
AVS Special Member
 
warlord260's Avatar
 
Join Date: Aug 2007
Location: kent,wa.
Posts: 1,350
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Adam-DiVine View Post

The package is fine. I haven't had a chance to unpack it yet. I will definitely get to it this weekend. I guess I am just not as excited since I have no way to actually use the sub. I looked at some cheap receivers today, but I just don't know if I can justify the expense for such a short term need. I am really hoping that UPS will resolve my issue so I can use the receiver I already paid for!!.

if you dont mind me asking what receiver was it?
you could always get a receiver that has a 30 day return policy.
if i was you i would be going crazy, not that i am not already!
warlord260 is offline  
post #747 of 9683 Old 02-26-2009, 10:39 AM
Senior Member
 
Adam-DiVine's Avatar
 
Join Date: Jan 2004
Location: Belvidere, NJ
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
OK, I opened up the sub this morning (yes, I did take pictures - I will post them after work) and I have few questions:

Does it matter which side of the sub faces forward? I can't remember if both 15"'s are active or if one is passive. How do you tell?

Also, I am having trouble with the connector for the power cord. I have never used this type of connector before, but it seems like it is supposed to twist-lock into place. I tried to twist it after inserting the connector and stopped for fear of breaking it. I know I am doing something wrong because the connector falls out too easily without some sort of locking mechanism.

Thanks for any help.

Warlord,

I was looking at some refurbished Denon units from Dakmart. I'm not sure what the return policy is on those. Anyway, I think I am going to wait until my situation with UPS is resolved. I stretched my budget already to get the submersive, I will just have to be patient and hope that UPS honors the insurance on the damaged receiver.
Adam-DiVine is offline  
post #748 of 9683 Old 02-26-2009, 10:51 AM
AVS Special Member
 
MIkeDuke's Avatar
 
Join Date: Dec 2004
Location: eastern PA
Posts: 6,275
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 115 Post(s)
Liked: 75
Quote:
Originally Posted by Adam-DiVine View Post

OK, I opened up the sub this morning (yes, I did take pictures - I will post them after work) and I have few questions:

Does it matter which side of the sub faces forward? I can't remember if both 15"'s are active or if one is passive. How do you tell?

Also, I am having trouble with the connector for the power cord. I have never used this type of connector before, but it seems like it is supposed to twist-lock into place. I tried to twist it after inserting the connector and stopped for fear of breaking it. I know I am doing something wrong because the connector falls out too easily without some sort of locking mechanism.

Thanks for any help.

Warlord,


I was looking at some refurbished Denon units from Dakmart. I'm not sure what the return policy is on those. Anyway, I think I am going to wait until my situation with UPS is resolved. I stretched my budget already to get the submersive, I will just have to be patient and hope that UPS honors the insurance on the damaged receiver.

It should not matter. Both drivers are active. Mark set mine up with the controls facing the wall(long ways) but I think he could have set it up the other way if he wanted. Not sure about the power cord. As I said, Mark did everything for me.

It ain't easy being green.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
MIkeDuke is offline  
post #749 of 9683 Old 02-26-2009, 10:55 AM
AVS Special Member
 
Mark Seaton's Avatar
 
Join Date: Jul 2000
Location: Chicago, IL, USA
Posts: 6,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 270
Quote:
Originally Posted by Adam-DiVine View Post

OK, I opened up the sub this morning (yes, I did take pictures - I will post them after work) and I have few questions:

Does it matter which side of the sub faces forward? I can't remember if both 15"'s are active or if one is passive. How do you tell?

Also, I am having trouble with the connector for the power cord. I have never used this type of connector before, but it seems like it is supposed to twist-lock into place. I tried to twist it after inserting the connector and stopped for fear of breaking it. I know I am doing something wrong because the connector falls out too easily without some sort of locking mechanism.

Hi Adam,

The blue connector pushes into the blue receptacle and then turns to the right with the metal tab starting around 10 o'clock on the dial and ending at 12 o'clock. With the first few inserts it can be a little snug, but so long as you push it all the way in so the collar is flush with the plate, just turn until it locks at 12 o'clock.

Both drivers are active, so there is no "front" to worry about. You want to maintain 3" or more in front of either grill if firing into a wall, but that's all that is needed. Of course you can also angle it in a corner if you like. It is generally intended for the amplifier face the wall.

Mark Seaton
Seaton Sound, Inc.
"Make no little plans; they have no magic to stir men's blood..." Daniel H. Burnham
Mark Seaton is offline  
post #750 of 9683 Old 02-26-2009, 12:13 PM
Senior Member
 
Adam-DiVine's Avatar
 
Join Date: Jan 2004
Location: Belvidere, NJ
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
Thanks for the response guys. I figured that the connector worked that way; I can see the small metal tab that should lock into place. I will try it again when I get home, it just seemed like it didn't want to turn. I'm sure I was being too gentle though.

Mark,

Was my order supposed to come with the calibration DVD? Just wondering, I didn't see it anywhere in the box. Hopefully I can give some listening impressions soon!

Thanks,

Adam
Adam-DiVine is offline  
Reply Subwoofers, Bass, and Transducers

Tags
Seaton Sound , Velodyne Dd 15 Digital Drive Subwoofer 15 Inch Gloss Black , Velodyne , Speaker Systems , New Pac Sni 1 Ground Loop Signal Isolator

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off