Official Outlaw Owners thread - Page 253 - AVS Forum | Home Theater Discussions And Reviews

Forum Jump: 
 39Likes
Reply
 
Thread Tools
post #7561 of 7569 Old 11-23-2016, 02:20 PM
Advanced Member
 
Radio81's Avatar
 
Join Date: Nov 2008
Posts: 550
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 160 Post(s)
Liked: 64
Quote:
Originally Posted by goldmastaflexx View Post
Thats great to hear! I was worried as I didnt see many reviews of the Ultra X12 but bought it as it was on sale for Black Friday. Looks like best bang for the $.. I might try them both together and if I run into trouble will try to sell the old Klipsch I guess
Once you get the X12 configured, I recommend trying it with the pod race scene from Star Wars The Phantom Menace. It's awesome.

Sent from my LG-H900 using Tapatalk
Radio81 is offline  
Sponsored Links
Advertisement
 
post #7562 of 7569 Old 11-25-2016, 12:22 PM
AVS Special Member
 
Transmaniacon's Avatar
 
Join Date: Oct 2009
Location: Raleigh, NC
Posts: 6,098
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1529 Post(s)
Liked: 1314
The X12 is a fantastic sub!! You will be in for a treat for sure, along with the pod race scene, I recommend watching War Of The Worlds!


Sent from my iPhone using Tapatalk

Samsung PN60F5300 | Denon AVR-1713 | EMP E55Ti | EMP E56Ci | EMP E5Bi | Outlaw Ultra-X12
Transmaniacon is online now  
post #7563 of 7569 Old 11-25-2016, 04:17 PM
Member
 
goldmastaflexx's Avatar
 
Join Date: May 2014
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Liked: 14
Quote:
Originally Posted by Transmaniacon View Post
The X12 is a fantastic sub!! You will be in for a treat for sure, along with the pod race scene, I recommend watching War Of The Worlds!


Sent from my iPhone using Tapatalk
Nice! Will do.. What setting do you guys run ur X12 in? Should I leave it on Max output or Max Extender? Dont want to keep changing the setting and I do 80% movies 20% music.
goldmastaflexx is offline  
post #7564 of 7569 Old 11-25-2016, 04:45 PM
AVS Special Member
 
Transmaniacon's Avatar
 
Join Date: Oct 2009
Location: Raleigh, NC
Posts: 6,098
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1529 Post(s)
Liked: 1314
Quote:
Originally Posted by goldmastaflexx View Post
Nice! Will do.. What setting do you guys run ur X12 in? Should I leave it on Max output or Max Extender? Dont want to keep changing the setting and I do 80% movies 20% music.


I use mine in max extension mode since I'm in an apartment and don't need all the output. Even still I'm only at 25% gain and -6dB trim in my receiver and it's quite loud. Unless you're in a massive room I would keep it in extension mode.


Sent from my iPhone using Tapatalk

Samsung PN60F5300 | Denon AVR-1713 | EMP E55Ti | EMP E56Ci | EMP E5Bi | Outlaw Ultra-X12
Transmaniacon is online now  
post #7565 of 7569 Old 11-30-2016, 05:33 PM
Member
 
goldmastaflexx's Avatar
 
Join Date: May 2014
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Liked: 14
Official Outlaw Owners thread

Hey guys,
I finally hooked up my ultra x12! How did you guys get the brown sticker of the sub? I can't seem to remove it and trying to peel it is a slow process.

Also do you use the receiver to set the crossover or are you using the settings on the sub?

Sent from my iPhone using Tapatalk
goldmastaflexx is offline  
post #7566 of 7569 Old 11-30-2016, 07:08 PM
AVS Special Member
 
Join Date: Sep 2014
Location: Northern NJ & Myrtle Beach area, SC
Posts: 1,193
Mentioned: 8 Post(s)
Tagged: 1 Thread(s)
Quoted: 590 Post(s)
Liked: 271
I bought an X-12 last year. After a few months I just slowly peeled back the brown paper to expose the nice top. And settings are in my AVR using the LFE input. Set the crossover dial accordingly in back, read the Outlaw manual; good luck
yanks1 is online now  
post #7567 of 7569 Old 12-01-2016, 01:19 AM
Member
 
goldmastaflexx's Avatar
 
Join Date: May 2014
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
Liked: 14
Quote:
Originally Posted by yanks1 View Post
I bought an X-12 last year. After a few months I just slowly peeled back the brown paper to expose the nice top. And settings are in my AVR using the LFE input. Set the crossover dial accordingly in back, read the Outlaw manual; good luck


Do you mainly use it in extended mode or max output? I tested extended mode all night and feels like it's missing that extra thump.


Sent from my iPhone using Tapatalk
goldmastaflexx is offline  
post #7568 of 7569 Old 12-01-2016, 07:49 AM
AVS Special Member
 
Join Date: Sep 2014
Location: Northern NJ & Myrtle Beach area, SC
Posts: 1,193
Mentioned: 8 Post(s)
Tagged: 1 Thread(s)
Quoted: 590 Post(s)
Liked: 271
So far primarily have both ports open. I am not a big basshead, but do plan to experiment more with 1 port plugged. It's at our vacation/2nd home so don't have much time there to play with my audio toys enough
yanks1 is online now  
post #7569 of 7569 Old Today, 06:38 AM
Member
 
Join Date: Mar 2015
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 0
I got my 2 Outlaw subs Monday and set them up. I haven't had time to recalibrate my room yet. I was wondering if anyone has ran one in extended mode, and other in max? If there would be any benefit to trying this?
nxs450 is online now  
Sponsored Links
Advertisement
 
Reply Subwoofers, Bass, and Transducers



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off