Official Outlaw Owners thread - Page 6 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #151 of 7120 Old 01-08-2008, 08:08 PM
Senior Member
 
Bob A (SD)'s Avatar
 
Join Date: Aug 2002
Location: South Dakota
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by laulau View Post


@Bob,
Glad to read (in the Outlaw Sale thread) that you were pleased with the Compact. That's a pretty good sized room you're trying fill.

Yeah things are working out great. I did recheck my measurements and the room actually is 3,426 ft3 (26' x 17' x 7.75'). That's still above the recommended max of 3k but I think they may have been a tad conservative.

I also appreciate the lead you've taken with the dimpled discs. I figure mine will show mid-next week

Best!
--Bob

-=[Bob]=-
My systems
Bob A (SD) is offline  
Sponsored Links
Advertisement
 
post #152 of 7120 Old 01-08-2008, 08:57 PM
Senior Member
 
txmatt's Avatar
 
Join Date: Oct 2005
Posts: 225
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Bob A (SD) View Post

Jasenj1,
I found your comments interesting about not only the great EX performance but your thinking that a smaller Outlaw sub would still have been an improvement over the old Polk. Were you referring to the discontinued LFM-1 or the new LFM-1 compact in that context? Just curious.
--Bob

Let me say I haven't heard any of the other Outlaw subs, but with the performance differential between the PSW650 and the LFM-1 EX, I bet the the LFM-1 compact would outperform the PSW650 and I wouldn't be shocked if the LFM-2 matched or exceeded the Polk's performance. That Polk is probably 6+ years old and I think subwoofers have progressed a long way since then. That and the "old" Polk has many hours of use on it by now.

...looking up some numbers...

Just did a search and it appears the claimed -3dB point for the PSW650 was 28Hz. Outlaw claims the LFM-1 Compact is -2dB at 25Hz and the LFM-2 is -2dB at 28Hz. Those numbers might seems to support my comparative guesses above.
txmatt is offline  
post #153 of 7120 Old 01-08-2008, 09:06 PM
Senior Member
 
Bob A (SD)'s Avatar
 
Join Date: Aug 2002
Location: South Dakota
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks txmatt. I wasn't familiar with that Polk sub but with what you've provided it all makes sense now.

-=[Bob]=-
My systems
Bob A (SD) is offline  
post #154 of 7120 Old 01-09-2008, 04:20 PM
Senior Member
 
Kpilk's Avatar
 
Join Date: Dec 2007
Posts: 331
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 23
Got my LMF-1c unpacked last night. Really a nice finish. I haven't got my system together so no report on sound. I'm a bit surprised with the paper type cone. I have been around subs quite a bit in car audio and most of the best SQ subs I tried had lighter weight 'paper' type cones. I wouldn't call this light weight, but it certainly looks like it should be musical, which is my main goal.

I wonder if all the Outlaws use the same driver sub, or HSU and the others for that matter. I do like the down port/down driver idea now that I see it. It allows for more flexible placement in and along the wall. I can run the wires out of the entertainment center and straight into the amp without having to expose the port or sub to the home 'elements'.

Hopefully my system will be ready to install in a week or so. Still deciding on LRC.
Kpilk is offline  
post #155 of 7120 Old 01-11-2008, 06:22 PM
Senior Member
 
Bob A (SD)'s Avatar
 
Join Date: Aug 2002
Location: South Dakota
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Received the dimpled disks today and installed them under the large thermoplastic spiked feet. Nice quality thick metal with felt pads on the lower side. Excellent customer service from Outlaw.

-=[Bob]=-
My systems
Bob A (SD) is offline  
post #156 of 7120 Old 01-11-2008, 07:52 PM
Senior Member
 
mulesqb's Avatar
 
Join Date: Jan 2003
Location: Putnam , NY
Posts: 416
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Finally received my LFM1-EX today. What a beast! It is awesome! It was an upgrade from the STF-2. It makes a world of difference - more than I thought it would. It came wrapped in a black blanket and double boxed. Only negative was that it didn't have an instruction manual in the box. No biggie as i just printed it out now off the Outlaw website. I'll keep playing all weekend and report back on Monday. Although I 've never done it before - i'll try to post a few pics. Although I didn't post much - thanks to everyone here and in the sale thread for guidance. i did all my research through these two threads.

If you have to tell people how good you are, you're not as good as you think.
mulesqb is offline  
post #157 of 7120 Old 01-12-2008, 03:17 PM
Senior Member
 
Bob A (SD)'s Avatar
 
Join Date: Aug 2002
Location: South Dakota
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I received an e-mail this morning indicating that because Outlaw ran out of their LFM-1+ they are continuing their holiday sale pricing on the LFM-1EX.

From all the comments it would appear that the EX is an outstanding choice. I know it would have mated with my 3,426 ft3 room better than than the 1c I did buy but (1) I remain content with the compact's performance, and (2) really couldn't see my way clear to the extra cost of the bigger sub. That said the $549 "substitute promotion" EX pricing is quite a deal for those whose budgets can support it.

-=[Bob]=-
My systems
Bob A (SD) is offline  
post #158 of 7120 Old 01-13-2008, 03:16 PM
Member
 
jasenj1's Avatar
 
Join Date: Jul 2005
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 16
I posted some comments about my LFM-1C and a graph with some measurements here.

So far I'm very pleased.

- Jasen.
jasenj1 is offline  
post #159 of 7120 Old 01-14-2008, 07:28 AM
Senior Member
 
mulesqb's Avatar
 
Join Date: Jan 2003
Location: Putnam , NY
Posts: 416
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Spent some time this weekend playing with the LFM-1 EX. As mentioned, I upgraded from a STF-2. It is more of an upgrade than I thought it would be. I'm no expert but the bass just spreads around the room more, is richer and deeper and really just makes my system complete. I have Polk Rti10s, CSi5 up front with the Denon 3808. Watched King Kong and Transformers with my boys. From previous viewings I remember a lot of rattle in the room. This time it was just deeper and truer sounding (not sure if that makes sense to anyone). It just sounded incredibly powerful. My kids wanted to watch Batman Returns yesterday and for an older DVD, the audio was excellent. Overall I just notice the bass a lot more, and it sounds like its not trying very hard. Sorry I don't have better terminology for this stuff, but I am ecstatic with this purchase. Oh yeah, during my beloved Giant game yesterday, we all noticed the bass like never before with all the fox graphics. Although my wife did say the loudest thump she heard all weekend was when I jumped up after RW's interception.

If you have to tell people how good you are, you're not as good as you think.
mulesqb is offline  
post #160 of 7120 Old 01-15-2008, 11:59 AM
Koy
Member
 
Koy's Avatar
 
Join Date: Nov 2003
Location: NYC
Posts: 148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just pulled the trigger on the LFM-1EX. It is still on sale for $549 ($630 with shipping). I had originally ordered the ED A3-300 but cancelled since it was a 6-8 week wait.

PSN: Bloodstryke
Live: Ferocious Gamer
Koy is offline  
post #161 of 7120 Old 01-15-2008, 01:58 PM
Advanced Member
 
sterankoman's Avatar
 
Join Date: Mar 2007
Location: Louisville, Ky
Posts: 743
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by mulesqb View Post

Oh yeah, during my beloved Giant game yesterday, we all noticed the bass like never before with all the fox graphics. Although my wife did say the loudest thump she heard all weekend was when I jumped up after RW's interception.

I like to watch football and the SciFi channel with my HT system (Outlaw sub) up and running. The networks are pumping out some nice deep bass recently.
sterankoman is offline  
post #162 of 7120 Old 01-15-2008, 02:08 PM
Member
 
openhelix's Avatar
 
Join Date: Jan 2006
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I've noticed both the LFM-1+ and the LFM-1EX get a LOT better after some break in. The first day or two always seems a little ho-hum, then the sub really comes into it's own after ~10-20 hours of use. The bass is deeper and more refined and hits harder.

Anyone have any thoughts on running with or without the port plug?
openhelix is offline  
post #163 of 7120 Old 01-15-2008, 03:27 PM
Member
 
lanion's Avatar
 
Join Date: Jul 2007
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
With the port plug I get flat to 15hz in my little room... so that is what I use! Bring on the Organ music! I have an MBM-12 as well, so I'm not worried about a sacrifice in mid-bass performance. To be honest I have not tried in Max Output at all really, and considering I have never hit any limit yet with the sub (except when playing with 10hz test tones), so I see no reason to add output.
lanion is offline  
post #164 of 7120 Old 01-15-2008, 03:58 PM
Member
 
openhelix's Avatar
 
Join Date: Jan 2006
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
nice! what volume/gain are you using on your EX lanion? Currently I have mine set for max output (no plug) and ~5-6 on the volume knob for a 15x20x10 room.
openhelix is offline  
post #165 of 7120 Old 01-15-2008, 05:18 PM
Member
 
lanion's Avatar
 
Join Date: Jul 2007
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
well, It is going through an SMS-1, so it is hard to compare but I think it is at 1/4 volume set to max-extension with one port plugged. My room is 10x10x8, so I have sub overkill in there! (would be great to pump it up except for a paper-thin ceiling to my neighbors -- apparently I was shaking their computer keyboard so they couldn't type, but what do you expect when a meteor hits the Earth!).

It could definitely handle a MUCH larger room since my LFM-2 has no trouble filling my living room with good bass for music and material >25hz.
lanion is offline  
post #166 of 7120 Old 01-15-2008, 06:50 PM
Advanced Member
 
tcat's Avatar
 
Join Date: Nov 2001
Location: Austin TX
Posts: 934
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Any problem taking an LFM-1EX and laying it on its face so the driver and ports are facing out from a cabinet? I've read that vertical orientaion for a driver is better than horizontal.

http://www.outlawaudio.com/images/EXbottommain.gif
tcat is offline  
post #167 of 7120 Old 01-16-2008, 07:05 AM
Senior Member
 
mulesqb's Avatar
 
Join Date: Jan 2003
Location: Putnam , NY
Posts: 416
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by openhelix View Post

I've noticed both the LFM-1+ and the LFM-1EX get a LOT better after some break in. The first day or two always seems a little ho-hum, then the sub really comes into it's own after ~10-20 hours of use. The bass is deeper and more refined and hits harder.

Anyone have any thoughts on running with or without the port plug?

I have my volume set in the 4/5 range with plug. Can't imagine having more bass. But I'll try it in max mode and see what happens. My room is 14 x 20 x 8.

If you have to tell people how good you are, you're not as good as you think.
mulesqb is offline  
post #168 of 7120 Old 01-16-2008, 02:47 PM
Advanced Member
 
met64's Avatar
 
Join Date: Nov 2005
Posts: 534
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
I own the LFM1 EX and LOVE IT!! Problem is... the auto sensing feature; no matter what format (dvd, music, tv, etc). this feature just isn't working. I have the LFE set at 80 (Onkyo 805) driving the sub and my Polk RTi10's and CSi5 and rears FXi3. I switched out cables; still not picking up the audio sensing from my Onkyo??? I wonder if its the receiver? Any ideas/Suggestions?

Thxs!!!
met64 is offline  
post #169 of 7120 Old 01-17-2008, 03:37 PM
Newbie
 
bigasia00's Avatar
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey laulau, I'm just curious. My LF1-EX should hopefully be here tomorrow, and I was reading over the forums just to get even more info on it, and more warm fuzzy's as well.
I saw you had ordered the LF1 compact, and that you had the Onkyo 705. I have the same receiver. I was just curious, what settings do you have the receiver at in terms of the subwoofer volume?
bigasia00 is offline  
post #170 of 7120 Old 01-17-2008, 04:34 PM
Senior Member
 
laulau's Avatar
 
Join Date: Nov 2004
Location: Oahu
Posts: 323
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 52
Quote:
Originally Posted by bigasia00 View Post

Hey laulau, I'm just curious. My LF1-EX should hopefully be here tomorrow, and I was reading over the forums just to get even more info on it, and more warm fuzzy's as well.
I saw you had ordered the LF1 compact, and that you had the Onkyo 705. I have the same receiver. I was just curious, what settings do you have the receiver at in terms of the subwoofer volume?


When I set up my system I set the volume control on the Compact to approx. the 11 o'clock position. I then ran the Audyssey calibration using 6 positions. Audyssey set the subwoofer volume on the 705 to -2, which is actually working very pretty good in my environment.

FWIW, on the 705 my subwoofer distance is set to 11.0 feet, crosses over at 90hz and all LFE are set at 0db. Also, the Compact itself is located near a corner of the room.

Of course your settings will be unique to your environment, but hope that helps.

...
Salk SongTowers-RAAL / SongCenter-RAAL / SongSurrounds; Rythmik F12 (x2); Denon AVR-4520CI; D-Sonic M2-800S; Oppo BDP93; Panny 65VT50; Schiit Audio Valhalla; Sennheiser HD600; BJC everywhere
WDTV Live Hub; Xbox 360; Harmony One; Furman Elite-15 PFi; Omnimic v2 & REW; CalMAN 5 HT; i1 Display Pro 3; i1 Pro2
laulau is offline  
post #171 of 7120 Old 01-18-2008, 06:38 AM
Advanced Member
 
weverb's Avatar
 
Join Date: Jan 2008
Location: Florida
Posts: 642
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
New to the forum and just joined the group by ordering a LFM-1EX today. It seemed to be a good deal while the sale is still on. I have been wanting a VTF3-MK3 for some time now, but just cannot afford to spend $800 on a sub. Maybe I will add a MBM-12 next year to get the max out of the LFM-1EX. Now comes the hard part.... waiting for its arrival.

Analog: Pioneer SX-950, CT-F9191, AD797MCPS, PL-707, RH-65, RG-1, SR-202, Monitor 10/HE-500 hp's
Digital: Laptop, M2tech Young, Oppo 83, Simaudio i5.3, Dali Mentor
weverb is offline  
post #172 of 7120 Old 01-18-2008, 08:45 AM
Newbie
 
bigasia00's Avatar
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks, I'm sure it will. Waiting for fedex as I type, so I'm sure this will be my weekend project (and a good one at that).
bigasia00 is offline  
post #173 of 7120 Old 01-18-2008, 03:24 PM
Member
 
tarche's Avatar
 
Join Date: Feb 2003
Location: Southeastern PA
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Any of you happy Outlaw owners coming from Def Tech origins? I have a PF15TL+ and I'm considering the on-sale LFM1-EX as an upgrade. The specs on the Def Tech are pretty good, but I can't help but think that the newer internet-only subs of the past 5 years have raised the bar. I like my sub, but can't help but wonder if there is another level of oomph I could be getting if I were to buy a new sub. Any insight would be appreciated.
tarche is offline  
post #174 of 7120 Old 01-22-2008, 08:58 PM
Senior Member
 
mulesqb's Avatar
 
Join Date: Jan 2003
Location: Putnam , NY
Posts: 416
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
More follow up: This sub has made my entire sustem sound so much better! My family is just enjoying the heck out of it. After a few days of the new sound we ended up going out and buying new theater recliners. I never imagined that a sub could make such a difference. If anyone is hesitating,all I can say is pull the trigger. At the new price the LFM-1 EX is an absolute steal and pound-for-pound the best piece of equipment I've bought.

If you have to tell people how good you are, you're not as good as you think.
mulesqb is offline  
post #175 of 7120 Old 01-23-2008, 11:55 AM
Senior Member
 
Bob A (SD)'s Avatar
 
Join Date: Aug 2002
Location: South Dakota
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by laulau View Post

When I set up my system I set the volume control on the Compact to approx. the 11 o'clock position. I then ran the Audyssey calibration using 6 positions. Audyssey set the subwoofer volume on the 705 to -2, which is actually working very pretty good in my environment.

FWIW, on the 705 my subwoofer distance is set to 11.0 feet, crosses over at 90hz and all LFE are set at 0db. Also, the Compact itself is located near a corner of the room.

Of course your settings will be unique to your environment, but hope that helps.

I too am running a TX-SR705 with my LFM-1c. My settings aren't all that much different from yours: 12.5' distance, xover 90Hz, -2dB sub volume, sub input sensitivity 5dB (see Analog Multich settings); and on the sub itself volume at 11 o'clock, xover "in" and set at 50Hz.

I was surprised to find that using both xovers gave the best results as did engaging the sensitivity setting on the receiver to eliminate any "booming." There are discussions elsewhere in this forum about using both a receiver and subwoofer xover to best effect.

-=[Bob]=-
My systems
Bob A (SD) is offline  
post #176 of 7120 Old 01-23-2008, 12:08 PM
Advanced Member
 
tcat's Avatar
 
Join Date: Nov 2001
Location: Austin TX
Posts: 934
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Curious.. doesn't setting the Sub Xover at 50hz. and the receiver at 90hz., mean you're losing everything from 50-90? I've always read that the sub should be set at Max xover if you're using your receiver's xover for the LFE output. I guess if your fronts are set at 50hz. on the receiver it wouldn't matter much.

Quote:
Originally Posted by Bob A (SD) View Post

I too am running a TX-SR705 with my LFM-1c. My settings aren't all that much different from yours: 12.5' distance, xover 90Hz, -2dB sub volume, sub input sensitivity 5dB (see Analog Multich settings); and on the sub itself volume at 11 o'clock, xover "in" and set at 50Hz.

I was surprised to find that using both xovers gave the best results as did engaging the sensitivity setting on the receiver to eliminate any "booming." There are discussions elsewhere in this forum about using both a receiver and subwoofer xover to best effect.

tcat is offline  
post #177 of 7120 Old 01-23-2008, 12:42 PM
Senior Member
 
Bob A (SD)'s Avatar
 
Join Date: Aug 2002
Location: South Dakota
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Tom,

Honestly it doesn't pass my sanity check either but there are a lot of things that are counter-intuitive. I believe the slopes of these respective crossovers have a great deal to do with the results. They are not so sharp as to "cut off" everything below 90Hz or above 50Hz. Bottom line is that it works well for my ears.

I didn't look for the thread on the use of both xovers but if memory serves what I'm doing was discussed.

--Bob

-=[Bob]=-
My systems
Bob A (SD) is offline  
post #178 of 7120 Old 01-31-2008, 09:52 PM
Senior Member
 
Kpilk's Avatar
 
Join Date: Dec 2007
Posts: 331
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 23
Got a question. Just plugged my Compact in tonight and don't have it hooked up to the receiver yet. I am just now getting my Sierras so tomorrow it all goes in. I just put the Sub selector to off, red light was on...normal. I just noticed that that the amp was putting off a fair amount of heat considering it was off. Will the amp still put off heat if not in use? I read the manual and it doesn't say anything about it. I also wonder how long the other owner's power plugs are. I had several power plugs with my gear waiting to install. I assumed the Outlaw had the heavy duty one which is about 8-10' long.
Kpilk is offline  
post #179 of 7120 Old 02-01-2008, 06:47 AM
Advanced Member
 
sterankoman's Avatar
 
Join Date: Mar 2007
Location: Louisville, Ky
Posts: 743
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Kpilk View Post

Got a question. Just plugged my Compact in tonight and don't have it hooked up to the receiver yet. I am just now getting my Sierras so tomorrow it all goes in. I just put the Sub selector to off, red light was on...normal. I just noticed that that the amp was putting off a fair amount of heat considering it was off. Will the amp still put off heat if not in use? I read the manual and it doesn't say anything about it. I also wonder how long the other owner's power plugs are. I had several power plugs with my gear waiting to install. I assumed the Outlaw had the heavy duty one which is about 8-10' long.

My Outlaw compact had an amp that ran very hot to the touch. It lasted 1 hour before failure. I contacted the Outlaw boys and they had a new amp on the way to me that day. I swapped them and returned the bad amp (at no cost to me) and it is running cool as a cucumber since. Sorry, but I think you are in for a failed amp. I would contact Outlaw today and ask them to send you a new amp.
sterankoman is offline  
post #180 of 7120 Old 02-02-2008, 06:44 AM
Senior Member
 
Kpilk's Avatar
 
Join Date: Dec 2007
Posts: 331
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 23
Quote:
Originally Posted by sterankoman View Post

My Outlaw compact had an amp that ran very hot to the touch. It lasted 1 hour before failure. I contacted the Outlaw boys and they had a new amp on the way to me that day. I swapped them and returned the bad amp (at no cost to me) and it is running cool as a cucumber since. Sorry, but I think you are in for a failed amp. I would contact Outlaw today and ask them to send you a new amp.

Thanks. I got everything together and it works fine. In the auto position and with the system off, therefore the sub amp off (red light) it still maintains some heat. In the OFF position, it really is off and puts off no heat. When its running with the system it doesn't seem to get any hotter. Its not 'hot', but just putting out heat when not in use. Seems strange to me. I will keep an eye on it and call Outlaw and ask them a few questions.
Kpilk is offline  
Reply Subwoofers, Bass, and Transducers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off