Mystifying digital audio problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 12-08-2009, 07:56 PM - Thread Starter
Member
 
fendel's Avatar
 
Join Date: Jan 2004
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Wondering if anyone can advise me. I'm stumped.

I have a 2008 MacBook running Plex, outputting optical audio to an Onkyo receiver (have had the receiver some years -- audio only). I used to have this intermittent problem where the sound would drop out, and if I switched from Dolby Pro Logic (or Dolby Digital, depending on the file) to stereo and back again, the sound would be restored. It's been happening more and more lately, and now I usually have to cycle through inputs on the receiver, switch surround modes back and forth, and switch from digital to analog and back on the input... sometimes, after much blundering around, the sound comes back. Sometimes it doesn't. And I don't really know which particular bit of voodoo is actually doing the trick. I've gotten into full-on button-mashing mode in my frustration.

The worst seems to be MKV files with DTS audio. Those yield a loud buzzing sound over the built-in speaker, or total silence over optical audio out. But even stereo streaming audio from last.fm is cutting out on audio sometimes lately.

I have the same problem with my old 2006 Macbook, except it seems to be somewhat less severe.

If it's my receiver, I would be a happy camper. But I'm hesitant to spend the $ on a new receiver when I just don't know if that will fix it.
fendel is offline  
Reply HTPC - Mac Chat

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off