MadVR - ArgyllCMS - Page 113 - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 180Likes
Reply
 
Thread Tools
post #3361 of 3384 Old 04-20-2015, 05:49 AM
Member
 
Join Date: Nov 2014
Posts: 105
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 78 Post(s)
Liked: 5
^^^^
Just a correction: I checked my madVR settings and I found that I had set "16-235" (only on madVR, in all other places it is 0-255).
Pepelegal is offline  
Sponsored Links
Advertisement
 
post #3362 of 3384 Old 04-20-2015, 09:37 AM
Member
 
MarcusSwe's Avatar
 
Join Date: Dec 2010
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 10
Pepelegal: Thank you very much for all the guidance - I will try it now!


On another note, I'd thought I'd give it a go and calibrate my iMac (in target display mode using the PC) with DCG. The strange thing is that I got odd results here as well, once again at low IREs. No artifacts though. Here's all the files: http://s000.tinyupload.com/?file_id=...23385901054840

Low level gamma becomes way too "high" (comes out of black too fast). The calibrated 2.2-profile displays gamma 5 IRE@1,9, 10@2.0 and then it finishes at 2.2 from IRE 40 and onwards. This has me thinking: either the readings are wrong at low IRE (which seems strange since the reader measures correctly (and confirms what I am seeing) in Chromapure) or the applied gamma curve is set wrongly in DCG (it creates a 2.2-gamma at high IRE, but the curve resembles a 1886-gamma that is set "0,2 steps too low", so to say).

Are there any hidden gamma settings in DCG that I can enable? (now I can only choose 2.2, 2.4 and absolute or 1886 (though the absolute or 1886 seems to give the same results (1886-"slope"), i.e. when I choose 2.4, it doesn't matter if I select absolute or 1886, it gives the same results). Because if I could just manually force another gamma response, that would probably take care of the problem.

In the meantime, I will get back to the OLED

And huge thanks for creating such awesome software and all input from everyone else here at the forum!
Attached Files
File Type: zip Gamma.zip (41.7 KB, 6 views)
MarcusSwe is offline  
post #3363 of 3384 Old 04-20-2015, 12:09 PM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
A DCG beta snapshot update is available.

Changes in 2.9.1.0 beta:
  • When using madTPG during interactive display adjustment, automatically leave fullscreen, and re-enter fullscreen for non-interactive display measurements. Also, if the OSD is disabled, temporarily re-enable it for "put the instrument on screen" messages.
  • Fixed minor quirk of log messages being repeated multiple times in session logfiles (bug introduced in 2.9.0.9).


Changes in 2.9.0.9 beta (never announced, thus FYI):
  • Added a button to create a compressed archive (7z or ZIP) of the currently selected profile and related files.
  • When using Resolve, fixed the possibility of APL pattern background RGB values getting negative (and thus rejected by Resolve, leading to the displayed pattern not being updated) if the test color is bright and the chosen test patch area is large.
anta1974 likes this.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3364 of 3384 Old 04-20-2015, 01:41 PM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by MarcusSwe View Post
On another note, I'd thought I'd give it a go and calibrate my iMac (in target display mode using the PC) with DCG. The strange thing is that I got odd results here as well, once again at low IREs. No artifacts though. Here's all the files: http://s000.tinyupload.com/?file_id=...23385901054840
Always start from a preset that's appropriate for the job. The profile you uploaded doesn't contain high-quality tables that are needed for a display profile. You can fix this by going into the "Options" menu, selecting "Enhance effective resolution of PCS to device tables" and choosing the existing profile.

Quote:
Originally Posted by MarcusSwe View Post
[...] i.e. when I choose 2.4, it doesn't matter if I select absolute or 1886, it gives the same results).
Rec. BT 1886 is equivalent to 2.4 absolute with 0% black output offset.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3365 of 3384 Old 04-21-2015, 01:01 AM
AVS Special Member
 
sillysally's Avatar
 
Join Date: Jun 2006
Location: Chicago
Posts: 3,964
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 248 Post(s)
Liked: 332
Quote:
Originally Posted by fhoech View Post
A DCG beta snapshot update is available.

Changes in 2.9.1.0 beta:
[LIST][*]When using madTPG during interactive display adjustment, automatically leave fullscreen, and re-enter fullscreen for non-interactive display measurements. Also, if the OSD is disabled, temporarily re-enable it for "put the instrument on screen" messages.[*]Fixed minor quirk of log messages being repeated multiple times in session logfiles (bug introduced in 2.9.0.9).<<<snip>>>
Once I re-enter fullscreen display when running interactive display measurements, and OSD is enabled, a pup up comes up on the left top of the screen that says argyllCMS patches, no count down.
However all seems to work if OSD is disabled except for place meter on the screen patch and no count down.

When running a verification, I don't have to re-enter fullscreen display. The message for place K10 on screen come up and the count down starts.
Works as I would think it should.

btw, why are you asking to place meter on the patch/screen, when using meter in off screen mode?

ss
sillysally is offline  
post #3366 of 3384 Old 04-21-2015, 03:21 AM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by sillysally View Post
Once I re-enter fullscreen display when running interactive display measurements, and OSD is enabled, a pup up comes up on the left top of the screen that says argyllCMS patches, no count down.
However all seems to work if OSD is disabled except for place meter on the screen patch and no count down.
The count-down only appears in fullscreen when not doing interactive adjustment. It's meant as a work-around for a single-screen situation where both madTPG and the interactive adjustment window have to be on at the same time, i.e. you'd do the interactive adjustment while not in fullscreen.

Quote:
Originally Posted by sillysally View Post
btw, why are you asking to place meter on the patch/screen, when using meter in off screen mode?
Because there's no way to detect if the meter is used in contact mode or not.
anta1974 likes this.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3367 of 3384 Old 04-21-2015, 11:48 AM
AVS Special Member
 
sillysally's Avatar
 
Join Date: Jun 2006
Location: Chicago
Posts: 3,964
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 248 Post(s)
Liked: 332
Quote:
Originally Posted by fhoech View Post
The count-down only appears in fullscreen when not doing interactive adjustment. It's meant as a work-around for a single-screen situation where both madTPG and the interactive adjustment window have to be on at the same time, i.e. you'd do the interactive adjustment while not in fullscreen.


Because there's no way to detect if the meter is used in contact mode or not.
Yes I know there is no way of detecting on or off screen mode, just wanted to make sure that gwgill didn't make some more magic and need the meter to be on screen.

Tried auto mode (9200+) with calibration (slow), worked very well.
Can you extend the number of patches for auto mode?

ss
sillysally is offline  
post #3368 of 3384 Old 04-21-2015, 12:24 PM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by sillysally View Post
Can you extend the number of patches for auto mode?
Sure. How many patches would you like (roughly)? The next step up would be 11140.
sillysally likes this.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3369 of 3384 Old 04-21-2015, 12:43 PM
AVS Special Member
 
sillysally's Avatar
 
Join Date: Jun 2006
Location: Chicago
Posts: 3,964
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 248 Post(s)
Liked: 332
Quote:
Originally Posted by fhoech View Post
Sure. How many patches would you like (roughly)? The next step up would be 11140.
11140 should work.
I am trying to compare with my custom built testcharts. The largest testchart I have used is about 13200.

After viewing the log on the auto mode run, I like how it seems to work.
Is this and the black hack what gwgill was refering to when he said he was making argyllCMS "a little smater".

Thanks.

ss
sillysally is offline  
post #3370 of 3384 Old 04-21-2015, 01:14 PM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by sillysally View Post
11140 should work.
I am trying to compare with my custom built testcharts. The largest testchart I have used is about 13200.
Ok, I've updated (only) the DCG 0install Windows feed with 2.9.1.1 to unlock this, so you need to update manually.

Quote:
Originally Posted by sillysally View Post
After viewing the log on the auto mode run, I like how it seems to work.
I tried to choose sensible parameters. Glad to hear it seems to work well for you.

Quote:
Originally Posted by sillysally View Post
Is this and the black hack what gwgill was refering to when he said he was making argyllCMS "a little smater".
There are many detail improvements, and some new features like this.
sillysally and anta1974 like this.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3371 of 3384 Old 04-21-2015, 01:28 PM
Senior Member
 
anta1974's Avatar
 
Join Date: Jun 2009
Location: Ukraine
Posts: 340
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 22
Where i can download this new version argyllCMS?

Last edited by anta1974; 04-21-2015 at 01:36 PM.
anta1974 is online now  
post #3372 of 3384 Old 04-21-2015, 01:38 PM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by anta1974 View Post
Where i can download this new version argyllCMS?
There is currently no official release, but Graeme is working on it.
anta1974 likes this.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3373 of 3384 Old 04-22-2015, 12:53 AM
Senior Member
 
anta1974's Avatar
 
Join Date: Jun 2009
Location: Ukraine
Posts: 340
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 22
and it is possible to receive the test this version argylcms?
anta1974 is online now  
post #3374 of 3384 Old 04-22-2015, 04:46 AM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by anta1974 View Post
and it is possible to receive the test this version argylcms?
Instructions here: MadVR - ArgyllCMS
anta1974 likes this.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3375 of 3384 Old Yesterday, 03:27 AM
Senior Member
 
anta1974's Avatar
 
Join Date: Jun 2009
Location: Ukraine
Posts: 340
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 22
Quote:
Originally Posted by zoyd View Post
I ran the normal sequence I use of about 2500 patches, DispcalGUI 2.9.0.2, madVR 0.87.14, ArgyllCMS 1.7.1b(mar6) - no problems detected
Zoyd!
Where is i can download ArgyllCMS 1.7.1b(mar6)?
anta1974 is online now  
post #3376 of 3384 Old Yesterday, 03:32 AM
AVS Special Member
 
zoyd's Avatar
 
Join Date: Sep 2006
Location: Planet Dog
Posts: 5,490
Mentioned: 61 Post(s)
Tagged: 0 Thread(s)
Quoted: 740 Post(s)
Liked: 639
There is no difference in LUT profiling or gamut mapping between the march 6 build and the current build.
anta1974 likes this.
zoyd is online now  
post #3377 of 3384 Old Yesterday, 03:55 AM
Senior Member
 
anta1974's Avatar
 
Join Date: Jun 2009
Location: Ukraine
Posts: 340
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 22
Ok, but current build 1.7.0!

Where i can find 1.7.1 ?
anta1974 is online now  
post #3378 of 3384 Old Yesterday, 04:27 AM
AVS Special Member
 
zoyd's Avatar
 
Join Date: Sep 2006
Location: Planet Dog
Posts: 5,490
Mentioned: 61 Post(s)
Tagged: 0 Thread(s)
Quoted: 740 Post(s)
Liked: 639
zoyd is online now  
post #3379 of 3384 Old Today, 10:19 AM
Member
 
monvo's Avatar
 
Join Date: Nov 2011
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 14
I've run into a bit of a problem with the latest version of dispcalGUI (2.9.1.1) and Argyll (1.7.0), both installed with zeroinstall. After starting the preconditioning process (reading 154 patches) it just says

Quote:
White drift was XXX
The instrument can be removed from the screen
Nothing happens after that, no CPU usage at all. The logs also stop there:

From the "interact.log":
2015-04-25 19:00:29,552 '\rpatch 154 of 154'
2015-04-25 19:00:33,934 '\r\nWhite drift was 0.498399 DE\r\nThe instrument can be removed from the screen.\r\n'

It seems to me as if dispcal just doesn't "press" a required button to continue or something like that. Can anybody provide some insight into what might be going on there?

All of the logs are attached in zipped format (from the folder "\AppData\Roaming\dispcalGUI\logs")

Edit: Apparently some of the logs contain multiple tries on my part. Please only consider the latest.
Attached Files
File Type: zip logs.zip (14.1 KB, 3 views)

Last edited by monvo; Today at 10:37 AM.
monvo is online now  
post #3380 of 3384 Old Today, 11:39 AM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by monvo View Post
All of the logs are attached in zipped format (from the folder "\AppData\Roaming\dispcalGUI\logs")
Hmm. From the logs it looks like dispread never exits after finishing reading the 154 patches. Please enable Argyll CMS diagnostic output in the "Options" menu and try again. Eventually the debug output will give a better idea as to why it seems to hang.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3381 of 3384 Old Today, 12:26 PM
Member
 
monvo's Avatar
 
Join Date: Nov 2011
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 14
Quote:
Originally Posted by fhoech View Post
Hmm. From the logs it looks like dispread never exits after finishing reading the 154 patches. Please enable Argyll CMS diagnostic output in the "Options" menu and try again. Eventually the debug output will give a better idea as to why it seems to hang.
Okay, here is the debugging output.

Last lines from dispcalGUI.log:

Code:
2015-04-25 21:17:32,529 White drift was 1.184509 DE
2015-04-25 21:17:32,529 The instrument can be removed from the screen.
2015-04-25 21:17:32,588 Diffuser thread returning
2015-04-25 21:17:32,619 madvrwin_del called
2015-04-25 21:19:12,562 dispcalGUI: Trying to end subprocess gracefully...
2015-04-25 21:19:21,569 dispcalGUI: Trying to terminate subprocess...
2015-04-25 21:19:21,671 ...subprocess terminated.
2015-04-25 21:19:21,674 dispcalGUI: Reached EOF (OK)
2015-04-25 21:19:21,734 ...aborted.
2015-04-25 21:19:21,766 Profiling has not been finished.
The last lines are me cancelling the process.
Attached Files
File Type: zip logs diagnostics.zip (87.6 KB, 2 views)
monvo is online now  
post #3382 of 3384 Old Today, 01:33 PM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by monvo View Post
Okay, here is the debugging output.

Last lines from dispcalGUI.log:

Code:
2015-04-25 21:17:32,529 White drift was 1.184509 DE
2015-04-25 21:17:32,529 The instrument can be removed from the screen.
2015-04-25 21:17:32,588 Diffuser thread returning
2015-04-25 21:17:32,619 madvrwin_del called
2015-04-25 21:19:12,562 dispcalGUI: Trying to end subprocess gracefully...
2015-04-25 21:19:21,569 dispcalGUI: Trying to terminate subprocess...
2015-04-25 21:19:21,671 ...subprocess terminated.
2015-04-25 21:19:21,674 dispcalGUI: Reached EOF (OK)
2015-04-25 21:19:21,734 ...aborted.
2015-04-25 21:19:21,766 Profiling has not been finished.
The last lines are me cancelling the process.
Thanks. Unfortunately it's still not clear where it is failing. Can you check if it has written the output file (C:\Users\YourUsername\AppData\Roaming\dispcalGUI\ storage\madVR 2015-04-25 S XYZLUT Profile\madVR 2015-04-25 S XYZLUT Profile.ti3) and attach it?

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
post #3383 of 3384 Old Today, 01:42 PM
Member
 
monvo's Avatar
 
Join Date: Nov 2011
Posts: 78
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 14
Quote:
Originally Posted by fhoech View Post
Thanks. Unfortunately it's still not clear where it is failing. Can you check if it has written the output file (C:\Users\YourUsername\AppData\Roaming\dispcalGUI\ storage\madVR 2015-04-25 S XYZLUT Profile\madVR 2015-04-25 S XYZLUT Profile.ti3) and attach it?
Unfortunately there is no file from today in that folder.

Right now I'm running a pre-configured test chart ( Massive testchart for LUT profiles, optimized for Gamma 2.2 with Rec.709 primaries (D65)) until I can get "Auto" to work.
monvo is online now  
post #3384 of 3384 Old Today, 01:53 PM
Senior Member
 
fhoech's Avatar
 
Join Date: Apr 2013
Location: Stuttgart, Germany
Posts: 478
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Liked: 123
Quote:
Originally Posted by monvo View Post
Right now I'm running a pre-configured test chart
I'd be surprised if that worked. dispread in your case fails somewhere between just after calling madvrwin_del and before writing the output file.

DCG (dispcalGUI) - Graphical front-end for Argyll CMS display calibration and characterization
Current stable version 2.6
Current development snapshot 2.9.1.0 beta (2015-04-20) - via 0install or standalone
fhoech is online now  
Sponsored Links
Advertisement
 
Reply Display Calibration



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off