Rock Band 3 Freestyle Drum/Mic Lag - AVS Forum
Forum Jump: 
 
Thread Tools
Old 05-11-2011, 06:10 PM - Thread Starter
Newbie
 
ShotgunZen's Avatar
 
Join Date: Apr 2011
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Greets All,

This question is for anyone playing Rock Band 3 through a high end 7.1 AVR.

First of all, and IMPORTANTLY, I'm not worried about standard lag - the kind the game can calibrate away. To see if you have lag from your digital audio processing, do the following: Load the drum trainer, and play a roll as fast as you can. If you hear a hit or two happen AFTER you finish, that's lag from your AV system. If you don't...well, you're alot less annoyed than me, probably.

If you can play RB3 with no lag time on the drum fills/freestyle/mic via HDMI, please post the receiver model you're using. I have a Yammy RX-A2000 which I really like, but I can't get rid of the lag and I'm about to ebay the damn thing and get something comprable if I can find an AVR with no drum lag. Thanks...
ShotgunZen is offline  
Sponsored Links
Advertisement
 
Old 05-11-2011, 09:35 PM
AVS Special Member
 
logicalnoise's Avatar
 
Join Date: Feb 2007
Location: Chicago suburbs
Posts: 5,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by ShotgunZen View Post

Greets All,

This question is for anyone playing Rock Band 3 through a high end 7.1 AVR.

First of all, and IMPORTANTLY, I'm not worried about standard lag - the kind the game can calibrate away. To see if you have lag from your digital audio processing, do the following: Load the drum trainer, and play a roll as fast as you can. If you hear a hit or two happen AFTER you finish, that's lag from your AV system. If you don't...well, you're alot less annoyed than me, probably.

If you can play RB3 with no lag time on the drum fills/freestyle/mic via HDMI, please post the receiver model you're using. I have a Yammy RX-A2000 which I really like, but I can't get rid of the lag and I'm about to ebay the damn thing and get something comprable if I can find an AVR with no drum lag. Thanks...

Harmon Kordon's have never had this problem as far as I know. Mine only does optical but lag has never been a problem.
logicalnoise is offline  
Old 05-11-2011, 10:47 PM
AVS Special Member
 
CoreyM's Avatar
 
Join Date: Oct 2005
Location: Portland, OR
Posts: 2,354
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 90 Post(s)
Liked: 88
I've had good luck with HK, Rotel and Denon, but I disable all surround processing.

Cheaper Onkyo I had for a while added about 45ms to the average.

I find <20 ms to be acceptable.

Just one thing to add - my HK AVR (254) forces video processing on you if you run through HDMI, it can be calibrated away in RB but it adds about 40ms of lag which I don't want when playing FPS games.

XBox: King Nuthin
CoreyM is online now  
Old 05-12-2011, 07:45 AM
AVS Special Member
 
garciab's Avatar
 
Join Date: Aug 2001
Location: Princeton, TX - USA
Posts: 1,074
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 32
I still think this is more a problem with the game. I can tolerate the lag on GH a lot better than that on RB. Speaking only of the games during only the 'freestyle' moments.

bg
garciab is offline  
Old 05-12-2011, 07:59 AM
AVS Special Member
 
Eddie Horton's Avatar
 
Join Date: May 2004
Location: Hayden, Alabama
Posts: 1,390
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
I had to disable the drum fills in RB3 because of the lag. Running HDMI from XBOX to Panasonic XR-57 to 55" Sony Bravia LCD. Even with the TV in Game Mode and all extra processing turned off in the receiver, it's still not tolerable. It's strange that it's only on the fills, though, but it sure makes you look like a goofball when you have been hitting every note on Expert Pro drums and then fall apart on a fill.

The previous post may contain spoilers, which will make the post less aerodynamic and increase handling at high speeds.
Eddie Horton is offline  
Old 05-12-2011, 08:30 AM
AVS Special Member
 
Lord Flatus's Avatar
 
Join Date: Aug 2005
Location: Vista, CA
Posts: 2,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 28
Quote:
Originally Posted by Eddie Horton View Post

It's strange that it's only on the fills, though

It only makes sense. The game deals with the lag by assuming you'll hit all the notes and playing them before you strike the pads/cymbals or strum a guitar note. That way when you hit the note the sound is coming out right then and it seems like you triggered it. But the first note you miss actually plays and then after that you get the miss sound. I start really noticing it when I'm "on" with the drums and I'm playing really fast sections. It actually takes me out of "suspension of disbelief" for a moment when I know I missed that frickin' note but I hear it play and then afterwards I hear the rim click.

The game can actually tune out quite a bit of lag this way, with the more lag accounted for the more noticeable it is.

In freestyle and fills, the game doesn't know what you are supposed to play so it can't play it first and then check to see if you actually hit it, so you hear the full on system delay that has been cal'd out. Same thing with vocals since it plays your actual voice over the speakers.

It's a pretty slick system that works great, but the fills and vocals show what's really going on.
Lord Flatus is offline  
Old 05-12-2011, 09:40 AM
AVS Special Member
 
ileff's Avatar
 
Join Date: Jul 2001
Location: Yuba City, CA
Posts: 1,983
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 20
I'm not sure about this. That means the first charted note would always play no matter what and I don't think thats the case. I'll give it a try.

Maybe you are meaning in crazy fast drumming parts. I play guitar and I've never noticed it playing something I missed. (not including all the slop that pro guitar allows)

xbl/gamecenter: leff4
psn/twitter: ileff
my app: video poker clock
ileff is offline  
Old 05-12-2011, 10:39 AM
AVS Special Member
 
Lord Flatus's Avatar
 
Join Date: Aug 2005
Location: Vista, CA
Posts: 2,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 28
Quote:
Originally Posted by ileff View Post

Maybe you are meaning in crazy fast drumming parts.

It's usually fast rolls where I notice it most since that's where I'm the weakest. I'll miss one and three notes later my streak will break.
Lord Flatus is offline  
Old 05-12-2011, 10:59 AM
AVS Special Member
 
NoThru22's Avatar
 
Join Date: May 2003
Location: Baltimore, MD
Posts: 9,431
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 164 Post(s)
Liked: 113
I have an Onkyo 701 and I don't get any lag added over what putting the game in 5.1 does. Apparently later Onkyos used a different processor that introduced a lot of lag, but I think that's corrected on the newer models.
NoThru22 is offline  
Old 05-12-2011, 11:37 AM
AVS Special Member
 
garciab's Avatar
 
Join Date: Aug 2001
Location: Princeton, TX - USA
Posts: 1,074
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 32
Not even on fills? For me, it's better on RB3, but it's still there and annoying.

bg
garciab is offline  
Old 05-12-2011, 05:12 PM
Bass Enabler
 
Scott Simonian's Avatar
 
Join Date: Oct 2001
Location: Clovis, CA
Posts: 14,309
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 859 Post(s)
Liked: 1030
I used to have an older HK525 that I used optical digital connection with and no lag issues back then in RB2. I now have an Onkyo TXNR3007 and I use HDMI with it. I needed to recalibrate the game with the new receiver and I always use 7.1 upmix (Pro Logic2x/z). I have no lag issues after calibrating.

Since you have a nicer Yammy, make sure to disable any CinemaDSP effects while playing music games. That dsp may add even more lag to the sound, fwiw.

My Dual 18" LLT subs 120dB down to 10hz

 

Plan9Reloaded Co-host

Listen to the Plan9Reloaded Gaming and Technology Podcast (may contain NSFW language)

https://soundcloud.com/plan9reloaded/sets/podcast - direct pod link

http://plan9reloaded.com/site/ - main website

Scott Simonian is offline  
Old 05-12-2011, 06:04 PM - Thread Starter
Newbie
 
ShotgunZen's Avatar
 
Join Date: Apr 2011
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I've tried running optical audio, disabling Dolby in the game, going to digital stereo on the xbox, and shutting off just about every processing item on the reciever I can get to, including going to pure direct mode. Still getting freestyle drum/mic lag. Some of the above improved it, but pretty much any lag at all will drive you crazy as a couple of you already noted. Really pisses you off to drop 1k+ on an AVR (which otherwise sounds great and is awesome) only to f' up your rock band....My old denon s-101 didn't have this issue at all, and it was doing virtual surround processing for a 2.1 system. I'm gonna try analog audio, but I'm waiting on the adapter for the xbox.

And to clarify again (most seem to follow), this is NOT the standard video/audio lag the game can calibrate away. This is real time lag on drum fills/freestyle/mic only. If you don't play alot/don't sing/don't drum on high levels you likely wouldn't know if you're getting this lag or not. If you're not 100% sure what I'm talking about, try the drum roll test mentioned in the original post.

Any other lag-free AVR recommendations much appreciated....
ShotgunZen is offline  
Old 05-12-2011, 06:58 PM
AVS Special Member
 
Eddie Horton's Avatar
 
Join Date: May 2004
Location: Hayden, Alabama
Posts: 1,390
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
The only remedy I've found for RB3 drum playing is........don't sing and turn drum fills off. It's very annoying, no doubt.

The previous post may contain spoilers, which will make the post less aerodynamic and increase handling at high speeds.
Eddie Horton is offline  
Old 05-12-2011, 11:10 PM
AVS Special Member
 
CoreyM's Avatar
 
Join Date: Oct 2005
Location: Portland, OR
Posts: 2,354
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 90 Post(s)
Liked: 88
Quote:
Originally Posted by NoThru22 View Post

I have an Onkyo 701 and I don't get any lag added over what putting the game in 5.1 does. Apparently later Onkyos used a different processor that introduced a lot of lag, but I think that's corrected on the newer models.

Not sure if its the later models or just the cheaper models. I think my bad one is a 506.

XBox: King Nuthin
CoreyM is online now  
Old 05-13-2011, 11:12 AM
Bass Enabler
 
Scott Simonian's Avatar
 
Join Date: Oct 2001
Location: Clovis, CA
Posts: 14,309
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 859 Post(s)
Liked: 1030
Its not your $1k receiver causing the lag during your fills. It's an inherent design of how the game works. Disable your drums fills. That's what I did.

My Dual 18" LLT subs 120dB down to 10hz

 

Plan9Reloaded Co-host

Listen to the Plan9Reloaded Gaming and Technology Podcast (may contain NSFW language)

https://soundcloud.com/plan9reloaded/sets/podcast - direct pod link

http://plan9reloaded.com/site/ - main website

Scott Simonian is offline  
Old 05-13-2011, 01:44 PM
AVS Special Member
 
NoThru22's Avatar
 
Join Date: May 2003
Location: Baltimore, MD
Posts: 9,431
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 164 Post(s)
Liked: 113
Quote:
Originally Posted by Scott Simonian View Post

Its not your $1k receiver causing the lag during your fills. It's an inherent design of how the game works. Disable your drums fills. That's what I did.

Yes, it's the $1K receiver causing the lag during fills. People have hooked up cheap receivers from other brands and not had this effect happen.
NoThru22 is offline  
Old 05-13-2011, 02:44 PM
AVS Special Member
 
CoreyM's Avatar
 
Join Date: Oct 2005
Location: Portland, OR
Posts: 2,354
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 90 Post(s)
Liked: 88
Quote:
Originally Posted by Scott Simonian View Post

Its not your $1k receiver causing the lag during your fills. It's an inherent design of how the game works. Disable your drums fills. That's what I did.

There may be a few (<5) ms of lag inherent in the system and depending if you are wired or unwired but it only becomes an issue when your surround processor isn't fast enough to keep that few ms to an amount that your ear doesn't distinguish. I've tried playing with enough processors to know how broadly it can fluctuate (from 5ms with no surround to 60-70ms on a slow processor with 5.1 enabled). Only on the slow receiver does it sound like I am singing in an echo chamber.

XBox: King Nuthin
CoreyM is online now  
Old 05-14-2011, 09:13 AM
AVS Special Member
 
garciab's Avatar
 
Join Date: Aug 2001
Location: Princeton, TX - USA
Posts: 1,074
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 32
I guess the true test will be with the analog setup. Can't wait to see what his results are then. I'm in the camp that believes the game is to blame.

bg
garciab is offline  
Old 05-14-2011, 11:48 PM - Thread Starter
Newbie
 
ShotgunZen's Avatar
 
Join Date: Apr 2011
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It's definately not the game. My old denon s-101 had no lag via optical, and that was with dolby on even.
ShotgunZen is offline  
Old 03-16-2012, 08:01 AM
Member
 
braves22's Avatar
 
Join Date: Mar 2012
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It could be your tv....

FWIW, I currently am at 196 ms of audio lag just connecting my xbox directly to my tv through HDMI....

Ok, so no problem with the guitar, it matches up ok...

Problem comes in when you play the keys, which are a different lag time, the drums, a MUCH different lag time, and then the worst, the mic which is so off that it sounds as if there's an echo when you sing because your voice feels like a 2 second delay
braves22 is offline  
Old 03-16-2012, 08:12 AM
AVS Special Member
 
Lord Flatus's Avatar
 
Join Date: Aug 2005
Location: Vista, CA
Posts: 2,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 28
196 seems pretty excessive...
Lord Flatus is offline  
Old 03-16-2012, 08:37 AM
Member
 
braves22's Avatar
 
Join Date: Mar 2012
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Lord Flatus View Post

196 seems pretty excessive...

Um yeah....

I think so too....


Would be nice if that could get fixed somehow
braves22 is offline  
Old 03-16-2012, 09:13 AM
AVS Special Member
 
NoThru22's Avatar
 
Join Date: May 2003
Location: Baltimore, MD
Posts: 9,431
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 164 Post(s)
Liked: 113
Quote:
Originally Posted by braves22 View Post

Um yeah....

I think so too....


Would be nice if that could get fixed somehow

What brand and model of TV?
NoThru22 is offline  
Old 03-16-2012, 09:39 AM
AVS Special Member
 
Lord Flatus's Avatar
 
Join Date: Aug 2005
Location: Vista, CA
Posts: 2,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 28
Quote:
Originally Posted by braves22 View Post

Um yeah....

I think so too....


Would be nice if that could get fixed somehow

Check the other thread you started on this subject for my suggestion. And it would probably be best to move this to the main Rock Band thread for the best chance at useful answers.
Lord Flatus is offline  
Old 03-16-2012, 09:44 AM
Member
 
braves22's Avatar
 
Join Date: Mar 2012
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Lord Flatus View Post


Check the other thread you started on this subject for my suggestion. And it would probably be best to move this to the main Rock Band thread for the best chance at useful answers.

Since i am using the app through my iPhone I didn't want to go on a thread like the regular RB one where it's 3 billion posts that I can't search through...

Also for your response in the "other" thread...which other thread and do you have a link?


That would help me....did i respond to your suggestion by chance....I may have already tried what you said?
braves22 is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off