PS3 white/black clipping - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 16 Old 02-26-2012, 08:07 AM - Thread Starter
Newbie
 
johnrl's Avatar
 
Join Date: Feb 2012
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi everyone.

I just got a PS3 and am now trying to calibrate my TV through the PS3 with a Disney World of Wonder bluray disc.

When I started calibrating I noticed that it seems like the PS3 is clipping black and white levels above ideal black and white - can anyone confirm if this is normal behavior for a PS3 and if not, if it can be remedied somehow?

I also have a WDTV live and I tried ripping some of the tests from the Disney disc onto the WDTV live. It does NOT clip black and whites like the PS3 does on the same HDMI port.

So in short: can anyone confirm if the PS3 white/black clipping is normal behavior and if not, if it can be remedied somehow?
johnrl is offline  
Sponsored Links
Advertisement
 
post #2 of 16 Old 02-26-2012, 10:59 AM
 
darklordjames's Avatar
 
Join Date: Jun 2003
Posts: 7,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 93
There is a Black Level and Super White setting that you have to twiddle. You'll find them in the Display settings section of the XMB. Also, check that Super White is on in the pop-up menu while playing a Bluray. Having run WOW last week on my PS3 for my new 64" plasma, I know the PS3 will spit out full range when set up properly.
darklordjames is offline  
post #3 of 16 Old 02-26-2012, 01:23 PM
AVS Special Member
 
Suntan's Avatar
 
Join Date: Mar 2004
Location: Twin Cities
Posts: 7,103
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 31
Be aware that the color spec for DVD and HD/BR are different. Can't say as I ever bothered with DVD, but the PS3 does output rec709 correctly.

In any case, I would stop wasting time with a Disney disc (they're traditionally the most poorly mastered discs I've ever seen) and make a couple of proper calibration discs based on the free files available in the monitor calibration forum.

-Suntan
Suntan is offline  
post #4 of 16 Old 02-26-2012, 02:49 PM
 
darklordjames's Avatar
 
Join Date: Jun 2003
Posts: 7,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 93
He already owns the WOW disc, so free doesn't matter. Also, WOW functions perfectly fine.

How about giving real advice instead of just telling him that he bought crap?
darklordjames is offline  
post #5 of 16 Old 02-26-2012, 03:16 PM - Thread Starter
Newbie
 
johnrl's Avatar
 
Join Date: Feb 2012
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the advice but still can't seem to figure it out. Btw I tried other calibration as well (found some free files in another forum) but they also show the clipping. I've used the Disney disc on several TV's and it always worked for me.

I tried playing the m2ts file from Disney WoW for brightness adjustment on the PS3 through USB (to compare with TV & WDTV) and it is still clipping so it doesn't seem to be a blu-ray specific problem.

I checked the Display Settings menu and found the following set
- RGB Full Range (HDMI): Full
- Super-White (HDMI): On

When playing the m2ts file I can't find any "Super white" option in the pop-up settings..

If I switch "RGB Full Range (HDMI)" to "Limited" the brightness goes way up and all blacks seem washed out grayish. However I still can't see any blacks below ideal black even with brightness at max.

"Super-White (HDMI)" doesn't seem to do anything. I tried both the brightness and contrast adjustments and the setting seems to have no effect on either.

I'm not sure who's the culprit here. As I mentioned my WDTV live connected to the same HDMI port (and exact same TV settings) has no clipping problems with the same m2ts file. Furthermore the TV itself has no problems either when the file is played directly on it with a connected USB.

PS: my TV (Sony NX720) has some color space settings for each HDMI port currently set to Automatic. One would think that should be fine?
johnrl is offline  
post #6 of 16 Old 02-26-2012, 07:20 PM
AVS Special Member
 
Suntan's Avatar
 
Join Date: Mar 2004
Location: Twin Cities
Posts: 7,103
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 31
Quote:
Originally Posted by darklordjames View Post


How about giving real advice instead of just telling him that he bought crap?

He asked if anyone could confirm if there were btb or wtw issues with the ps3 and I responded that the ps3 does output rec709 correctly.

How about chilling out and taking off the self appointed "internet-sheriff" hat just because somebody might have denigrated a disc you own.

To the op, you stated that you are playing an m2ts file via the USB port on the ps3. It's been a long time since I bothered with the USB port, but if memory serves, the ps3 does not adhere to proper playback via the USB connection unless you have the USB drive formatted as an avchd "disc."

You can use clownhd to format the folder structure you need to accomplish this.

Otherwise, use discs in the disc drive to make sure you are getting proper playback.

-Suntan
Suntan is offline  
post #7 of 16 Old 02-26-2012, 10:47 PM - Thread Starter
Newbie
 
johnrl's Avatar
 
Join Date: Feb 2012
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Suntan View Post

To the op, you stated that you are playing an m2ts file via the USB port on the ps3. It's been a long time since I bothered with the USB port, but if memory serves, the ps3 does not adhere to proper playback via the USB connection unless you have the USB drive formatted as an avchd "disc."

You can use clownhd to format the folder structure you need to accomplish this.

Otherwise, use discs in the disc drive to make sure you are getting proper playback.
-Suntan

I see. But in this case it doesn't seem to matter. Be it the WoW disc, usb playback of m2ts or DLNA they all play identically and all do b/w clipping.

There must be some settings that are not right with my TV and the PS3 or just one of them if you guys don't have any clipping.. question is what it is.
johnrl is offline  
post #8 of 16 Old 02-27-2012, 09:18 AM
AVS Special Member
 
TornadoTJ's Avatar
 
Join Date: Jan 2008
Location: Dallas, TX
Posts: 3,915
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 34
I still believe it has to do with Display Settings -> RGB Full Range (HDMI), Y Pb / Cb Pr / Cr Super-White (HDMI), or the Deep Color Output (HDMI) settings. I found with the WOW disc that one of my TVs I thought supported super white would not calibrate properly when super white was on. I believe RGB Full Range only affects RGB output, Super-White only affects Y Pb / Cb Pr / CR. This is set in Video Settings, BD / DVD Video Output Format (HDMI). My computer monitor won't even accept one of them, don't remember which. It also freaks if I try to send Deep Color to it.
TornadoTJ is offline  
post #9 of 16 Old 02-27-2012, 09:57 AM
Advanced Member
 
tezster's Avatar
 
Join Date: Sep 2007
Location: Mississauga, Canada
Posts: 537
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 39
When connected to the PS3, my TV has the option of an 'HDTV' or 'PC' mode under the display settings - both modes operate very differently in terms of how brightness levels are represented i.e. the upper/lower levels of white clipping and crushed blacks are limited; I would suggest checking your TV if there's a similar setting.

In my case, the PC mode appears to limit the colour range/gamut, so I set it to HDTV.
tezster is offline  
post #10 of 16 Old 02-27-2012, 02:25 PM
 
darklordjames's Avatar
 
Join Date: Jun 2003
Posts: 7,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 93
Look for an HDMI Black Level setting on your display. That will also effect black crush. Your display may be weird in that it remembers per device instead of per input, so it's automatically switching back and forth between Normal and Low when you plug different devices in to the same HDMI port. I don't know for certain as I am not standing in your living room, but that would be the first thing I'd look at on the display.
darklordjames is offline  
post #11 of 16 Old 02-28-2012, 01:31 PM
AVS Special Member
 
bdwright77's Avatar
 
Join Date: Dec 2007
Location: Houston
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I was able to set black correctly, but could never get the white gradient steps to ever appear using the WOW disc. Toggled super white, black level, etc. to no avail.
bdwright77 is offline  
post #12 of 16 Old 03-01-2012, 04:30 AM - Thread Starter
Newbie
 
johnrl's Avatar
 
Join Date: Feb 2012
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Can't get it working no matter what I try. I have tried all your suggestions and tried playing with countless combinations of the settings on my TV and the PS3.

Are you sure that the PS3 is capable of non-clipping when playing from USB or DLNA? I could use the Disney disc directly if I wanted, but I rip ALL my movies to mkv format and stash away the discs in the basement (same thing I did with the Disney disc except it's m2ts since its calibration ==> better lossless), so I really want to achieve correct settings with playing files.

So the question is; have any of you got the PS3 to output non-clipped b/w with usb or dlna playing?
johnrl is offline  
post #13 of 16 Old 03-01-2012, 06:34 AM
AVS Special Member
 
Suntan's Avatar
 
Join Date: Mar 2004
Location: Twin Cities
Posts: 7,103
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 31
Quote:
Originally Posted by johnrl View Post

So the question is; have any of you got the PS3 to output non-clipped b/w with usb or dlna playing?

Be aware that you will also not get the PS3 to playback in proper 24p if using the usb or DLNA route. The only exception being the afore mentioned formatting to look like an AVCHD disc trick.

-Suntan
Suntan is offline  
post #14 of 16 Old 07-07-2012, 03:17 PM
Member
 
JustaSheep's Avatar
 
Join Date: Jul 2011
Location: Texas
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 22
Hi all,

I'm a little late to this conversation but I wanted to know if there is anything definitive regarding the clipping issue on the PS3.

I am using the S&M Bluray for calibration and I'm stuck on the black level clipping. I was also experience clipping on the high whites, but after setting my AVR to passthru, that problem went away. No luck on the blacks though.

I'm sure it's partly psychological, but I know see large areas of black where I'm sure detail is missing. Any help or input would be appreciated.

Thanks,
Sheep


PS: Here's what I'm running:

PS3 Blu-Ray
Onkyo TX-NR809
Panasonic 55ST50

PSS: Give me one excuse to add an Oppo BD93 to the wishlist, PLEASE!
JustaSheep is offline  
post #15 of 16 Old 07-09-2012, 12:27 PM
AVS Special Member
 
TornadoTJ's Avatar
 
Join Date: Jan 2008
Location: Dallas, TX
Posts: 3,915
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 34
PS3
Pioneer VSX-1021
Panasonic 60ST50

No clipping on mine. Very easy to calibrate with either the WOW disc or the freebie calibration disk I found here at AVSForum.
TornadoTJ is offline  
post #16 of 16 Old 05-20-2013, 05:50 AM
Newbie
 
vgmarques's Avatar
 
Join Date: Jan 2007
Location: Brasil
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Guys, any news?

I tried PS3 and have the same problems, using S&M. Replaced PS3 by Oppo BDP-80 and have the same problem...

Does it make sense to be something concerning HDMI cable? Mine is a old one (1.3).
vgmarques is offline  
Reply PlayStation Area

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off