ps3 audio - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 8 Old 11-11-2012, 10:50 PM - Thread Starter
Newbie
 
MAGRACER's Avatar
 
Join Date: Oct 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a new Denon receiver and new plasma panasonic gt65. When other input sources play it says dolby digital. But when using ps3 for blue-rays or regular dvds it says it is playing in PC II sound, shouldnt this sound be digital, also ?
MAGRACER is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 11-12-2012, 01:27 AM
 
darklordjames's Avatar
 
Join Date: Jun 2003
Posts: 7,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 93
What is "PC II" sound? That sounds like a typo'd ProLogic II, or a bad PCM. We can't help you if you don't get us the correct information to begin with.
darklordjames is offline  
post #3 of 8 Old 11-12-2012, 06:42 AM - Thread Starter
Newbie
 
MAGRACER's Avatar
 
Join Date: Oct 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Sorry correction, when I use my PS3 for dvds or blue-rays receiver says it is playing in pro-logic II. I am using a HDMI cable. Why does it not play in dolby digital like all other sources?
MAGRACER is offline  
post #4 of 8 Old 11-12-2012, 12:51 PM
 
darklordjames's Avatar
 
Join Date: Jun 2003
Posts: 7,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 93
You don't want it to play in Dolby Digital. What you want is multichannel PCM, an uncompressed format. If you look at your PS3 Sound settings, you need to make sure that more than just Stereo is turned on. Also, in your Bluray options change audio output from Bitstream to Linear PCM.

All of that maybe turned on already and you are just applying PL II on top of PCM.
darklordjames is offline  
post #5 of 8 Old 11-12-2012, 08:31 PM - Thread Starter
Newbie
 
MAGRACER's Avatar
 
Join Date: Oct 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
could please explain why I dont want digital. I thought Blue rays sound better in digital.
MAGRACER is offline  
post #6 of 8 Old 11-12-2012, 11:43 PM
 
darklordjames's Avatar
 
Join Date: Jun 2003
Posts: 7,909
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 93
PCM is digital. It is just an uncompressed format. HDMI is really designed for the source device to handle any format conversions, with PCM transported to the playback device. Your PS3 will decode any of the various formats that are on the Blu disc, then always feed your receiver PCM, if you let it.

So what you need to look for is a display or menu option on your receiver that tells you what's playing. It should say something like "7/.1 PCM" or "5/.1 PCM" if set up properly. If you get "2/.0 PCM" as the confirmed format, then you have the PS3 set to spit out stereo. Again, go look at the Sound options on your PS3 that I told you about earlier.
darklordjames is offline  
post #7 of 8 Old 11-13-2012, 10:16 AM
Member
 
kanti123's Avatar
 
Join Date: Sep 2011
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 23
I have denon receiver too, mine didn't do that. your LCD screen on your receiver should say MultCH PCM. Unless you have the slim PS3 and set the audio to bit stream It'll say DTS or Dolby Digital. My suggestion is redo the Audio setup on PS3. either way PCM or Dolby DIgital on the screen make so different. PCM means ps3 decode the audio and send it to receiver and the receiver pass it on to each speaker. If Dolby Digital is on that means the receiver is decoding it.
kanti123 is offline  
post #8 of 8 Old 11-29-2012, 01:25 PM
Newbie
 
TooByFoor's Avatar
 
Join Date: Oct 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Been browsing through here trying to find a solution to my audio intermittently dropping ONLY when playing Call of Duty games. I noticed this when I rented MW3, and now the same issue on Black Ops 2. Some googling told me to un-check everything in my PS3 audio settings except for the Linear 5.1 44.1hz (I think). When I did this, I didn't have the audio drop outs, but it sounded like most everything came from the rear speakers. And when I restarted the PS3, it went back to having everything checked for the Audio settings.

Hooked to a Denon AVR 1312 through HDMI only, using Klipsch 5.1 speaker system.

I don't have this issue with any other games. My receiver screen says MULTI CH IN and the only time I've ever change this on the DENON AVR1312 is when playing Guitar Hero (I changed to MULTI STEREO, it just sounds better). Most everything in the PS3 is set to auto.

Forgive my ignorance on all this, and i'm trying to understand all the PCM/Linear stuff (by browsing this forum, but it's a lot of info)...but anyone else having this problem or have any suggestions? Can (should) I force the PS3 to use a specific setting and should I be at all concerned about that warning message that basically says if I do this wrong I could damage my speakers?
TooByFoor is offline  
Reply PlayStation Area

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off