Frame rate issue with gtx titan - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 11-21-2013, 06:11 PM - Thread Starter
Member
 
mumflaps's Avatar
 
Join Date: Mar 2013
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Hi guys

Just got my copy of assasins creed black flag. Started playing it and getting terrible frame rates. Especially when in the built up cities. My gfx card is the gtx titan so not your mid-range GPU. I'm also running an i7 3770k. Does anybody know why this might be? I've tried updating drivers etc. lowering settings right down helps a bit, but I've heard people with less powerful cards able to play on maxed out settings. Any help would be appreciated.

Thanks
mumflaps is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-28-2014, 03:02 PM
Newbie
 
Ryant1110's Avatar
 
Join Date: Jan 2014
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10

How much ram?

 

Are you sure that your not accidentally using the integrated graphics card?

 

Download a program that will monitor your framerates and if its above 60 you may be getting screen tearing and artifacting due to the card pushing more frames per second than the refresh on your monitor.

 

Try reinstalling the drivers.  (always click the clean install button)

 

Check bios and see what the card configuration is.  

 

Update directX

 

Just a few suggestions.  Not sure if any are your issue but its a start.

Ryant1110 is offline  
Reply General Gaming Help

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off