Help guys... can't get my monitor to display at correct resolution - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 21 Old 05-27-2011, 05:48 PM - Thread Starter
AVS Special Member
 
Anthony1's Avatar
 
Join Date: Sep 1999
Posts: 5,928
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 144
Ok, here is my situation.

To get decent audio from my computer, I'm using the hdmi out from my video card, and routing that hdmi out to my receiver. (Marantz SR7001). This way, the audio goes to my receiver, and I'm able to get 5.1 or 7.1 or whatever.

However, here is the problem. To get the video to my monitor (LG IPS226), I have to obviously go from the hdmi output of the receiver, back to the monitor. When I do this, the video card is thinking that the Marantz SR7001 is my display, and it's limiting me to 720p. The only way I can change this is by going into my Nvidia control panel, and basically forcing a 1080p resolution.

So, what's the problem? Well, in the Nvidia control panel, when I force the resolution to 1080p, the only 1080p options are:

1080p at 59 Hz or 1080p at 50 Hz. I want to set it to 1080p at 60 Hz, but there is no option for this. When I instead connect my video card directly to the monitor, I get the correct 1080p at 60Hz, but then I'm obviously not getting any 5.1 or 7.1 audio, because the hdmi output isn't going directly into the receiver.

My video card is a Gigabyte GTX 560 Ti SOC by the way. I'm using the mini-hdmi output. (which is really pissing me off, but that's another story).

Anyways, I just have a feeling that this weird 59Hz thing, instead of the 60Hz thing is going to be a problem for me. Maybe it won't be a problem, I don't know, but it just seems kinda weird to me. Basically, I'm just trying to somehow get my 5.1 (or 7.1 ) sound, and also get a legit 1920 x 1080p @ 60Hz resolution. I'm new to the whole PC thing, so maybe it's something really simple that I need to do, but I'm just clueless about it. Any suggestions would be greatly appreciated. Thanks.
Anthony1 is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 05-27-2011, 06:08 PM
AVS Special Member
 
MSmith83's Avatar
 
Join Date: Jun 2005
Posts: 8,542
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 48
A 59.94Hz refresh rate is typical for regular video applications, and is probably what the graphics card is outputting in this case (or something extremely close). It's fine; games running at 60fps frame-rate at a 59.94Hz refresh will look just as smooth as with exactly 60Hz. I've extensively played PC games using both.
MSmith83 is offline  
post #3 of 21 Old 05-27-2011, 06:43 PM - Thread Starter
AVS Special Member
 
Anthony1's Avatar
 
Join Date: Sep 1999
Posts: 5,928
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 144
Quote:
Originally Posted by MSmith83 View Post

A 59.94Hz refresh rate is typical for regular video applications, and is probably what the graphics card is outputting in this case (or something extremely close). It's fine; games running at 60fps frame-rate at a 59.94Hz refresh will look just as smooth as with exactly 60Hz. I've extensively played PC games using both.

I hear what you're saying, but when I connect the monitor, directly to the video card (not using the receiver), the video quality just seems better. Also, when I am using the receiver, and I try to adjust the settings on my monitor, it seems to kinda spaz out. Like it doesn't like going thru these various handshakes. For awhile there, the monitor kept going dark, and then showing the picture, and then going dark and then showing the picture. Like it was losing sync or something. Almost like it was turning off and on, but it wasn't actually turning off and on.


I was thinking, that if I could just use the mini-hdmi for audio only, and run that to my receiver, and then use one of the DVI outputs for video, that would work fine, but when I try to hook it up that way it doesn't work. It seems like it's either one or the other. Unless there is a setting in the Nvidia control panel that I need to select or something, to allow this to work this way.
Anthony1 is offline  
post #4 of 21 Old 05-27-2011, 06:58 PM
AVS Special Member
 
LexInVA's Avatar
 
Join Date: Jun 2007
Posts: 1,864
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 37
Quote:
Originally Posted by Anthony1 View Post

I hear what you're saying, but when I connect the monitor, directly to the video card (not using the receiver), the video quality just seems better. Also, when I am using the receiver, and I try to adjust the settings on my monitor, it seems to kinda spaz out. Like it doesn't like going thru these various handshakes. For awhile there, the monitor kept going dark, and then showing the picture, and then going dark and then showing the picture. Like it was losing sync or something. Almost like it was turning off and on, but it wasn't actually turning off and on.


I was thinking, that if I could just use the mini-hdmi for audio only, and run that to my receiver, and then use one of the DVI outputs for video, that would work fine, but when I try to hook it up that way it doesn't work. It seems like it's either one or the other. Unless there is a setting in the Nvidia control panel that I need to select or something, to allow this to work this way.

Did you try the DVI port farthest from the HDMI port?
LexInVA is offline  
post #5 of 21 Old 05-27-2011, 08:21 PM - Thread Starter
AVS Special Member
 
Anthony1's Avatar
 
Join Date: Sep 1999
Posts: 5,928
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 144
Quote:
Originally Posted by LexInVA View Post

Did you try the DVI port farthest from the HDMI port?

Yep.


Here is my new problem. I'm still going thru my Receiver, and I'm just doing the thing where I force 1080p @59Hz. It's working ok, but when I'm playing certain games, for some reason the maximum resolution that it's allowing me to accept is 1440 x 900, which was the resolution of the previous monitor that I was using. No matter what I do, I can't get it to go past 1440 x 900. I've tried this with the Bulletstorm Demo, DiRT 2 demo and Far Cry 2 (full game). I have been able to play Assassin's Creed Director's Cut in 1080p. I was also able to play the Just Cause 2 demo in 1080p. For some reason, on those other games, I can't get a 1080p resolution, which is really weird. So, I've connected my monitor directly with out the receiver (no sound), and I'm going to try those demos and see if I can now get the legit 1080p.

This is really starting to piss me off. I guess I'm going to have to get a dedicated sound card or something. I was thinking that one of the nice things about the PC now is that you didn't need to buy a sound card....


Update: I hooked the GPU directly to the monitor, and now I can select 1080p in those other games. Fudge....

I don't understand why it works with Assassin's Creed and Just Cause 2 demo, but won't work with these other games.... So I've got the 1080p working, but I'm using 2 channel sound for now....
Anthony1 is offline  
post #6 of 21 Old 05-27-2011, 11:56 PM
Senior Member
 
PubFiction's Avatar
 
Join Date: Dec 2010
Location: Lansing, MI
Posts: 303
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
Have you tried to create custom resolutions in the nVidia control panel? Thet should get you over any limitations of not being able to set a resolution for the whole computer.

If nothing works for you are work around might be to buy a HDMI splitter and split the HDMI near the computer 1 cable going to the reciever and the other to the monitor. This might be better if the reciever is causing any delays anyay.

Isn't HDMI the worst invention ever? Seriously I never had any problems before I started trying to use HDMI for junk. Also there may be some setting on the reciever like HDMI pass through that would help you. Basically you want your computer to see the id info for the monitor but instead it sees the info for the reciever.
PubFiction is offline  
post #7 of 21 Old 05-28-2011, 12:45 AM
Senior Member
 
lurkor's Avatar
 
Join Date: Jun 2010
Posts: 364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
The 3D Vision manual recommends a straight connection to your display using their supplied cables. I haven't used 3dtv play so I don't want to give bad advice, but it seems Nvidia is making their drivers more idiot proof at a cost of functionality. You should probably stick with the what the manual suggests instead of getting creative.
lurkor is offline  
post #8 of 21 Old 05-28-2011, 08:34 AM
AVS Special Member
 
257Tony's Avatar
 
Join Date: Dec 2006
Location: Syracuse
Posts: 2,012
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Have you considered just going to analog multi channel sound? It will give you the best of both worlds, IMO.
257Tony is offline  
post #9 of 21 Old 05-28-2011, 11:05 AM - Thread Starter
AVS Special Member
 
Anthony1's Avatar
 
Join Date: Sep 1999
Posts: 5,928
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 144
Quote:
Originally Posted by lurkor View Post

The 3D Vision manual recommends a straight connection to your display using their supplied cables. I haven't used 3dtv play so I don't want to give bad advice, but it seems Nvidia is making their drivers more idiot proof at a cost of functionality.


Obviously, with 3D Vision or 3DTV Play, I would assume it's like my Samsung 3D Plasma in that I must connect my PS3 directly to the TV and run optical to the receiver (because my AVR isn't 3D ready). I actually haven't tried to do anything 3D with this PC yet. I want to try messing with that soon, but haven't tried it yet.


Quote:
Originally Posted by lurkor View Post

You should probably stick with the what the manual suggests instead of getting creative.


Well, I'm not exactly trying to be creative or anything. I'm simply trying to use the HDMI output of my video card for sound. If the GPU is capable of giving me sound via the HDMI port, then why not use it? Of course, I still need to somehow get the video to the monitor, and that's where the problem occurs.
Anthony1 is offline  
post #10 of 21 Old 05-28-2011, 11:12 AM - Thread Starter
AVS Special Member
 
Anthony1's Avatar
 
Join Date: Sep 1999
Posts: 5,928
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 144
Quote:
Originally Posted by 257Tony View Post

Have you considered just going to analog multi channel sound? It will give you the best of both worlds, IMO.


You know, this might be what I'm going to need to do, and I know that when I start using 3DTV Play or whatever, I'm going to have to use the analog multi channel outputs, because I don't have a 3D Ready AVR. Either that, or I'll have to use some type of HDMI splitter / repeater type thing.

However.... I don't see how using 4 cables from the analog multi outputs is going to give me some legit 7.1 sound. Honestly, I'm kinda confused in general about PC game sound. It doesn't seem very similar to the Playstation 3 or Xbox 360. With the PS3 or Xbox 360, it's pretty easy to work with. You can get Dolby Digital 5.1 or DTS 5.1 with a simple optical cable. I have an optical output on the back of my PC, and I originally was using that, but I was only getting 2 channel sound in my games, so obviously that won't work for 5.1 (unless I'm doing something wrong).

Is it even possible for the PC to get "true", discrete 7.1 channels of sound like the PS3 is able to do for games like Uncharted and Resistance? Do you need a special sound card to achieve that? Seriously... one thing the PC is trailing the consoles in, is the ease of use for getting high-quality game sound. It seems to be possible with the PC, but definitely no ease of use, and I honestly wonder if true, discrete, uncompressed 7.1 sound like the PS3 is able to do is something that is done in PC games. When I'm playing PC games, I don't see any logos in regards to Dolby Digital or anything like that.
Anthony1 is offline  
post #11 of 21 Old 05-28-2011, 11:16 AM
AVS Special Member
 
LexInVA's Avatar
 
Join Date: Jun 2007
Posts: 1,864
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 37
What's your motherboard make and model?
LexInVA is offline  
post #12 of 21 Old 05-28-2011, 01:09 PM - Thread Starter
AVS Special Member
 
Anthony1's Avatar
 
Join Date: Sep 1999
Posts: 5,928
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 144
Quote:
Originally Posted by LexInVA View Post

What's your motherboard make and model?


Asus P8P67 it's the standard version, not the super cheapo LE, and not the better Deluxe or Pro.
Anthony1 is offline  
post #13 of 21 Old 05-28-2011, 01:57 PM
AVS Special Member
 
257Tony's Avatar
 
Join Date: Dec 2006
Location: Syracuse
Posts: 2,012
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by Anthony1 View Post

You know, this might be what I'm going to need to do, and I know that when I start using 3DTV Play or whatever, I'm going to have to use the analog multi channel outputs, because I don't have a 3D Ready AVR. Either that, or I'll have to use some type of HDMI splitter / repeater type thing.

However.... I don't see how using 4 cables from the analog multi outputs is going to give me some legit 7.1 sound.
Honestly, I'm kinda confused in general about PC game sound. It doesn't seem very similar to the Playstation 3 or Xbox 360. With the PS3 or Xbox 360, it's pretty easy to work with. You can get Dolby Digital 5.1 or DTS 5.1 with a simple optical cable. I have an optical output on the back of my PC, and I originally was using that, but I was only getting 2 channel sound in my games, so obviously that won't work for 5.1 (unless I'm doing something wrong).

Is it even possible for the PC to get "true", discrete 7.1 channels of sound like the PS3 is able to do for games like Uncharted and Resistance? Do you need a special sound card to achieve that? Seriously... one thing the PC is trailing the consoles in, is the ease of use for getting high-quality game sound. It seems to be possible with the PC, but definitely no ease of use, and I honestly wonder if true, discrete, uncompressed 7.1 sound like the PS3 is able to do is something that is done in PC games. When I'm playing PC games, I don't see any logos in regards to Dolby Digital or anything like that.

If the game has legit 7.1 sound, you'll get it through MCH analog. If it doesn't, you'll get 5.1.
257Tony is offline  
post #14 of 21 Old 05-28-2011, 03:40 PM
Senior Member
 
lurkor's Avatar
 
Join Date: Jun 2010
Posts: 364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
Mini hdmi output to receiver + dvi output to display. It should be trouble free.
lurkor is offline  
post #15 of 21 Old 05-28-2011, 05:32 PM
AVS Special Member
 
blackssr's Avatar
 
Join Date: Feb 2007
Location: South Florida
Posts: 2,467
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 17
Quote:
Originally Posted by Anthony1 View Post
Ok, here is my situation.

To get decent audio from my computer, I'm using the hdmi out from my video card, and routing that hdmi out to my receiver. (Marantz SR7001). This way, the audio goes to my receiver, and I'm able to get 5.1 or 7.1 or whatever.

However, here is the problem. To get the video to my monitor (LG IPS226), I have to obviously go from the hdmi output of the receiver, back to the monitor. When I do this, the video card is thinking that the Marantz SR7001 is my display, and it's limiting me to 720p. The only way I can change this is by going into my Nvidia control panel, and basically forcing a 1080p resolution.

So, what's the problem? Well, in the Nvidia control panel, when I force the resolution to 1080p, the only 1080p options are:

1080p at 59 Hz or 1080p at 50 Hz. I want to set it to 1080p at 60 Hz, but there is no option for this. When I instead connect my video card directly to the monitor, I get the correct 1080p at 60Hz, but then I'm obviously not getting any 5.1 or 7.1 audio, because the hdmi output isn't going directly into the receiver.

My video card is a Gigabyte GTX 560 Ti SOC by the way. I'm using the mini-hdmi output. (which is really pissing me off, but that's another story).

Anyways, I just have a feeling that this weird 59Hz thing, instead of the 60Hz thing is going to be a problem for me. Maybe it won't be a problem, I don't know, but it just seems kinda weird to me. Basically, I'm just trying to somehow get my 5.1 (or 7.1 ) sound, and also get a legit 1920 x 1080p @ 60Hz resolution. I'm new to the whole PC thing, so maybe it's something really simple that I need to do, but I'm just clueless about it. Any suggestions would be greatly appreciated. Thanks.
What input on the AVR are you using? Is the conversion turned off for that input? (Page 35 of your manual) HDMI video should be untouched through your AVR if conversion is set to off, just the audio is routed if the THX post processing is used. Does this receiver do HDMI conversion or post processing, If yes, set conversion to 1080P and see if that helps. My Denon 5308CI scales my PS3, HTPC and security camera computer to 1080P.
blackssr is offline  
post #16 of 21 Old 05-28-2011, 09:04 PM - Thread Starter
AVS Special Member
 
Anthony1's Avatar
 
Join Date: Sep 1999
Posts: 5,928
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 144
Quote:
Originally Posted by lurkor View Post
Mini hdmi output to receiver + dvi output to display. It should be trouble free.
I'm using a Gigabyte GTX 560 Ti SOC. You're saying that I should be able to use the dvi and hdmi outputs at the same time?
Anthony1 is offline  
post #17 of 21 Old 05-28-2011, 09:16 PM
AVS Special Member
 
MSmith83's Avatar
 
Join Date: Jun 2005
Posts: 8,542
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 48
Quote:
Originally Posted by Anthony1 View Post
I'm using a Gigabyte GTX 560 Ti SOC. You're saying that I should be able to use the dvi and hdmi outputs at the same time?
You should be able to clone the outputs via Nvidia control panel under "Set up multiple displays", so the same 1080p signal is output from both connections. You should then be able to use the HDMI connection for audio as well.
MSmith83 is offline  
post #18 of 21 Old 05-28-2011, 10:33 PM
Senior Member
 
lurkor's Avatar
 
Join Date: Jun 2010
Posts: 364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
It can be done, and I've tested it with Despicable Me 3D on PDVD2. I don't have the hdmi slots to spare so I went back to optical, but where there's a will there's a way.
lurkor is offline  
post #19 of 21 Old 05-29-2011, 04:39 AM
AVS Special Member
 
WJonathan's Avatar
 
Join Date: Jun 2007
Posts: 1,766
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I noticed this too on my new setup. For some reason the latest NVidia drivers are limiting my 1080 output to 30 Hz to my TV. Didn't have this problem with the older drivers.
WJonathan is offline  
post #20 of 21 Old 06-01-2011, 10:25 PM - Thread Starter
AVS Special Member
 
Anthony1's Avatar
 
Join Date: Sep 1999
Posts: 5,928
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 144
Quote:
Originally Posted by lurkor View Post

Mini hdmi output to receiver + dvi output to display. It should be trouble free.


Strangely, I couldn't get this to work, when I was using a DVI to hdmi adapter, on the DVI out on the GPU. Then I took off that adapter, and just used a DVI to DVI cable, to run to the monitor, and then had the HDMI going to the receiver. Now everything is working
Anthony1 is offline  
post #21 of 21 Old 06-01-2011, 11:03 PM
Senior Member
 
lurkor's Avatar
 
Join Date: Jun 2010
Posts: 364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
*shrug* who knows with all this EDID foolishness going on. It reminds me of Darth Vader breathing heavily and wearing a latex glove telling me to cough. I'm trying to avoid it as long as I can.
lurkor is offline  
Reply HTPC Gaming

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off