Problem with Sony STR-DH520 and pc - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 06-24-2012, 04:59 PM - Thread Starter
Newbie
 
Satsujin925's Avatar
 
Join Date: Jun 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
hey, not sure if right place to post this but here goes.

i have my sony receiver hooked up to my PC using HDMI, i just aquired a sound card that i want to use for the audio instead of the HDMI by means of using an optical cable. My problem is i get no sound when trying to configure my receiver to use optical audio instead of the HMDI and i think i might not be doing it right, the manuals instructions arent clicking to great in my head.

The sound card i have is the Diamond Xtreme XS71DDL

the card is fully detected all drivers installed ( sept i cant seem to get the sound control program for some reason even though the official driver pack said it had it included...) and i can select either its pci or optical as the main device. so i think my problem lies in setting up the receivers audio

any help please?! will post more info if needed meanwhile ill continue to fiddle with settings

-ps- newbie in receiver setup world!
Satsujin925 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-25-2012, 04:36 AM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 6,583
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 111 Post(s)
Liked: 348
Exactly what model of Sony receiver do you have?

A couple of things to try:

Make sure that you've downloaded and installed the most recent drivers from Diamond's Web site.

In the receiver's internal settings, make sure that the optical input is enabled for / associated with the appropriate device selection (e.g. CD). Some receivers let you associate any optical input with any device name. Associate it with a device on the receiver which is different from the one you've been using for the HDMI connection. Then you can more easily switch back and forth between the two inputs to listen for differences.

Selden
Selden Ball is online now  
post #3 of 5 Old 06-26-2012, 02:13 PM
Senior Member
 
Trogdor2010's Avatar
 
Join Date: Jul 2010
Posts: 335
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 14
Actually you might not need to use your sound card, especially since your receiver accepts audio from HDMI.

The question is what graphics card you have? HDMI accepts both video and audio in the same cord. It's actually better than using optical for audio due to the limited compatibility of optical. The only reason I would use a sound card for is with analog outputs, and even then, many motherboards have more than sufficient audio output. Unless if your HDMI port on your card doesn't accept audio, it be better to use HDMI for this purpose.
Trogdor2010 is offline  
post #4 of 5 Old 06-29-2012, 03:11 PM - Thread Starter
Newbie
 
Satsujin925's Avatar
 
Join Date: Jun 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
thanks for tips, got it fixed lol. problem was that i had to search online for the sound control panel that normally comes on the disk of the sound card. once i got that i saw that i had to activate the optical sound ports and set them up for dolby digital.

my hdmi port on my video card (GTX 570 ) allows for audio but my receiver picked it up as stereo so i got the sound card for the surround sound. n yea ive read that hdmi has more bandwith n stuff but only this way have i gotten 5.1 out of games that supported dolby digital.
otherwise it was always stereo sound.
Satsujin925 is offline  
post #5 of 5 Old 06-30-2012, 04:49 AM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 6,583
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 111 Post(s)
Liked: 348
By default, the number of output HDMI audio channels used by Windows is controlled by the settings in the "Playback devices" tab of the Sound menu. Some player programs override it, but most don't.

1. right-mouse-button click on the speaker icon at the right end of the taskbar
2. Select "Playback devices"
OR
1. Start menu --> Control Panel --> Small Icons --> Sound menu
2. Select the "Playback" tab (the default)

3. select the HDMI device (usually at the bottom of the list of devices)
4. select the Configure button
5. Select the desired number of HDMI channels. (Stereo is usually selected by default)
6. select the options to test the audio outputs
7. Click OK until exited from the menu.

Selden
Selden Ball is online now  
Reply HTPC Gaming

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off