5.1 surround sound on non certified Dobly games? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 09-01-2012, 05:53 PM - Thread Starter
Member
 
SecretSexyNinja's Avatar
 
Join Date: Jun 2011
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just set up my Denon 1911 surround system at my new apartment. I decided to use it for games and LOVE how it sounds in Guild Wars 2. It really adds to the immersion of the game.

However, I went to play CS:GO and selected 5.1 in their options menu and all I get is stereo. The surround speakers don't work at all. I think I read somewhere that GW2 supports Dolby but many games like CS: GO and Borderlands (another I couldn't get it working) don't have the license for Dolby so the games cant output like that through my receiver.

I have my sound coming from my GTX580 via HDMI to my receiver, which is set to Dolby PLII (this mode is for 5.1 channel surround) in the Cinema Mode. The receiver is also showing PCM and DIG. Now, there are other modes like simulation, but I want the real thing.

Is there a specific setting on the receiver for video games that have 5.1 but not Dolby? I'm sorry, I know this is a little technical and honestly I'm not entirely sure what I need to be searching for as a solution. Is there a way to convert via software the signal to Dolby or am I missing an option on my receiver?
SecretSexyNinja is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-01-2012, 06:33 PM
AVS Special Member
 
MSmith83's Avatar
 
Join Date: Jun 2005
Posts: 8,543
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 48
You have to configure Windows for 5.1 output in addition to selecting it through the game options.

Go to the sound section in Windows Control Panel, click on the GTX 580's audio controller (which should be set for Windows' default sound device), click on "configure," select "5.1 surround," and make all speakers full-range since your AVR should be handling bass management.

The output you should be getting is 5.1 PCM in games that support 5.1; no Dolby re-encode is necessary for any game.

Also, make sure your AVR says something like "MULTI CH IN" on the display.
MSmith83 is offline  
post #3 of 5 Old 09-01-2012, 06:52 PM - Thread Starter
Member
 
SecretSexyNinja's Avatar
 
Join Date: Jun 2011
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So weird.. I did have 5.1 selected in CP but when I just checked it is now only showing stereo. It was literally working last night. I guess that's the problem. I have no idea how it switched and I can't figure it out. Also, I have a mode called SIMULATION which has "MULTI CH STEREO" in it. From what I've read this isn't true surround. Is that wrong? The Dobly PLII shouldn't be selected though?

edit: I can't get the sound to give me the option for 5.1 anymore. I have no idea what happened.
SecretSexyNinja is offline  
post #4 of 5 Old 09-01-2012, 07:39 PM - Thread Starter
Member
 
SecretSexyNinja's Avatar
 
Join Date: Jun 2011
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Alright, my computer is showing what looks like my TV (instead of my receiver) in the sound options. I don't know why it's doing this. I have an HDMI going from gtx580 -> receiver, then another hdmi, receiver -> TV. I might try to reinstall my gfx card and see if that has anything to do with it

Disconnecting and reconnecting the hdmi from my PC fixed it. Now to set my options on the receiver. Thanks for the help
SecretSexyNinja is offline  
post #5 of 5 Old 09-01-2012, 09:39 PM
AVS Special Member
 
MSmith83's Avatar
 
Join Date: Jun 2005
Posts: 8,543
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 48
Quote:
Originally Posted by SecretSexyNinja View Post

Disconnecting and reconnecting the hdmi from my PC fixed it.

That's good to know. The HDMI "handshake" can be unpredictable at times.

No, do not use any of the simulation modes like multichannel stereo. Disregard Pro Logic II, because most modern games will send a full discrete 5.1 channels of audio to your 5.1 system when everything is set correctly. Do not use any of the direct modes (like "MULTI CH DIRECT"), as that tends to eliminate all-important features like bass management.

My older Denon AVR says "MULTI CH IN" when set properly for incoming multichannel PCM signals. Your model might be different.
MSmith83 is offline  
Reply HTPC Gaming

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off