DBP2011 & DBP-1611 owner's thread. All questions and comments go here. - Page 35 - AVS | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
Reply
 
Thread Tools
post #1021 of 1056 Old 02-25-2013, 06:39 AM
Newbie
 
Kathycat's Avatar
 
Join Date: Mar 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a Playback Problem with my Denon DBP-2012:

I have Playback problems with 1 Blu-Rays recently, which I am not able to solve. Firmware is most recent.

1.) Haven, Season 1 - Disc 3
Once I placed the Blu-Ray into my Denon DBP-2012 it shows Data Disc in the Display and I can navigate through the Disc Folder - but not able to play back the Disc. All other 3 remaining disc are working fine - only on this I have the issue. Even remove the power supply does not solve this problem. Have anyone any idea / suggestion how it is possible to start to Playback? Others Disc start without any problem and no further setting has to be made.

Thanks for your help
Kathycat is offline  
Sponsored Links
Advertisement
 
post #1022 of 1056 Old 02-25-2013, 10:32 AM
AVS Special Member
 
Beerstalker's Avatar
 
Join Date: Mar 2005
Location: Peoria, IL
Posts: 1,982
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 23
Quick question here guys, how much of a difference is there between the 1611 and the 1713? I'm trying to decide if I should order the 1713 (for $450), or just buy and open box 1611 that my local store has for sale (hopefully for around $300). They will be paired with a Denon 3808 receiver, and a Hitachi 65F710 TV.

Is it even worth me getting a Denon, or should I just get a newer Panasonic/Sony/Samsung? I only have a couple SACDs, that I don't really listen to anyway. I hate the goofy shapes of the new Sony and Panasonic players though, so I'd probably be leaning toward the Panasonic 220.
Beerstalker is offline  
post #1023 of 1056 Old 05-25-2013, 07:46 AM
Member
 
oldprof's Avatar
 
Join Date: May 2013
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by Beerstalker View Post

Quick question here guys, how much of a difference is there between the 1611 and the 1713? I'm trying to decide if I should order the 1713 (for $450), or just buy and open box 1611 that my local store has for sale (hopefully for around $300). They will be paired with a Denon 3808 receiver, and a Hitachi 65F710 TV.

Is it even worth me getting a Denon, or should I just get a newer Panasonic/Sony/Samsung? I only have a couple SACDs, that I don't really listen to anyway. I hate the goofy shapes of the new Sony and Panasonic players though, so I'd probably be leaning toward the Panasonic 220.

I recently bought the Sony S790. This unit has not been "updated" to the new look. Has 2 HDMI outs so you can use it with your 3808 (as I am doing). Plays SACD just fine as well. Most of the discussion here on AVS about this unit seems to feel the S790 is as good as the OPPO at 1/2 the price. Lots of "smart" features as well, but the MSRP is $250. I am very happy with mine.
oldprof is offline  
post #1024 of 1056 Old 06-27-2013, 07:23 AM
AVS Special Member
 
Transmaniacon's Avatar
 
Join Date: Oct 2009
Location: Raleigh, NC
Posts: 4,340
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 756 Post(s)
Liked: 614
Hi guys, I can get this unit open box with a 1 year warranty for $125. Do you think it would be a worthwhile investment? I was hoping to get a universal to replace my Samsung BD-E5900 so I can play SACD and DVD. It would be connected to my Denon 1713 via HDMI.

Samsung PN60F5300 | Denon AVR-1713 | EMP E55Ti | EMP E56Ci | EMP E5Bi | BIC F-12
Transmaniacon is offline  
post #1025 of 1056 Old 06-27-2013, 11:45 AM
AVS Special Member
 
mogorf's Avatar
 
Join Date: May 2009
Location: Budapest, Hungary
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 436 Post(s)
Liked: 171
Quote:
Originally Posted by Transmaniacon View Post

Hi guys, I can get this unit open box with a 1 year warranty for $125. Do you think it would be a worthwhile investment? I was hoping to get a universal to replace my Samsung BD-E5900 so I can play SACD and DVD. It would be connected to my Denon 1713 via HDMI.

At that price level if I were you I would buy two for $240.- !! JK smile.gif

I've had mine for two and a half years now without any issues and paired with a Denon 2310 they look pretty handsome together. LOL I also like that it plays CD/DVD/BD/SACD and has a USB input on the front side (repeat: front side!) for pendrive files.

Go for it and enjoy! smile.gif
mogorf is online now  
post #1026 of 1056 Old 06-27-2013, 01:49 PM
AVS Special Member
 
Transmaniacon's Avatar
 
Join Date: Oct 2009
Location: Raleigh, NC
Posts: 4,340
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 756 Post(s)
Liked: 614
Went by and picked it up! Time to fire it up, think I will watch Star Trek (2009) tonight.

Samsung PN60F5300 | Denon AVR-1713 | EMP E55Ti | EMP E56Ci | EMP E5Bi | BIC F-12
Transmaniacon is offline  
post #1027 of 1056 Old 06-27-2013, 01:54 PM
AVS Special Member
 
mogorf's Avatar
 
Join Date: May 2009
Location: Budapest, Hungary
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 436 Post(s)
Liked: 171
Quote:
Originally Posted by Transmaniacon View Post

Went by and picked it up! Time to fire it up, think I will watch Star Trek (2009) tonight.

Congrats on your decision! smile.gif
mogorf is online now  
post #1028 of 1056 Old 07-15-2013, 06:34 AM
Senior Member
 
Krutsch's Avatar
 
Join Date: Mar 2011
Location: Minnetonka, MN
Posts: 403
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 36
I know this isn't a very active thread... but, I have a question:

I want to use my DBP-1611 as a music disc player for a 2-channel system; that is, analog out into an integrated amp for SACD and DVD-Audio.

I read in the manual that I need disable HDMI audio output if I want DSD decoding (SACD) to output via the analog outs. Has anyone used the 1611 in this manner and is it enough to simply not have anything connected to the HDMI port? Or, do I need to hook this thing to a TV and go into the setup and disable HDMI audio out?

Thanks, in advance.

"Play the volume as loud as you want - but don't touch my levels now. I got them set just like I like them"
Krutsch is offline  
post #1029 of 1056 Old 07-16-2013, 04:08 AM
AVS Special Member
 
artur9's Avatar
 
Join Date: Mar 2013
Location: near philly
Posts: 1,039
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
Liked: 69
Quote:
Originally Posted by Krutsch View Post

I read in the manual that I need disable HDMI audio output if I want DSD decoding (SACD) to output via the analog outs. Has anyone used the 1611 in this manner and is it enough to simply not have anything connected to the HDMI port? Or, do I need to hook this thing to a TV and go into the setup and disable HDMI audio out?

Thanks, in advance.

I have some issues in the past with HDMI and Coax where sound doesn't get sent via Coax if HDMI isn't disabled. So I think you need to disable it.

But, I'd try it first cause it sounds easier not to hook up a TV?
artur9 is online now  
post #1030 of 1056 Old 07-16-2013, 05:11 AM
Senior Member
 
Krutsch's Avatar
 
Join Date: Mar 2011
Location: Minnetonka, MN
Posts: 403
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 36
Quote:
Originally Posted by artur9 View Post

I have some issues in the past with HDMI and Coax where sound doesn't get sent via Coax if HDMI isn't disabled. So I think you need to disable it.

But, I'd try it first cause it sounds easier not to hook up a TV?

Thanks for the reply... in your case, did you still have the HDMI cable connected to an AVR?

"Play the volume as loud as you want - but don't touch my levels now. I got them set just like I like them"
Krutsch is offline  
post #1031 of 1056 Old 07-16-2013, 05:16 AM
AVS Special Member
 
mogorf's Avatar
 
Join Date: May 2009
Location: Budapest, Hungary
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 436 Post(s)
Liked: 171
Quote:
Originally Posted by Krutsch View Post

Thanks for the reply... in your case, did you still have the HDMI cable connected to an AVR?

I have my DBP-1611 hooked up to my Denon AVR-2310 via HDMI and coax as well, HDMI assigned to a different input than the coax. No problem on my side to playback via either input. Hope this helps. smile.gif
mogorf is online now  
post #1032 of 1056 Old 07-25-2013, 02:56 PM
Newbie
 
DEddz's Avatar
 
Join Date: Jul 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey Guys,
My Denon DVP 1611 Blu Ray player for some reason is not reading discs properly. It stutters and then "Unknown" disc comes up. There is no particular type of CD it trips out on, it's just random.
Any help/walk through on fixing it is appreciated.
DEddz is offline  
post #1033 of 1056 Old 07-26-2013, 12:14 PM
Member
 
burkeydvm's Avatar
 
Join Date: Nov 2012
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
I have a DBP-1611 connected to my Denon AVR-3312 via HDMI only and am having problems with playback of SACD and DVDA discs.
Last night I was listening to a Diana Krall DVDA which has both a multichannel high resolution portion and a Stereo high resolution portion on the DVDA.
I am able to listen to the multichannel portion with no difficulty and it sounds great, but I can not figure out how to play the Stereo portion. I am confused as to which buttons I push and in what sequence to access the Stereo high resolution portion of the DVDA. The "SOURCE" button and the "DISC LAYER" button have me totally confused!!! What does it mean when the display on the 1611 says "ROOT"?
I spent the last few days reading through this entire thread, and it seemed like other people have had similar questions. It would be really nice if someone could make an alogrithm of when to put in the disc and which buttons to push to access each of the different groups and layers of DVDA's and SACDs.
I thought I would start with my DVDA question first, then move onto the different layers of a SACD.
Thanks!
burkeydvm is offline  
post #1034 of 1056 Old 08-03-2013, 07:02 AM
Newbie
 
KasabeHD's Avatar
 
Join Date: May 2009
Location: Katy, TX
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Does any one recall how to turn off remote lock on DBP-1611. Can't remember what buttons I have to hold down
KasabeHD is offline  
post #1035 of 1056 Old 08-10-2013, 11:54 PM
Newbie
 
lefterisgt's Avatar
 
Join Date: Dec 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello everyone, I have my Denon DBP1611 ud blue ray player for three years now. I regularly update the firmware and generally take good care of it. Last night I decided to watch a movie. After watching it, I tried to take the disk out but the disk tray won't open. I tried to unplug the device and plug it back in but still nothing. By the way this is a rental movie and I have to take it back. Any ideas how to make the tray open or taking it to service is the only solution?? Thank you!
lefterisgt is offline  
post #1036 of 1056 Old 08-11-2013, 02:18 PM
AVS Special Member
 
mogorf's Avatar
 
Join Date: May 2009
Location: Budapest, Hungary
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 436 Post(s)
Liked: 171
Quote:
Originally Posted by lefterisgt View Post

Hello everyone, I have my Denon DBP1611 ud blue ray player for three years now. I regularly update the firmware and generally take good care of it. Last night I decided to watch a movie. After watching it, I tried to take the disk out but the disk tray won't open. I tried to unplug the device and plug it back in but still nothing. By the way this is a rental movie and I have to take it back. Any ideas how to make the tray open or taking it to service is the only solution?? Thank you!

I feel for you lefterisgt coz I have the exact same problem with my also 3 year old 1611. I put my finger under the set, lift it a bit then softly "drop" it. That makes the tray open instantly, but hey, that should not be the solution, eh? At least you can release your rental movie from the set.

Anyone?
mogorf is online now  
post #1037 of 1056 Old 08-13-2013, 09:48 AM
Member
 
burkeydvm's Avatar
 
Join Date: Nov 2012
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
My 1611 started doing the same thing......it will not respond to the command "open tray". I took mine into a factory authorized repair center two weeks ago and have not heard anything from them yet as to the cause and what will be necessary to fix the unit. I have only had my 1611 for 18 months. I will post a follow up after I hear anything.
burkeydvm is offline  
post #1038 of 1056 Old 08-29-2013, 06:09 PM
Member
 
burkeydvm's Avatar
 
Join Date: Nov 2012
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
Quick follow up:
The repair center was able to repair the open/close mechanism on the tray pretty easily. It turns out it the gears were just very dirty and needed a good cleaning. Cost me $100.....working well so far.
burkeydvm is offline  
post #1039 of 1056 Old 09-15-2013, 11:55 AM
Member
 
rezalon's Avatar
 
Join Date: Jul 2008
Location: Redondo Beach, California
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Having issue with playing blue ray discs on the 1611 - great picture but somehow sound read as "stereo" by pioneer elite sc55 receiver through the hdmi cable. as such, you lose the center channel main dialogue in the video. intermittently it works with pcm going through if you restart the player. sc55 receiver not having issue with ps3, apple tv, wii - only with the 1611. older denon dvd players working fine on same hdmi cable. called denon and they said to take it to the service center as I am still under warranty. anyone out there have any "quick" solutions?

Thanks
rezalon is offline  
post #1040 of 1056 Old 09-15-2013, 12:38 PM
AVS Special Member
 
mogorf's Avatar
 
Join Date: May 2009
Location: Budapest, Hungary
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 436 Post(s)
Liked: 171
Quote:
Originally Posted by rezalon View Post

Having issue with playing blue ray discs on the 1611 - great picture but somehow sound read as "stereo" by pioneer elite sc55 receiver through the hdmi cable. as such, you lose the center channel main dialogue in the video. intermittently it works with pcm going through if you restart the player. sc55 receiver not having issue with ps3, apple tv, wii - only with the 1611. older denon dvd players working fine on same hdmi cable. called denon and they said to take it to the service center as I am still under warranty. anyone out there have any "quick" solutions?

Thanks

Hi rezalon, sorry to ask the obvious, but can you make sure HDMI out is set to "bitstream"?

(Page 38 of DBP-1611 Manual)

mogorf is online now  
post #1041 of 1056 Old 09-15-2013, 01:51 PM
Member
 
rezalon's Avatar
 
Join Date: Jul 2008
Location: Redondo Beach, California
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Good catch. It had somehow reset itself to "PCM" for the hdmi audio output setting. put it back to bitstream and working fine now. how do I prevent it from resetting itself again?
rezalon is offline  
post #1042 of 1056 Old 09-15-2013, 02:02 PM
AVS Special Member
 
mogorf's Avatar
 
Join Date: May 2009
Location: Budapest, Hungary
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 436 Post(s)
Liked: 171
Quote:
Originally Posted by rezalon View Post

Good catch. It had somehow reset itself to "PCM" for the hdmi audio output setting. put it back to bitstream and working fine now. how do I prevent it from resetting itself again?

Glad to see the problem solved. And tell'im seriously not to do that ever again! tongue.gifcool.gifsmile.gif
mogorf is online now  
post #1043 of 1056 Old 11-08-2013, 12:44 PM
Newbie
 
bluez3's Avatar
 
Join Date: Dec 2008
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Is anyone having issues playing back Monsters University on the 1611? The audio cuts out at different but repeatable parts throughout the movie. I tried a firmware update on both the player and AVR, but it only served to make the cutouts occur at different repeatable points of the movie.

I have a DBP-1611 connected to a denon AVR-3313 via hdmi. I have confirmed I am using bitstream on the player, and DolbyTrueHD appears on the AVR. I have swapped hdmi cables out and that did not fix it. I have tried both the 2D and 3D discs that came in the set, and they both cut out at different locations, but it seems to be repeatable to each version of the movie. Further, the 5.1 and 7.1 versions cut out at similar points.

I know its not the discs since I can play them back on my PS3 without the cutouts.

I don't know what to further try. it seems to be some sort of buffering issue. if I experience a cut out, and rewind to try and play the cutout back again, it will not occur. but if I start the chapter over or rewind further back, it will cut out again at the same point in the film.

Edit:
Boooo... looked around some on this. apparently other players have the same issue. fix is to set to PCM. is the audio output apples vs. apples? only difference is where the processing took place (DBP or AVR), right?
bluez3 is offline  
post #1044 of 1056 Old 11-08-2013, 12:56 PM
AVS Special Member
 
mogorf's Avatar
 
Join Date: May 2009
Location: Budapest, Hungary
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 436 Post(s)
Liked: 171
Quote:
Originally Posted by bluez3 View Post

Is anyone having issues playing back Monsters University on the 1611? The audio cuts out at different but repeatable parts throughout the movie. I tried a firmware update on both the player and AVR, but it only served to make the cutouts occur at different repeatable points of the movie.

I have a DBP-1611 connected to a denon AVR-3313 via hdmi. I have confirmed I am using bitstream on the player, and DolbyTrueHD appears on the AVR. I have swapped hdmi cables out and that did not fix it. I have tried both the 2D and 3D discs that came in the set, and they both cut out at different locations, but it seems to be repeatable to each version of the movie. Further, the 5.1 and 7.1 versions cut out at similar points.

I know its not the discs since I can play them back on my PS3 without the cutouts.

I don't know what to further try. it seems to be some sort of buffering issue. if I experience a cut out, and rewind to try and play the cutout back again, it will not occur. but if I start the chapter over or rewind further back, it will cut out again at the same point in the film.

While waiting for others to chime in, have you ever considered to use a Laser Lens Cleaning Disc? In-room relatively high humidity may result in build-up of a layer on the lens in form of a mixture of dust and moisture making the lens blurry and resulting in such disc reading errors you are experiencing. Cleaning laser lens should be part of regular maintenance of our gear. I do it! smile.gif
mogorf is online now  
post #1045 of 1056 Old 11-14-2013, 12:28 PM
AVS Special Member
 
mogorf's Avatar
 
Join Date: May 2009
Location: Budapest, Hungary
Posts: 4,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 436 Post(s)
Liked: 171
Quote:
Originally Posted by bluez3 View Post

Edit:
Boooo... looked around some on this. apparently other players have the same issue. fix is to set to PCM. is the audio output apples vs. apples? only difference is where the processing took place (DBP or AVR), right?

Hah, ...didn't look back to your "edit", but please note Bitstream or PCM is not a real fix to your issue of audio cut outs, the 1611 should play either of them error free.

Did you try my suggestion? smile.gif
mogorf is online now  
post #1046 of 1056 Old 11-15-2013, 06:01 AM
AVS Special Member
 
67jason's Avatar
 
Join Date: Jan 2011
Posts: 2,907
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 78 Post(s)
Liked: 795
Quote:
Originally Posted by bluez3 View Post

Is anyone having issues playing back Monsters University on the 1611? The audio cuts out at different but repeatable parts throughout the movie. I tried a firmware update on both the player and AVR, but it only served to make the cutouts occur at different repeatable points of the movie.

I have a DBP-1611 connected to a denon AVR-3313 via hdmi. I have confirmed I am using bitstream on the player, and DolbyTrueHD appears on the AVR. I have swapped hdmi cables out and that did not fix it. I have tried both the 2D and 3D discs that came in the set, and they both cut out at different locations, but it seems to be repeatable to each version of the movie. Further, the 5.1 and 7.1 versions cut out at similar points.

I know its not the discs since I can play them back on my PS3 without the cutouts.

I don't know what to further try. it seems to be some sort of buffering issue. if I experience a cut out, and rewind to try and play the cutout back again, it will not occur. but if I start the chapter over or rewind further back, it will cut out again at the same point in the film.

Edit:
Boooo... looked around some on this. apparently other players have the same issue. fix is to set to PCM. is the audio output apples vs. apples? only difference is where the processing took place (DBP or AVR), right?

dont have the movie, but I do have the same player.

it seems that there may be an issue with the disc.

see this thread.

and post #29 in this thread.

I don't need snobs to tell me how to think, thank you!
67jason is offline  
post #1047 of 1056 Old 01-17-2014, 01:14 AM
Newbie
 
Luge8's Avatar
 
Join Date: Mar 2012
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi,

I need your help with one issue I have with my DBP-1611. Anytime I turn it on it totally jams my Wi-Fi network. The Wi-Fi signal strength is reduced roughly by 80 to 90%. I am absolutelly sure the Denon is causing this (it occurs at the exast moment I turn it on a ends with its turn-off). I tried two higher-end Wi-Fi routers and it was the same with both of them. Cannot you think about some easy solution to this problem? Thanks a lot.

Right now I am thinking about selling the Denon (mainly because abovementioned problem) in favour of Sony S790. Is there something Denon does better tha this Sony? I will be using it in source direct and bitstreming modes nd I am interested rather in picture quality than streaming options.

Thanks a lot.
Luge8 is offline  
post #1048 of 1056 Old 02-13-2014, 09:23 PM
Advanced Member
 
Dave Moritz's Avatar
 
Join Date: May 2003
Posts: 598
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 23 Post(s)
Liked: 24


I love my Denon 1611UD bluray player! It does everything want it to do and have not had any problems. And it really looks good now that it is hooked up to a new Samsung 55" UHD TV 4K/1080P 3D TV. I can not say I have used any wireless feature as I personally would rather run Ethernet to each device and I find wireless to be unreliable and unsecurable.

Supporter of 1080p & 4K video / Supporter of Lossless PCM, Dolby True HD and DTS HD Master Audio / Say No To MP3 & WMA / Say no to Bose
Dave Moritz is offline  
post #1049 of 1056 Old 03-06-2014, 10:07 PM
Advanced Member
 
Dave Moritz's Avatar
 
Join Date: May 2003
Posts: 598
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 23 Post(s)
Liked: 24
Has anyone had issues playing Flightplan on bluray disc in this player? The disc will not play in the Denon or my pc and now I need to try and find my denon password to access the denon website.

This is the second disc that no longer plays and it is frustrating!


Supporter of 1080p & 4K video / Supporter of Lossless PCM, Dolby True HD and DTS HD Master Audio / Say No To MP3 & WMA / Say no to Bose
Dave Moritz is offline  
post #1050 of 1056 Old 03-07-2014, 04:31 AM
AVS Special Member
 
Transmaniacon's Avatar
 
Join Date: Oct 2009
Location: Raleigh, NC
Posts: 4,340
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 756 Post(s)
Liked: 614
That's odd, I haven't run into any issues playing something on mine, have you updated the firmware?

Samsung PN60F5300 | Denon AVR-1713 | EMP E55Ti | EMP E56Ci | EMP E5Bi | BIC F-12
Transmaniacon is offline  
Reply Blu-ray Players

Tags
Blu Ray Players , Denon Dbp 1611ud Universal Blu Ray Dvd Cd Player Black
Gear in this thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off