Yamaha BD-A1000 Blu-Ray Player Defects - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 04-16-2011, 04:49 PM - Thread Starter
OnThePike's Avatar
Join Date: Mar 2011
Location: Long Island, New York
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
We are on our third Yamaha BD-A1000 Blu-Ray player within a 30-day period.

The first one was fine playing standard DVD's, but upon playing a BD, it would stop playing 11 seconds into the movie. We tried a few other (never opened) BD's, same issue. Blu-Ray discs don't play through.

Our second BD-A1000 arrived a week later. We connected it, and this time, it wouldn't play BD at all. Insert disc, reading... STOP. Try again, reading... STOP. This one wound up flung across the kitchen floor.

We are now testing our third BD-A1000. It's 3 days old and has just been connected.

This is a pretty extensive Crutchfield order, of which we are still learning to use (these threads help immensely). We received some poor advice during the initial ordering process, but other advisers have come through for us.

Has anyone else had similar issues with the Yamaha?
OnThePike is offline  
Sponsored Links
Old 04-16-2011, 07:47 PM
AVS Addicted Member
rboster's Avatar
Join Date: Jul 2000
Location: USA
Posts: 12,974
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 389 Post(s)
Liked: 245
Please post all questions and comments in your player owner's thread


"Retired" AVS Moderator
rboster is offline  
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off