Sony S570 problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 02-01-2012, 02:16 PM - Thread Starter
Member
 
sirhc55's Avatar
 
Join Date: Oct 2007
Location: Sydney, Australia
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
I am hoping someone will be able to help me.

I purchase a S570 from the US (I am in Australia) with DVD free & Blue Ray chipped for region free.

I did one firmware upgrade no problem but on the last firmware upgrade (M04.R.787) I lost the ability to have region free bluray (it is now locked to Region A)

Has anyone else experienced this problem and secondly is it possible to go back to the previous firmware?

Cheers
sirhc55 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-01-2012, 02:23 PM
Super Moderator
 
teachsac's Avatar
 
Join Date: May 2006
Location: Elk Grove, CA
Posts: 4,133
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 122
You might want to repost in the player thread for your Sony. This particular forum asks all posts be posted in the appropriate player thread.

http://www.avsforum.com/avs-vb/showt...light=sony+570

S~

Please use the report post button to alert staff to problematic posts. Never quote or respond to them yourself
teachsac is online now  
post #3 of 3 Old 02-01-2012, 09:13 PM - Thread Starter
Member
 
sirhc55's Avatar
 
Join Date: Oct 2007
Location: Sydney, Australia
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Thanks for the heads up
sirhc55 is offline  
Closed Thread Blu-ray Players

Tags
Sony Bdp S570 3d Blu Ray Disc Player
Gear in this thread

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off