Denon DBP-2010ci wont play any bluray - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 02-19-2012, 06:51 AM - Thread Starter
Newbie
 
Ps0831's Avatar
 
Join Date: Feb 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I was noticing that my 2010ci was freezing during Tron and True Grit BD's, then Jurassic Park. It plays DVD's just fine but now any BD I load will not play. It sits on 'Loading' for a while and then rejects the disk. I checked the firmware and it's listed as 1.015, which isn't even available on the Denon website, so I'm not sure how it was updated but i did notice that most of these problems started after my latest network update. Is it possible that an update would render all BD's unplayable or is this a problem with the player that needs service? Any thoughts are greatly appreciated.
Ps0831 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-19-2012, 07:26 AM
Super Moderator
 
teachsac's Avatar
 
Join Date: May 2006
Location: Elk Grove, CA
Posts: 4,309
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 52 Post(s)
Liked: 131
Welcome to the forum. Please copy your post in the owner's thread of the Denon as mods will lock this one. Sorry you are having trouble. Mine is still chugging along just fine. Usually not playing any blu-ray means the blue laser is going out or shot.

http://www.avsforum.com/avs-vb/showt...ght=denon+2010

S~

Please use the report post button to alert staff to problematic posts. Never quote or respond to them yourself
teachsac is online now  
post #3 of 3 Old 02-19-2012, 07:32 AM - Thread Starter
Newbie
 
Ps0831's Avatar
 
Join Date: Feb 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks, post has been copied.
Ps0831 is offline  
Closed Thread Blu-ray Players

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off