Samsung Blu Ray BD C6500 No Sound - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 09-17-2012, 04:01 PM - Thread Starter
doyledh's Avatar
Join Date: Jun 2006
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I had the ATT Uverse guy install a Samsung Blu Ray BD C6500.
He connected it by HDMI to the TV.
It is all connected to the internet, the picture looks good ... I'm getting no sound when I try to play a movie or music.

I have a 5.1 surround sound speaker system hooked up to a
Denon AVR 687
This model does not have a HDMI.
Is something obvious missing in the connection?
Or do I have to fiddle with the set up on the screen for the Blu-Ray?
I'm a novice but willing to learn if you make it clear.
I really appreciate your help.

doyledh is offline  
Sponsored Links
Old 09-17-2012, 07:28 PM
AVS Addicted Member
rboster's Avatar
Join Date: Jul 2000
Location: USA
Posts: 19,003
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 455 Post(s)
Liked: 299
for questions or comments about this player, please post in the owner's thread:


"Retired" AVS Moderator

FS: Full Size Yoda Statue $350:

FS: JVC DLA-X700R (RS57U) w/3yr warranty will be for sale soon!
rboster is offline  

Samsung Bd C6500 1080p Blu Ray Disc Player , Denon Avr 687 7 1 Channel Home Theater Receiver
Gear in this thread - C6500 by
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off