Official OPPO BDP-103 Owner's Thread - Page 713 - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 491Likes
 
Thread Tools
Old 06-25-2015, 10:02 AM
Senior Member
 
NCCaniac's Avatar
 
Join Date: May 2007
Posts: 302
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 28
Quote:
Originally Posted by torii View Post
everytime i watch a youtube clip at the end the player stalls out and only recourse is to power on/off.

I know I am not the only youtube watcher with oppo so whats the catch?

the last couple youtube vids I have this happe is w/ pink floyd and steeley dan vids over 1 hr each.

any hints? this is really bad for an oppo player imo....
Are you on the latest firmware?
NCCaniac is offline  
Sponsored Links
Advertisement
 
Old 06-25-2015, 10:43 AM
Member
 
torii's Avatar
 
Join Date: Mar 2015
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 67 Post(s)
Liked: 17
Quote:
Originally Posted by NCCaniac View Post
Are you on the latest firmware?
yes i am, but let me double check

Power: Marantz sr7008, NAD C 275Bee x 2, Video: Oppo 103, Samsung 75un6300
Speakers: Focal aria 948, Focal cc800v, Klipsch synergy KSF 10.5 Subs: Velodyne HGS 12, VA 1512
torii is online now  
Old 06-25-2015, 04:40 PM
Member
 
atlantasteve's Avatar
 
Join Date: Jan 2007
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Quote:
Originally Posted by Joey C View Post
This link says it will happen in the next firmware update. But we don't know if the 103 will get Tidal, it isn't confirmed.

http://www.whathifi.com/news/oppo-ad...lu-ray-players
Here is the reply I got from oppo:

We anticipate releasing title as a firmware upgrade to the player and an update to the MediaControl application in the following two to three weeks.
atlantasteve is offline  
Old 06-25-2015, 06:21 PM
Newbie
 
dragon1952's Avatar
 
Join Date: Apr 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
I'm getting a lot of video flickering but only when watching discs. Streaming Netflix everything is fine. Both use same HDMI connection to AVR. Any ideas?
dragon1952 is offline  
Old 06-25-2015, 06:48 PM
One-Man Content Creator
 
wmcclain's Avatar
 
Join Date: May 2006
Posts: 18,571
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1119 Post(s)
Liked: 533
Quote:
Originally Posted by dragon1952 View Post
I'm getting a lot of video flickering but only when watching discs. Streaming Netflix everything is fine. Both use same HDMI connection to AVR. Any ideas?
Both DVDs and Blu-rays?

What output resolution?

1080p24 on or off?

-Bill

Review older films here: 1979 and earlier | 1980s | 1990s | Combined reviews: Strange Picture Scroll
Unofficial OPPO FAQS: BDP-103 | BDP-93 | BDP-83 | BDP-80    
wmcclain is online now  
Old 06-25-2015, 07:31 PM
Newbie
 
dragon1952's Avatar
 
Join Date: Apr 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Thanks for the quick reply, Bill.
1.Both DVD and Blu-Ray? I believe I've only watched Blu-Ray since we got the Oppo
2. What output resolution? Output resolution is set to Auto
3. 1080p24 on or off? 1080p24 is set to Auto

BTW, this is a 103D. TV is LG 60PK550, AVR is Anthem MRX310
dragon1952 is offline  
Old 06-25-2015, 07:38 PM
One-Man Content Creator
 
wmcclain's Avatar
 
Join Date: May 2006
Posts: 18,571
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1119 Post(s)
Liked: 533
Quote:
Originally Posted by dragon1952 View Post
Thanks for the quick reply, Bill.
1.Both DVD and Blu-Ray? I believe I've only watched Blu-Ray since we got the Oppo
2. What output resolution? Output resolution is set to Auto
3. 1080p24 on or off? 1080p24 is set to Auto

BTW, this is a 103D. TV is LG 60PK550, AVR is Anthem MRX310
Try setting resolution to 1080p. Then try 1080p24 both off and on.

If still no good, test with a direct connection from the player to the display.

-Bill

Review older films here: 1979 and earlier | 1980s | 1990s | Combined reviews: Strange Picture Scroll
Unofficial OPPO FAQS: BDP-103 | BDP-93 | BDP-83 | BDP-80    
wmcclain is online now  
Old 06-25-2015, 07:40 PM
Newbie
 
dragon1952's Avatar
 
Join Date: Apr 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Thanks.....I'll try that tonight and get back to you tomorrow. Appreciate the help ;^ )
dragon1952 is offline  
Old 06-26-2015, 04:58 PM
Member
 
rickydenim's Avatar
 
Join Date: Dec 2012
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 10
I'm noticing every now and then that when I go to 'Youtube share' to my Oppo 103 sometimes it isn't there. Last night there was stuff I wanted to show someone and it didn't list at all. I restarted my phone, the Oppo and the TV and turned wifi on/off but now it's gone. Anyone have any suggestions? I could however use my Samsung share to the Oppo for pics etc and the Oppo media app worked also. Maybe more a Youtube issue?
rickydenim is offline  
Old 06-26-2015, 07:03 PM
Senior Member
 
TheDudeAbides's Avatar
 
Join Date: Oct 2004
Location: Eugene, OR
Posts: 371
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
Audio

I just bought one of these. I was expecting the video to blow my mind, which it did, but the greatest benefit by far was the audio. My god the audio... It was like going from Ascends (great speakers) to PBN Montana's (priceless speakers, in my opinion).

Thank you, OPPO.
ellisr63 and Iron Maiden like this.

"The Dude abides. I don't know about you but I take comfort in that. It's good knowin' he's out there. The Dude. Takin' 'er easy for all us sinners. Shoosh. I sure hope he makes the finals."
TheDudeAbides is offline  
Old 06-26-2015, 07:11 PM
Senior Member
 
Tornado Red's Avatar
 
Join Date: Jan 2013
Location: Canada
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 136 Post(s)
Liked: 82
Quote:
Originally Posted by dragon1952 View Post
I'm getting a lot of video flickering but only when watching discs. Streaming Netflix everything is fine. Both use same HDMI connection to AVR. Any ideas?
If it's only with discs, possible dirty laser?
Tornado Red is offline  
Old 06-26-2015, 09:27 PM
Newbie
 
dragon1952's Avatar
 
Join Date: Apr 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Quote:
Originally Posted by Tornado Red View Post
If it's only with discs, possible dirty laser?
Yeah, I suppose, and I did think of that. Awful lot of dog hair around these parts....ha ha. Probably won't watch another disc for a day or two but I'll try Bill's suggestions first. Thanks.
dragon1952 is offline  
Old 06-27-2015, 08:46 PM
Newbie
 
Join Date: Jun 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Quote:
Originally Posted by torii View Post
everytime i watch a youtube clip at the end the player stalls out and only recourse is to power on/off.

I know I am not the only youtube watcher with oppo so whats the catch?

the last couple youtube vids I have this happe is w/ pink floyd and steeley dan vids over 1 hr each.

any hints? this is really bad for an oppo player imo....
Same problem here. Been happening for the past few days.

I am having problems with my Oppo BDP-103 freezing/crashing with the new updated YouTube menu system.

How can I fix this or is the problem on YouTube's end??

I can turn the player on, enter the YouTube browser, and go through their new menu design and pick a video to watch and it will play fine. When it is over I can exit back to the menu screen but when I try to play another video the usual bottom screen controls menu appears but the video will not play. No matter what I do I can't exit out of that screen. When the bluray's "home" button is pushed to exit me out of the YouTube browser the attached image shows the next screen. It stays on this screen which I can't exit from until I turn Oppo off and restart.

They only way I can go from one video to another in YouTube now is to exit out of YouTube and re-enter YouTube after each video.

My player has the updated firmware also.

Any ideas?

This happens no matter if I am browsing using a paired devise or just the remote. And started to occur only in the past few days.
Darren Németh is offline  
Old 06-27-2015, 08:49 PM
Newbie
 
Join Date: Jun 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
The screen the player freezes to when I try to exit out of YouTube as described above.
Attached Thumbnails
Click image for larger version

Name:	DSCN4863.JPG
Views:	30
Size:	110.8 KB
ID:	799498  
Darren Németh is offline  
Old 06-28-2015, 03:42 AM
AVS Special Member
 
pbarach's Avatar
 
Join Date: Jul 2005
Location: Northeast Ohio
Posts: 2,767
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 183 Post(s)
Liked: 125
Quote:
Originally Posted by Darren Németh View Post
Same problem here. Been happening for the past few days.

I am having problems with my Oppo BDP-103 freezing/crashing with the new updated YouTube menu system.

How can I fix this or is the problem on YouTube's end??

I can turn the player on, enter the YouTube browser, and go through their new menu design and pick a video to watch and it will play fine. When it is over I can exit back to the menu screen but when I try to play another video the usual bottom screen controls menu appears but the video will not play. No matter what I do I can't exit out of that screen. When the bluray's "home" button is pushed to exit me out of the YouTube browser the attached image shows the next screen. It stays on this screen which I can't exit from until I turn Oppo off and restart.

They only way I can go from one video to another in YouTube now is to exit out of YouTube and re-enter YouTube after each video.

My player has the updated firmware also.

Any ideas?

This happens no matter if I am browsing using a paired devise or just the remote. And started to occur only in the past few days.
As a workaround, start YouTube on your phone will the Oppo is on, pair the phone's YouTube with the Oppo, then operate youtube from the phone (the search and interface are much better).

AT&T U-Verse Northeast Ohio

Denon x4000, Carver m1.0t, Samsung LED TV, B&W 704 mains, two M&K subwoofers, Oppo 103, Roku 2, etc.
Headphone system: Sennheiser HD600, AKG K701, Burson HA-160, Marantz CD5004, Denon DVD-3910
pbarach is offline  
Old 06-28-2015, 11:23 AM
Advanced Member
 
bweissman's Avatar
 
Join Date: Sep 2003
Location: California
Posts: 898
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 114 Post(s)
Liked: 49
Quote:
Originally Posted by Darren Németh View Post
The screen the player freezes to when I try to exit out of YouTube as described above.
My 103 shows that screen for a very long time when exiting YouTube, but it eventually goes away. I think it took 5 minutes the last time. What is so time-consuming about exiting this app???

Unrelated gripe: the 103's YouTube app won't play the streaming Grateful Dead shows. "Sorry, this video cannot be viewed on this device." Grr.
bweissman is offline  
Old 06-28-2015, 11:33 AM
AVS Special Member
 
SeeMoreDigital's Avatar
 
Join Date: Jul 2003
Location: Notts, UK
Posts: 2,104
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 252 Post(s)
Liked: 113
Quote:
Originally Posted by bweissman View Post
My 103 shows that screen for a very long time when exiting YouTube, but it eventually goes away. I think it took 5 minutes the last time. What is so time-consuming about exiting this app???

Unrelated gripe: the 103's YouTube app won't play the streaming Grateful Dead shows. "Sorry, this video cannot be viewed on this device." Grr.
I can't remember the last time I used the YouTube app. Anyway, I've just tried it and it took 25 seconds to get to the Home Page... And 10 seconds to exit.

I SUPPORT 'FAIR USE'. MY MORALS PREVENT ME FROM HELPING ANYONE WHO OBTAINS COPYRIGHTED CONTENT ILLEGITIMATELY
I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout and A/V Gear

Last edited by SeeMoreDigital; 06-28-2015 at 12:17 PM.
SeeMoreDigital is offline  
Old 06-28-2015, 12:14 PM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 28,689
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 958 Post(s)
Liked: 1174
^ I believe it is trying to record what you watched for your account's recently viewed history, but when Google is involved (they own YouTube) it's hard to be sure what they've decided to stash.
--Bob

Anthem D2/D2v/AVM50/AVM50v/ARC1 tweaking guide. -- Need personal consultation/training? PM me!
Bob Pariseau is online now  
Old 06-28-2015, 12:15 PM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 28,689
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 958 Post(s)
Liked: 1174
Quote:
Originally Posted by bweissman View Post
. . . .
Unrelated gripe: the 103's YouTube app won't play the streaming Grateful Dead shows. "Sorry, this video cannot be viewed on this device." Grr.
YouTube evidently acquires some content for distribution to computers only -- excluding home theater devices.
--Bob

Anthem D2/D2v/AVM50/AVM50v/ARC1 tweaking guide. -- Need personal consultation/training? PM me!
Bob Pariseau is online now  
Old 06-28-2015, 02:18 PM
Advanced Member
 
bweissman's Avatar
 
Join Date: Sep 2003
Location: California
Posts: 898
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 114 Post(s)
Liked: 49
Quote:
Originally Posted by Bob Pariseau View Post
YouTube evidently acquires some content for distribution to computers only -- excluding home theater devices.
--Bob
In this case, other HT devices (AppleTV, Roku, Chromecast, and more) were supported. But no Blu-ray players.
bweissman is offline  
Old 06-28-2015, 03:24 PM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 28,689
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 958 Post(s)
Liked: 1174
^ It's kind of silly, but that's Google for you. I believe all of those have YouTube clients that support the latest YouTube, HTML 5 interface. So do the OPPO 10x players. But a lot of older Blu-ray players don't, so they may have decided to block all Blu-ray players to keep it simple. Except for things like the PS3, of course, which they had to allow in because there are so darn many of them out there.
--Bob

Anthem D2/D2v/AVM50/AVM50v/ARC1 tweaking guide. -- Need personal consultation/training? PM me!
Bob Pariseau is online now  
Old 06-28-2015, 04:09 PM
AVS Special Member
 
ellisr63's Avatar
 
Join Date: Jul 2002
Location: Northern California, In the HT
Posts: 2,539
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 396 Post(s)
Liked: 293
Strange thing happened today... I was setting up the Krell Showcaes 7.1, and the Oppo 103, and i noticed that as of today my Media Server (Openelec/Kodi) will not play DTS-HD movies when passing through the Oppo 103. It played them fine the day before, and i had changed no settings on it. Is there a setting somewhere on the Oppo that would only affect the HDMI inputs? I am using the Oppo 7.1 analog out only on the Oppo. If i stream the same movie directly from the Unraid NAS to the Oppo it plays fine, but when I switch the Oppo to the rear HDMI (where the Media server is) it will not play any audio from the same movie (picture plays fine).

Krell Showcase 7.1, (3) JBL 2360As/EV DHA-1s, (3) 1/4 Pie bass bins, (3) MiniDSP 2x4s, (4) Klipsch HIPs,  PS3, XBox 360, (3) Intel NUCs, Blue Jeans 7.1 Cables, Redmere HDMI cables, Monster HTPS7000, 2 DTS-10 subs, Panasonic AE8000, SeymourAV 180 (195" diagonal) scope screen, Darbee Darcet, (1) Yamaha P7000s, (4) Yamaha P2500s, & (2) Yamaha P2075 amps, and a Oppo 103.
The Ellis Family Go Big or go Home HT
ellisr63 is online now  
Old 06-28-2015, 04:20 PM
AVS Special Member
 
fmalczewski's Avatar
 
Join Date: Feb 2004
Posts: 1,038
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 51 Post(s)
Liked: 31
Quote:
Originally Posted by ellisr63 View Post
Strange thing happened today... I was setting up the Krell Showcaes 7.1, and the Oppo 103, and i noticed that as of today my Media Server (Openelec/Kodi) will not play DTS-HD movies when passing through the Oppo 103. It played them fine the day before, and i had changed no settings on it. Is there a setting somewhere on the Oppo that would only affect the HDMI inputs? I am using the Oppo 7.1 analog out only on the Oppo. If i stream the same movie directly from the Unraid NAS to the Oppo it plays fine, but when I switch the Oppo to the rear HDMI (where the Media server is) it will not play any audio from the same movie (picture plays fine).
LPCM is the only lossless audio that can be passed through the Oppo's HDMI inputs, if I'm not mistaken. Otherwise it's plain old DD or DTS.
ellisr63 likes this.
fmalczewski is offline  
Old 06-28-2015, 04:24 PM
AVS Special Member
 
ellisr63's Avatar
 
Join Date: Jul 2002
Location: Northern California, In the HT
Posts: 2,539
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 396 Post(s)
Liked: 293
Quote:
Originally Posted by fmalczewski View Post
LPCM is the only lossless audio that can be passed through the Oppo's HDMI inputs, if I'm not mistaken. Otherwise it's plain old DD or DTS.
Sorry, I meant HDMI to the Oppo... not passing through with HDMI. Since I am not running HDMI through... Shouldn't the Oppo be converting the DTS-HD tracks to analog 7.1?

Krell Showcase 7.1, (3) JBL 2360As/EV DHA-1s, (3) 1/4 Pie bass bins, (3) MiniDSP 2x4s, (4) Klipsch HIPs,  PS3, XBox 360, (3) Intel NUCs, Blue Jeans 7.1 Cables, Redmere HDMI cables, Monster HTPS7000, 2 DTS-10 subs, Panasonic AE8000, SeymourAV 180 (195" diagonal) scope screen, Darbee Darcet, (1) Yamaha P7000s, (4) Yamaha P2500s, & (2) Yamaha P2075 amps, and a Oppo 103.
The Ellis Family Go Big or go Home HT
ellisr63 is online now  
Old 06-28-2015, 04:35 PM
AVS Special Member
 
fmalczewski's Avatar
 
Join Date: Feb 2004
Posts: 1,038
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 51 Post(s)
Liked: 31
Quote:
Originally Posted by ellisr63 View Post
Sorry, I meant HDMI to the Oppo... not passing through with HDMI. Since I am not running HDMI through... Shouldn't the Oppo be converting the DTS-HD tracks to analog 7.1?
No, it does not know what to do with such a lossless audio track. Input has to be PCM or DD (or DTS) to begin with. (I'm being lazy and not looking in the manual, or the 103 FAQ, but perhaps you should. Pretty sure it's spelled out there.)
ellisr63 likes this.
fmalczewski is offline  
Old Today, 02:21 PM
AVS Special Member
 
QuiGonJosh's Avatar
 
Join Date: Mar 2003
Posts: 1,024
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 121 Post(s)
Liked: 65
I too am having trouble with the Youtube app. It's been working spendidly up until this point. I get to watch one video and then select another and it freezes on the video loading screen and the only thing I can do is power it off and back on. Then I usually have to sign back into Youtube. Please someone at Oppo, help!
QuiGonJosh is offline  
Old Today, 02:34 PM
AVS Special Member
 
scott_bernstein's Avatar
 
Join Date: Oct 2004
Location: Upper West Side, Manhattan, NYC, US
Posts: 1,622
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 16
Quote:
Originally Posted by QuiGonJosh View Post
I too am having trouble with the Youtube app. It's been working spendidly up until this point. I get to watch one video and then select another and it freezes on the video loading screen and the only thing I can do is power it off and back on. Then I usually have to sign back into Youtube. Please someone at Oppo, help!
I noticed that my Samsung Smart TV used to have the EXACT same Youtube app as the Oppo. But in one of my TV's recent firmware updates, the YouTube app got a complete overhaul. Maybe it's related to the YouTube app being slightly outdated now? (I suspect the next Oppo firmware release will contain this same update?)

It's been a while since I did any YouTube watching on my Oppo, so cannot confirm whether I'm having the issue or not.

Have you tried the standard solutions to any problem? i.e. switch the "Quick Start" mode to whichever setting you don't have, factory reset, etc.?
scott_bernstein is offline  
Old Today, 02:39 PM
Member
 
poochpa's Avatar
 
Join Date: Jun 2011
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
I'm considering buying the BDP-103. When playing a std. music cd, will the 103 display track info on a connected TV screen without resort to Gracenote? If so, what info will it show? Thanks.
Mike
poochpa is online now  
Old Today, 02:42 PM
AVS Special Member
 
scott_bernstein's Avatar
 
Join Date: Oct 2004
Location: Upper West Side, Manhattan, NYC, US
Posts: 1,622
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 16
Quote:
Originally Posted by poochpa View Post
I'm considering buying the BDP-103. When playing a std. music cd, will the 103 display track info on a connected TV screen without resort to Gracenote? If so, what info will it show? Thanks.
Mike
It will go to Gracenote if you allow it to (I believe there is a setting?) and if it's connected to the internet. But if it can't get to Gracenote, it will read track info encoded in CD-TEXT if the CD has it. Certainly very old CDs don't have it. But many CDs from the last 10 years or so have it encoded. Otherwise it will basically just say "Track 1", "track 2", etc.
scott_bernstein is offline  
Old Today, 05:39 PM
Member
 
poochpa's Avatar
 
Join Date: Jun 2011
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Quote:
Originally Posted by scott_bernstein View Post
It will go to Gracenote if you allow it to (I believe there is a setting?) and if it's connected to the internet. But if it can't get to Gracenote, it will read track info encoded in CD-TEXT if the CD has it. Certainly very old CDs don't have it. But many CDs from the last 10 years or so have it encoded. Otherwise it will basically just say "Track 1", "track 2", etc.
Thanks Scott. That's disappointing. The majority of my cds are from the 1980s and 90s. About half of them are classical, and Gracenote has trouble with the more obscure or import ones.
Mike
poochpa is online now  
Sponsored Links
Advertisement
 
 

Tags
Oppo Bdp 103 3d Blu Ray Player , Oppo Bdp 105 Blu Ray Player , Oppo Bdp 93 Blu Ray Player , Oppo Digital Inc
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off