Official OPPO BDP-105 Owner's Thread - Page 199 - AVS Forum
Forum Jump: 
 46Likes
Reply
 
Thread Tools
post #5941 of 11418 Old 06-14-2013, 11:37 AM
wse
AVS Special Member
 
wse's Avatar
 
Join Date: Mar 2008
Location: USA
Posts: 6,489
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 232 Post(s)
Liked: 299
Quote:
Originally Posted by Process53 View Post

Sure in hindsight that's exactly what I should have done. My question was should Oppo have informed the "marketplace" (the buyers) back in April about optional chassis colours? If they knew it was coming why not advertise the fact? Look I know this is all a bit of "sour grapes" and "after the fact" and "live and learn" stuff. I missed the boat on this one - maybe others did too. Maybe there is a lesson for Oppo as well.

I had bought the black one and after sent them an email to consider a silve one for the next version of OPPO, that's when they told me about the silver coming out so I returned the black one in the mean time I had sold my BDP-95 and was left with an old Pansonic for two months before the Silver came out!
wse is offline  
Sponsored Links
Advertisement
 
post #5942 of 11418 Old 06-14-2013, 12:12 PM
Senior Member
 
Process53's Avatar
 
Join Date: Jul 2007
Location: Lacombe, Alberta, Canada
Posts: 250
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 23
Quote:
Originally Posted by wse View Post

I had bought the black one and after sent them an email to consider a silve one for the next version of OPPO, that's when they told me about the silver coming out so I returned the black one in the mean time I had sold my BDP-95 and was left with an old Pansonic for two months before the Silver came out!
Now that is brutal! smile.gif

Going through my Canadian dealer there will be return shipping costs at the very least so I will be keeping what I have. The bottom line - since I got the 105 my music system sounds incredible.

Oppo BDP-105 Player
Musical Paradise MP-301 MK3 Tube Amp x 3
Paradigm Studio 60 v.2 x 3 Speakers
Paradigm Studio ADP-470 v.3 x 2 Speakers
Paradigm Seismic-10 Subwoofer
Process53 is offline  
post #5943 of 11418 Old 06-14-2013, 12:53 PM
AVS Addicted Member
 
rdgrimes's Avatar
 
Join Date: Mar 2004
Location: Nuevo Mexico
Posts: 16,143
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 181 Post(s)
Liked: 215
Considering the price that used 105 players are bringing on eBay, how much would it really cost to "trade up" to silver? Maybe $200?
But as gsr stated, there's no guarantee that silver players will ever be available again, so if someone really wants one they should act. One might also ask Oppo if they have any replacement face plates in silver.
rdgrimes is online now  
post #5944 of 11418 Old 06-14-2013, 01:00 PM
wse
AVS Special Member
 
wse's Avatar
 
Join Date: Mar 2008
Location: USA
Posts: 6,489
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 232 Post(s)
Liked: 299
Quote:
Originally Posted by rdgrimes View Post

Considering the price that used 105 players are bringing on eBay, how much would it really cost to "trade up" to silver? Maybe $200?
But as gsr stated, there's no guarantee that silver players will ever be available again, so if someone really wants one they should act. One might also ask Oppo if they have any replacement face plates in silver.

From what they told me they do, but I wanted the whole unit in silver which is why I waited!
wse is offline  
post #5945 of 11418 Old 06-14-2013, 02:13 PM
Advanced Member
 
a1usedcomp's Avatar
 
Join Date: Jun 2009
Location: Janesville WI
Posts: 745
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 25



I didn't even know that silver was an option , looks pretty slick

Preamp: NOS Valves NBS Preamplifier
Selah Tempestas
BMC Pure Dac - Mac Mini
VPI Classic 2
a1usedcomp is offline  
post #5946 of 11418 Old 06-14-2013, 03:29 PM - Thread Starter
AVS Addicted Member
 
Neuromancer's Avatar
 
Join Date: Jul 2005
Location: Navigating the Black IC
Posts: 10,959
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 171
Silver became available only last Friday.
Neuromancer is offline  
post #5947 of 11418 Old 06-14-2013, 03:48 PM
wse
AVS Special Member
 
wse's Avatar
 
Join Date: Mar 2008
Location: USA
Posts: 6,489
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 232 Post(s)
Liked: 299
Quote:
Originally Posted by a1usedcomp View Post


I didn't even know that silver was an option , looks pretty slick

Yes I like it it fits well with the SSP-800!
wse is offline  
post #5948 of 11418 Old 06-14-2013, 10:07 PM
AVS Special Member
 
dmusoke's Avatar
 
Join Date: Jul 2009
Location: Redondo Beach, CA
Posts: 2,425
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 78

I believe Bob P. asked you for pictures a page back?

Tasdom likes this.

How to phase match subwoofers to the mains speakers: http://www.avsforum.com/avs-vb/showt...0#post19542630
dmusoke is offline  
post #5949 of 11418 Old 06-15-2013, 08:03 AM
wse
AVS Special Member
 
wse's Avatar
 
Join Date: Mar 2008
Location: USA
Posts: 6,489
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 232 Post(s)
Liked: 299
Quote:
Originally Posted by dmusoke View Post

I believe Bob P. asked you for pictures a page back?

And the magic word is!
wse is offline  
post #5950 of 11418 Old 06-15-2013, 08:55 AM
AVS Special Member
 
Torqdog's Avatar
 
Join Date: May 2010
Location: Carson City, NV
Posts: 1,387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 102
Quote:
Originally Posted by wse View Post

And the magic word is!
Pretty please with a cherry on top? LOL

He (or she) who dies with the most HT gear doesn't win anything. They're DEAD!
Torqdog is offline  
post #5951 of 11418 Old 06-15-2013, 08:57 AM
Member
 
tr@nz's Avatar
 
Join Date: Aug 2007
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by Mikicasellas View Post

Hello everyone,

I am curious about the DAC performance of the OPPO 105 compared with other DACs like Benchmark 2 or Wyred4Sound DAC2 SE, has anyone compared?

Mike

Hi Mike,

Yes I have compared it to the Benchmark 1, and a few pricier models. It is okay but does not beat the dedicated DACs. Now to be fair many quality DACs cost more than the Oppo alone. You can also use it as an USB to SPDIF converter and still use an external DAC.
It really depends on how revealing your system is. Every ear is different, so you really need to do your own testdrive but don't expect it to beat a DAC2 or W4S.
tr@nz is offline  
post #5952 of 11418 Old 06-15-2013, 09:57 AM
MLM
Senior Member
 
MLM's Avatar
 
Join Date: Jan 2003
Location: New York City Area
Posts: 283
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by Mikicasellas View Post

Hello everyone,

I am curious about the DAC performance of the OPPO 105 compared with other DACs like Benchmark 2 or Wyred4Sound DAC2 SE, has anyone compared?

Mike

I have compared it to the DAC I had for several years, the Lavry Black, an already excellent unit that gave many years of pleasure. In detail, space, soundstage, transients, dynamics and bass response the Oppo is a clear winner. I am impressed with how notes begin on the Oppo. It is extremely competitive in important respects with vinyl and this concert-goer finds that it brings me closer to the real thing than I have before experienced with digital.

Some people have found the Oppo "thin" sounding. In the first place, often it does not get enough break-in before conclusions are drawn. When I first heard mine I wondered, "What have I done?" In the second place, and here is a strong opinion, many hi fi rigs (and very many that I have experienced in hi fi shops) are thin sounding, seemingly designed to show off the detail of what's coming through. This seems especially true on the naturally recorded classical material I normally bring in. Hence, perhaps, the eventual desire to seek mods to change the Oppo sound.

On my Sim Audio/Von Schweikert system the Lavry sounded quite lush--extremely pleasant but not as close to the real thing as the Oppo--at least to me.

The Oppo is also quite good enough to demand better than give-away interconnects and power cord IMO.

Just my $.02

Len
MLM is offline  
post #5953 of 11418 Old 06-15-2013, 10:12 AM
wse
AVS Special Member
 
wse's Avatar
 
Join Date: Mar 2008
Location: USA
Posts: 6,489
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 232 Post(s)
Liked: 299
Quote:
Originally Posted by Torqdog View Post

Pretty please with a cherry on top? LOL

Now that's the magic word, will do soon!
wse is offline  
post #5954 of 11418 Old 06-15-2013, 10:27 AM
AVS Special Member
 
dmusoke's Avatar
 
Join Date: Jul 2009
Location: Redondo Beach, CA
Posts: 2,425
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 78

smile.gif


How to phase match subwoofers to the mains speakers: http://www.avsforum.com/avs-vb/showt...0#post19542630
dmusoke is offline  
post #5955 of 11418 Old 06-16-2013, 09:37 AM
Advanced Member
 
a1usedcomp's Avatar
 
Join Date: Jun 2009
Location: Janesville WI
Posts: 745
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 25
Does anyone here own a SONY SCD-XA5400ES along with a Oppo BDP-105 ? I just purchased the 105 and it only has maybe 15 hours on it but my Sony just seems to sound better when playing " SACD" Analog

Preamp: NOS Valves NBS Preamplifier
Selah Tempestas
BMC Pure Dac - Mac Mini
VPI Classic 2
a1usedcomp is offline  
post #5956 of 11418 Old 06-16-2013, 09:52 AM
Advanced Member
 
DanF8500's Avatar
 
Join Date: Apr 2013
Posts: 963
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Liked: 136
Quote:
Originally Posted by a1usedcomp View Post

Does anyone here own a SONY SCD-XA5400ES along with a Oppo BDP-105 ? I just purchased the 105 and it only has maybe 15 hours on it but my Sony just seems to sound better when playing " SACD" Analog
Can you elaborate a little more when you say "seems to sound better"? Details please? More warmth, more bass, more revealing, etc.....if you listened to and enjoyed a component in your home for years, it's hard to break that bias....Also, were you playing a multi-channel or stereo sacd? What analog outputs were you using on the 105 (multi or two-chan)?
DanF8500 is offline  
post #5957 of 11418 Old 06-16-2013, 10:02 AM
MLM
Senior Member
 
MLM's Avatar
 
Join Date: Jan 2003
Location: New York City Area
Posts: 283
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by a1usedcomp View Post

Does anyone here own a SONY SCD-XA5400ES along with a Oppo BDP-105 ? I just purchased the 105 and it only has maybe 15 hours on it but my Sony just seems to sound better when playing " SACD" Analog

The Oppo needs about 200-300 hours of play to break in. Put some music on a zip drive and have it play continuously 24/7. You'll be quite surprised.

Len
MLM is offline  
post #5958 of 11418 Old 06-16-2013, 01:12 PM
AVS Special Member
 
bakerwi's Avatar
 
Join Date: Jul 2008
Location: The Peach State
Posts: 2,840
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Liked: 35
Quote:
Originally Posted by a1usedcomp View Post

Does anyone here own a SONY SCD-XA5400ES along with a Oppo BDP-105 ? I just purchased the 105 and it only has maybe 15 hours on it but my Sony just seems to sound better when playing " SACD" Analog

Well you’re ears are accustom to the Sony sonic signature. What I hear between my players are “differences” and I have a preference for one over the other depending on the genre of music.smile.gif In the end you may still prefer the Sony and you wouldn't be the first.smile.gif

Pioneer Elite PRO-151FD

Zektor MAS7.1

Classé CA-2200/CA-5200

Oppo BDP-105, Denon DVD-5910CI, Cambridge 752BD, Cambridge 640C V2

Paradigm Signature S8, Paradigm Signature ADP1

Paradigm Signature ADP3, Paradigm Signature C5

REL R-505 Sub (2)

Oppo BDP-93, BDP-103D, Pioneer BDP-320

Sony BDP-S790

bakerwi is online now  
post #5959 of 11418 Old 06-16-2013, 04:25 PM
Member
 
audionuts's Avatar
 
Join Date: Aug 2012
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 16
What is going on with my Oppo 105. The player just stop in the middle of the play (Celtic Thunder- it's entertainment blu ray disc) and I can not do anything to it. I got no picture, no sound. I even unplug the power outlet and wait a little bit but gotno luck. My disc is stuck inside the player. Now all I got is the blue light on but my home screen on my tv is blank and still got no respone from the player. I can not even eject my disc. I will contact Oppo soon but just ask here to see if anyone got the same experience.
audionuts is offline  
post #5960 of 11418 Old 06-16-2013, 06:41 PM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 27,391
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 251 Post(s)
Liked: 847
Quote:
Originally Posted by audionuts View Post

What is going on with my Oppo 105. The player just stop in the middle of the play (Celtic Thunder- it's entertainment blu ray disc) and I can not do anything to it. I got no picture, no sound. I even unplug the power outlet and wait a little bit but gotno luck. My disc is stuck inside the player. Now all I got is the blue light on but my home screen on my tv is blank and still got no respone from the player. I can not even eject my disc. I will contact Oppo soon but just ask here to see if anyone got the same experience.

OK, this is not good. Your player likely needs service (it's acting like it has a power supply problem).

Try this:

1) Disconnect EVERYTHING from the player -- even the Wifi stick or any USB sticks, and take the player and its power cord to another room that's fed with a different wall power circuit.

2) Wait half an hour with the player unplugged.

3) With the player still unplugged, PRESS AND HOLD the power button on its Front Panel for 10 seconds. This is to discharge any lingering power in the circuitry.

4) Plug in the player, wait for its Red power light to show near the Front Panel power button. Do not press that Power Button.

5) Instead, press the TRAY OPEN button on the Front Panel. This should both power up the player and immediately eject the Tray.

If the player powers up normally and the Tray opens, then remove the disc, power off, and try power cycling a few more times. If still no problem then take the player back to your normal setup and hook it up one step at a time -- starting with just the power cord. The problem might either be a voltage problem on the power feed there, or a short or other electrical issue on the various things you have connected to the player. Isolate which connection is causing the problem.

If the player does NOT power up normally when disconnected and moved, then email OPPO Tech Support to arrange warranty service (or call them tomorrow during work hours).
--Bob

Anthem D2/D2v/AVM50/AVM50v/ARC1 tweaking guide. -- Need personal consultation/training? PM me!
Bob Pariseau is offline  
post #5961 of 11418 Old 06-16-2013, 06:45 PM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 27,391
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 251 Post(s)
Liked: 847
Quote:
Originally Posted by wse View Post

And the magic word is!

Wednesday: Pass the salt.
Uncle Fester: What do we say?
Wednesday: NOW!!

--Bob

Anthem D2/D2v/AVM50/AVM50v/ARC1 tweaking guide. -- Need personal consultation/training? PM me!
Bob Pariseau is offline  
post #5962 of 11418 Old 06-16-2013, 06:54 PM
wse
AVS Special Member
 
wse's Avatar
 
Join Date: Mar 2008
Location: USA
Posts: 6,489
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 232 Post(s)
Liked: 299

So sorry, on the road so pictures are going to have to wait! wink.gif

wse is offline  
post #5963 of 11418 Old 06-16-2013, 08:19 PM
Member
 
audionuts's Avatar
 
Join Date: Aug 2012
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 16
Bob,

Thank you for your respone. I did contact Oppo and got a quick respone. Their solution is just like what you have susgested. Unfortunately, I am not home right now will be back late tonight so This will be a first thing I would do tomorrow. Thanks anyway.

Here is Oppo respone to my problem.

Disconnect all cables from the player, including the HDMI, analog, and power cables. If your player was hardware modified to support alternative regions, please try removing this kit and returning the player to stock.

Change the dip switch on the back of the player from 115V to 230V.

Press and hold the POWER button on the front panel of the player for 5 seconds. Release.

Change the dip switch on the back of the player from 230V to 115V.

Reconnect just the power cable, connecting it direct toy our walled power outlet, bypassing any switch, power conditioner or transformer.

Press EJECT.

Does the player turn on, eject the tray, and eventually display OPEN after 10 minutes?

Best Regards,

Customer Service
OPPO Digital, Inc.
2629B Terminal Blvd.
Mountain View, CA 94043
Service@oppodigital.com
Tel: 650-961-1118
Fax: 650-961-1119

Edit: I took the player out and follow the direction above. No luck at all. Oppo has issue RMA lable. Kudo to Oppo service.
audionuts is offline  
post #5964 of 11418 Old 06-16-2013, 09:37 PM
AVS Special Member
 
Styln's Avatar
 
Join Date: Nov 2006
Location: Silicon Valley, CA
Posts: 1,157
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 26
"We can convert the player to a Silver unit for $150.00 plus the shipping to us. This fee covers all parts, labor and return shipping to you.

Best Regards,

Customer Service
OPPO Digital, Inc.
2629B Terminal Blvd.
Mountain View, CA 94043
Service@oppodigital.com
Tel: 650-961-1118
Fax: 650-961-1119"

Since I live and work in the bay area, this is very affordable. Looking forward to a silver Oppo that finally matches the rest of my system! When it returns will do a complete audio review. Am sure that silver will sound superior to black... post burn-in, of course smile.gif

Styln
Styln is offline  
post #5965 of 11418 Old 06-16-2013, 10:58 PM
AVS Special Member
 
audiofan1's Avatar
 
Join Date: Feb 2009
Posts: 3,015
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 413
Quote:
Originally Posted by Styln View Post

"We can convert the player to a Silver unit for $150.00 plus the shipping to us. This fee covers all parts, labor and return shipping to you.

Best Regards,

Customer Service
OPPO Digital, Inc.
2629B Terminal Blvd.
Mountain View, CA 94043
Service@oppodigital.com
Tel: 650-961-1118
Fax: 650-961-1119"

Since I live and work in the bay area, this is very affordable. Looking forward to a silver Oppo that finally matches the rest of my system! When it returns will do a complete audio review. Am sure that silver will sound superior to black... post burn-in, of course smile.gif

Styln

Hmm! maybe! just maybe I will biggrin.gif it might just give my Halo A21 some company in the rack finally !
audiofan1 is offline  
post #5966 of 11418 Old 06-17-2013, 12:04 AM
Newbie
 
letmely's Avatar
 
Join Date: Aug 2006
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Having the same issue as many other with netflix freezing (black screen) after finishing streaming episode. Tried the factory reset / clearing everything / unplugging but the problem persists. Running the latest official firmware. Highly annoying.
letmely is offline  
post #5967 of 11418 Old 06-17-2013, 12:29 AM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 27,391
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 251 Post(s)
Liked: 847
Quote:
Originally Posted by letmely View Post

Having the same issue as many other with netflix freezing (black screen) after finishing streaming episode. Tried the factory reset / clearing everything / unplugging but the problem persists. Running the latest official firmware. Highly annoying.

Yep. I don't know of a workaround to this. We're all in the same boat -- just waiting until OPPO & Netflix can sort this out.

The only hint we've got is that OPPO has said this is related to the Netflix app re-authorixing the player's connection to the account -- something that happens rather frequently apparently, given the way Netflix coded that app. I don't know how confident they are that this is the problem.

It has been suggested that you switch the DNS settings in the player to use one of the free, public DNS servers instead of the one provided by your ISP -- i.e., Google's free DNS servers, or OpenDNS, both of which are highly regarded. This can't be a true fix, but it MAY reduce the chances of failure due to the player being able to make the periodic authorization connection faster. For example the OpenDNS servers are at 208.67.222.222 and 208.67.220.220. Anybody can use them -- no need to set up any sort of account or the like. Similarly with Google's version.
--Bob

Anthem D2/D2v/AVM50/AVM50v/ARC1 tweaking guide. -- Need personal consultation/training? PM me!
Bob Pariseau is offline  
post #5968 of 11418 Old 06-17-2013, 07:09 AM
AVS Club Gold
 
thduke's Avatar
 
Join Date: Dec 2010
Location: LI New York
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 15
I am not having such problems with Netflix running the latest official firmware Optimum online is my ISP, I did de-active and re-activate after the firmware upgrade have had no issues since.

GoldenEar Triton One's 2
GoldenEar Triton Two's 2
GoldenEar Super Center XL 1
GoldenEar SuperSat 3 2
GoldenEar ForceField 5 1
OPPO 105, Emotiva XPA-5, Emotiva XPA-2
thduke is offline  
post #5969 of 11418 Old 06-17-2013, 07:17 AM
Newbie
 
edemtbs's Avatar
 
Join Date: Jan 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Bob Pariseau View Post

Yep. I don't know of a workaround to this. We're all in the same boat -- just waiting until OPPO & Netflix can sort this out.

There is some comfort in knowing that I'm not the only one and that a remedy is pending. Seems to fluctuate between being mostly okay to sometimes constantly freezing - no idea why. Looking forward to a fix.
edemtbs is offline  
post #5970 of 11418 Old 06-17-2013, 10:40 AM
Senior Member
 
bwv1080's Avatar
 
Join Date: Aug 2009
Location: Davis, CA
Posts: 301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 42
Quote:
Originally Posted by a1usedcomp View Post

Does anyone here own a SONY SCD-XA5400ES along with a Oppo BDP-105 ? I just purchased the 105 and it only has maybe 15 hours on it but my Sony just seems to sound better when playing " SACD" Analog

I have both and prefer the 105 via HDMI overall (I vastly prefer multi-channel audio). It has better bass and sounds a little less "digital" to me. The differences are rather subtle, though.

DALI Epicon 2 front speakers; DALI Epicon Vokal center speaker; Definitive Technology ProMonitor 1000 surrounds; SVS SB 13 Ultra subwoofer; Marantz AV 8801 pre/pro; Parasound Halo A51 power amp; Sony XA5400ES SACD player; Oppo BDP 105 SACD/Blu-ray player; Sennheiser HD 800 headphones; Woo Audio WA6 headphone amp.
bwv1080 is offline  
Reply Blu-ray Players

Tags
Oppo Bdp 105 Blu Ray Player

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off