BDP-S590 Issue. Sound but no video. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 12-09-2012, 04:54 PM - Thread Starter
Newbie
 
Rob Kenny's Avatar
 
Join Date: Dec 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey all - Long time lurker, new poster.. I did some searching but didn't find anything on this so I come looking for you guys for some help.

I have a newly purchased Sony BDP-S590 Blu-Ray player for my home theater system. Everything is connected via HDMI to a Denon AVR-1612 receiver. The issue I'm having is that when I go to play a Blu-Ray disc, I get sound but no video. If I play a DVD on the player, audio and video works fine. Thinking it might be the Denon, I bypassed the receiver and plugged the Blu-Ray directly into the TV seeing if I could get video but it does the same thing... I walked through the settings on the player and everything seems to be ok - Any thoughts?

Thanks!
Rob
Rob Kenny is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-09-2012, 05:08 PM
AVS Special Member
 
JChin's Avatar
 
Join Date: Oct 2008
Location: Mesquite Tx
Posts: 8,526
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
Liked: 132
Hi Rob Kenny, welcome to AVS. Just fyi mods has ask that all posts go in the official player thread (Official Sony BDP-S590 and BDP-390 Thread).

You can try turning off "HDMI Deep Color Output" found in the setting menu under "Screen Settings".
JChin is offline  
post #3 of 3 Old 12-09-2012, 05:15 PM - Thread Starter
Newbie
 
Rob Kenny's Avatar
 
Join Date: Dec 2012
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Oops, my mistake. I tried to delete the thread but it seems to be I couldn't.

I changed the output to 1080i and it works but my TV, while older, was advertised as 1080p. It's a Samsung LN-S4095. I have a post going over on that thread since it seems to be a TV issue. THANKS for the quick reply.
Rob Kenny is offline  
Closed Thread Blu-ray Players

Tags
Sony Bdp S590 3d Blu Ray Player
Gear in this thread - S590 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off