Help with Blu Ray Player - please - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 01-22-2013, 10:23 AM - Thread Starter
Member
 
DustyMonkey1's Avatar
 
Join Date: May 2008
Posts: 85
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I bought a home theater in a box about a year ago. It came with a Samsung Blu-Ray that the surround sound speakers connect directly into the back of the Blu-Ray player and it acts as the receiver as well. I haven't had a problem with the player...until now.

The optical jack in the back (that I use with my cable box) has stopped working correctly. I tried two different optical cables and it only gets sound through optical when the I don't insert the cord in all the way. And the HDMI won't keep a signal to the TV. Some of the time the TV says "no signal" other times it will go a gray snowy screen during a movie. I have to smack the player and move it to get the signal back. Tried three different HDMI cables and this happened on all of them.

Is the player shot? If I get a new Blu Ray player, how will I hook up my speakers? These are the speakers that specifically came with this setup (7.1 system) and as I said, they go directly in the back of the player. There is a separate connection for each. So if I upgrade my player, how will I use my speakers? There is no other way to connect them, and the rear surround speakers are wireless and this player picks them up.

Any advice would be appreciated.
DustyMonkey1 is offline  
Reply Blu-ray Players

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off