Issue with either my Oppo BDP 93 or Rotel RSX 1560 - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
Old 03-28-2013, 11:09 AM - Thread Starter
Newbie
 
jalbregts's Avatar
 
Join Date: Jan 2008
Location: The Woodlands, TX
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have an Oppo BDP 93. A couple of firmware upgrades ago I started running into an issue and I'm curious if anyone else is seeing this. My Oppo is running through a Rotel RSX 1560. When I'm watching TV through my DirectTV receiver, and want to switch to the DVD, if the Oppo is already turned on and I switch to that input, I don't receive video or audio through my system (just a black screen). If I turn my Oppo off then on again, it will work. Obviously that's a pain so I don't want to have to do that.

I haven't changed anything on my Rotel so I don't know if it's a Rotel issue or an issue with one of my previous Oppo firmware upgrades. Has anyone else experienced this with either the Rotel or Oppo?

J Albregts
jalbregts is offline  
Sponsored Links
Advertisement
 
Old 03-28-2013, 02:37 PM
AVS Special Member
 
Alan P's Avatar
 
Join Date: Jan 2003
Location: South Dakota
Posts: 5,084
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 2064 Post(s)
Liked: 1090
Have you checked to make sure the HDMI cable is well seated? Tried a different cable?
Alan P is offline  
 

Tags
Oppo Bdp 93 Blu Ray Player
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off