Need help on BDP 8520 (BD660) - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 04-29-2013, 01:55 AM - Thread Starter
Senior Member
 
happy hopping's Avatar
 
Join Date: Dec 2006
Location: Malibu, CA, USA
Posts: 293
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
My BDP 8520 (the Wal Mart model BD660) was working fine. My folks ask me to test their BD660 at my house, so I unplug my BD 660, both the HDMI and the power cord. Plug my HDMI cable to their BD660 and connect their unit w/ power. They ask me to diagnositcs something unrelated, that only took 5 min.

I re-plug back in my BD660, now all I get is 480i instead of 1080p. So some1 told me it's the HDMI handshaking, so I turn off everything, turn on the BD660, then my Yamaha integrated amp., same thing, I only get 480i. I had 1080p since day 1.

I also try to connect my HDMI on the BD660 to the Sharp screen itself. Eventually it got 1080p. So I plug back that HDMI to the integrated amp., now back to 480i.

There must be a reset somehow, the question is, how do you fix it

p.s. the integrated amp. is the yamah Rx-v573, so either the integrated amp. is reset to 480i or the BD660 is not sending anything higher than 480i to the yamaha
happy hopping is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 05-12-2013, 05:24 AM - Thread Starter
Senior Member
 
happy hopping's Avatar
 
Join Date: Dec 2006
Location: Malibu, CA, USA
Posts: 293
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
I'm hoping some1 have more insight on this:

I got a 2nd BD660 player from a friend. His blu-ray BD660 player was playing 1080i on his samsung as that seems to be the max on his samsung.

Bring that BD660 over here, and it only plays at 1080i eventhough the Sharp screen can display 1080p

So realistically, we have:

BD660 Player 1 now somehow can only play at 480i

BD660 Player 2 now somehow can only play at 1080i or 720p, 480p, or 480i

For this BD660 player 2, When I press the HDMI button, the screen went blank, then I went to the TV setting page, select Auto, , it scaled down to 480p. Then I press the HDMI button, and it moves back to as much as 1080i eventhough the auto detect fail

There is no chance that both players are defective. There has to be a setting that can fix this. Can any1 help?
happy hopping is offline  
post #3 of 4 Old 05-13-2013, 09:14 AM
Advanced Member
 
Bill C.'s Avatar
 
Join Date: Apr 2006
Location: Plano, TX
Posts: 884
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 15
I don't have one of these to be sure, but I was curious: pushing the HDMI button on the remote apparently makes it cycle through its possible output display resolutions, right? (Similarly to some HD-DVD players and a few older DVD players.) So, as long as the set is happy with a 1080i/p signal, what happens if you try to cycle through its display outputs again?

...and I need your sweet love, Latina T-Mobile girl!

Bill C. is offline  
post #4 of 4 Old 05-15-2013, 04:31 AM - Thread Starter
Senior Member
 
happy hopping's Avatar
 
Join Date: Dec 2006
Location: Malibu, CA, USA
Posts: 293
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
I try that trick already. All I get is a black screen. Before I unplug the unit, I used to be able to see 1080p

Now, something else has happened: I was playing a region B blu-ray, it plays fine. Then while I try to continue watch that movie the next day, it no longer able to watch that very same movie. So I unplug the power cord, same thing. Until I do that 3 more times, then I can play the movie again.

All these is on my BD660 player 2. So there is some sort of bug
happy hopping is offline  
Reply Blu-ray Players

Tags
Bdp 52fd , Lg 3d Blu Ray Player Bd660
Gear in this thread

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off