NO SURROUND ON LG BH7420P connected to my PC ATI HD5670 - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 02-10-2013, 08:40 AM - Thread Starter
Newbie
 
Xblade II's Avatar
 
Join Date: Jan 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi, I have just purchased a LG BH7420P, and I am getting really disappointed as I can't get surround from my PC. I have a PC with a ATI HD5670, and I have connected with a HDMI cable on HDMI input 1 into the BH7420P and then HDMI to my LG LW650T, on windows 7 on my PC, on HDMI Audio output, my only options for speaker setup is Stereo, there is no quadraphonic or 5.1 Surround, when I look on properties it only shows max numbers of channels - 2, the bit rate are 32 / 44.1 / 48 Khz, the encoded formats supported are only dolby digital and DTS, I was expecting to see at least 6 channels, DTS HD, dolby digital +, dolby True HD, all audio formats supported by this home cinema system. I have tried many things, by installing HDMI audio drivers, AMD or Realtek, I have actually tried EDID overrrides, but I can't the surround to work.

I can see movies already encoded as DTS or dolby digital as 5.1 surround using fddshow audio encoder, but my point is I am not getting into the received 5.1 PCM audio. Does anyone have experienced or know if this possible with the device ?

Thanks
Xblade II is offline  
Reply General Home Theater & Media/Game Rooms

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off