No Sound: Sony PS-X55 Turntable through Pioneer VSX-520-K Receiver - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 03-26-2011, 03:16 PM - Thread Starter
Newbie
 
JohnnyD0914's Avatar
 
Join Date: Mar 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I'm having a problem getting my Sony PS-X55turntable to play through my Pioneer VSX-520-K Receiver. The turntable does work through my previous Panasonic receiver. I didn't find a input marked Phono on the back of the reciever, though it did advertise and spec phono capabilities. I did an internet search and found another person who was having the same problem and used the CD-R/Tape input and it worked for him. However that doesn't work for me. I used the CD-R/Tape input, selected CD-R/Tape on the receiver, scrolled through all the input signal settings for either HDMI, Digital, or Analog (which should be analog) and still no sound. Well, I get a weak signal if I really crank it up.

Any help would be appreciated.
JohnnyD0914 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-26-2011, 03:25 PM
AVS Special Member
 
mcnarus's Avatar
 
Join Date: Nov 2007
Posts: 6,126
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 94 Post(s)
Liked: 309
You MUST use a phono input. If your receiver doesn't have one, you'll need to buy a phono preamp. If budget is limited, check out www.phonopreamps.com.

If you can't explain how it works, you can't say it doesn't.—The High-End Creed

mcnarus is online now  
Reply CD Players & Dedicated Music Transports

Tags
Pioneer Vsx 520 K 5 1 Home Theater Receiver

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off