? re-badged clone ? pretender or contender HD radio ? 3 "new" HD radio's recently. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 12-02-2008, 11:31 PM - Thread Starter
Member
 
Lionanimal's Avatar
 
Join Date: May 2005
Location: metro Seattle, WA, USA
Posts: 141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 11
Within the last week I have seen two different "new" Insignia HD radios and one "new" S#ny HD radio model. Only the most recent Insignia has both digital coax and optical outputs. That is the one I purchased this evening.

Way to go S*ny for giving us only RCA jacks for outputs.

Soon I will hook it up to a rooftop HDTV antenna. That rooftop HDTV antenna worked really well with a Sangean 1X. I gave the 1X to my Dad.

Suppose I should have just rotated a second 1X into my rack, but I'm a bit adventuresome. The item I purchased late this evening was a small fraction of the purchase price of the Sangean, but appears from an external physical view to be either an imitator or a re-badged clone of the 1X.

However, the Insignia mini-system with HD that I purchased from Best Buy (it is their "house" brand from various sources) in Summer 2008 was and is a disappointment. Maybe this latest (different) model will be much improved.

Does anyone out-there want to read a review of it ?
Lionanimal is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 12-04-2008, 04:31 PM
AVS Special Member
 
jmscott42's Avatar
 
Join Date: Apr 2002
Posts: 1,186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I'd definitely be curious to hear how that Insignia compares to the Sangean, since they seem to be really close in functionality and I wonder if it isn't some sort of rebranding deal.

I was close to buying the Insignia but stumbled across the $50 rebate back in September that didn't include it (so ended up with the Sony which I'm plenty happy with, even without digital).. it'd be good to know how it stacks up, especially from someone with Sangean experience.
jmscott42 is offline  
post #3 of 6 Old 12-08-2008, 09:42 PM - Thread Starter
Member
 
Lionanimal's Avatar
 
Join Date: May 2005
Location: metro Seattle, WA, USA
Posts: 141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 11
Going from memory, since the latest (second) Insiginia is here now and the Sangean 1X was rotated out of here last June ...

The second Insignia sounds just as good. I don't have any technical equipment to give your the performance capability parameters however.

Note: Back in September I did purchase a small docking and mini Insignia with coaxial digital output etc. Total cr^p that one. This latest once is a vast improvement.
Lionanimal is offline  
post #4 of 6 Old 12-23-2008, 04:22 PM
AVS Special Member
 
ti-triodes's Avatar
 
Join Date: Mar 2007
Location: Damfino
Posts: 2,191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 32 Post(s)
Liked: 59
Someone must really hate Sony if they can't even type the name!
ti-triodes is online now  
post #5 of 6 Old 12-24-2008, 05:59 PM - Thread Starter
Member
 
Lionanimal's Avatar
 
Join Date: May 2005
Location: metro Seattle, WA, USA
Posts: 141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 11
Quote:
Originally Posted by ti-triodes View Post

Someone must really hate Sony if they can't even type the name!

Just seems that S*ny goes out of their way to make stuff that is not interoperable with other current equipment. Seems like some cort of cultural edict that they spend more to give us less, but charge us "way more". That is not "way cool".

On the other hand, I have ponied up for some great stuff from S*ny.
Lionanimal is offline  
post #6 of 6 Old 12-30-2008, 08:16 AM
Super Moderator
 
DrDon's Avatar
 
Join Date: Mar 2002
Location: Metro Detroit
Posts: 12,673
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)
Liked: 270
FWIW, I just returned the Insignia to Best Buy, last night. I had it and my BA hooked to the same antenna. The BA pulled in all of the local stations in HD. The Insignia only did about half and was unable to render the lone HD3 in town.

While I can live with the signal issues, the main reason for the return was an audio issue. There was a low level splatter in the audio. At first, I assumed it to be the station running the levels too hot into the encoder. But it was there on every station, AM, FM, analog and digital. And on both RCA and optical outputs. I even moved the box around to see if some other component was affecting it. Thought about exchanging it, but didn't want to have to go through three long lines at Best Buy on a single night. The 45 minute wait just to return it was quite enough.

Walking the fine line between jaw-dropping and a plain ol' yawn.
DrDon is offline  
Reply HD Radio

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off