Polk I-Sonic. High Defect Rate? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 11 Old 10-30-2007, 09:17 PM - Thread Starter
Member
 
motorcop's Avatar
 
Join Date: Jul 2003
Location: Los Angeles, California
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have three Polk I-Sonics. I have lost count but I'd say that I've had to have each replaced two or three times. The oldest is nearly a year old while the newest is about six months.

Some of the earlier replacements were for "ticking" on the CD/DVD transport. It's loud and is irritating if you're playing it at low volume or are sitting close to it. That problem has never been solved however some units seem louder than others.

Other problems have included the CD volume going down to nearly nothing while the radio section worked fine. Another had a complete failure of the unit, leaving the clock stuck at 12:00.

That being said, Polk Audio has been very responsive in replacing these units. I hope they are because two more are now down for the count again. I e-mailed them yesterday requesting replacements.

Am I just unlucky or are there widespread problems with this unit? I run all of my I-Sonics on either a high-quality UPS or surge protector.
motorcop is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 11-17-2007, 07:36 AM
Member
 
bradpeters's Avatar
 
Join Date: Dec 2006
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Motorcop,

Sorry I'm just responding to your post. I haven't logged on lately.

A friend of mine purchased an I-Sonic more than a year ago and has had a lot of trouble with it. He has returned it at least twice for replacement or service. Another time they sent him a CD-ROM to fix a problem. I asked him why he hasn't replaced it with something more reliable, but he likes the I-Sonic features, especially the integrated radio/CD player. Is that the reason you have been so loyal to the product? There are plenty of other HD radios out there!

He echoes your sentiments that Polk is very conscientious about their customer service. With a problematical product, they should be.

Brad
bradpeters is offline  
post #3 of 11 Old 11-17-2007, 10:24 AM - Thread Starter
Member
 
motorcop's Avatar
 
Join Date: Jul 2003
Location: Los Angeles, California
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for responding, Brad. So it appears that there's at least one other person out there with similar issues. I was beginning to wonder.

Anyway, I received my two replacements and they are fine (so far), with the exception of the same "ticking" CD drive that drives me nuts. I don't play CDs often, but use the HD and XM radio sections primarily.

If the product wasn't so great otherwise, I'd have asked for my money back a long time ago.

I'm hoping that Polk will finally get these issues worked out and that one of these days (soon) I'll have a "final" working product that looks great and has all the features I was looking for.

One of the units is nearing its first anniversary (if you don't consider the fact that it's been replaced three times) and will be going out of warranty. I hope that Polk continues to be responsive should this one become defective after the warranty expires.

I'll keep this thread updated should I have additional problems.
motorcop is offline  
post #4 of 11 Old 02-12-2008, 07:01 PM - Thread Starter
Member
 
motorcop's Avatar
 
Join Date: Jul 2003
Location: Los Angeles, California
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Another of my three I-Sonics has been acting up and will soon be sent back to meet its maker.

This one began acting up a month or so ago by displaying "Demo Mode" for no apparent reason while I was listening to AM radio. It locked up and wouldn't do anything until I pulled the plug. Then it would still show "Demo Mode" on occasion but still function.

Now, the other day it developed a loud hum on all modes. I narrowed it down to the XM mini-tuner. When I unplug XM the hum goes away. I tested the same mini-tuner on my other I-Sonics and neither of them hum.

So I fired off an e-mail to Polk. This is my third or fourth replacement.

Is it just me?

Update: Brought the unit home from my office, plugged it in to make certain I hadn't left a disc in it. I got a loud hum (no XM attached) and no display. Unplugged it and tried again. This time no hum and a half-lit display with about half of all pixels lit. Of course nothing happens when I press Eject. Guess I won't know if I have a disc in there or not.
motorcop is offline  
post #5 of 11 Old 02-12-2008, 11:13 PM
Senior Member
 
Rob Babcock's Avatar
 
Join Date: Apr 2004
Posts: 278
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It sucks that the product has such reliability problems. Especially since it's becoming legendary for its sound. But what good is superb sound if it's always in the shop? Hopefully Polk will make it right for you.
Rob Babcock is offline  
post #6 of 11 Old 02-15-2008, 09:59 PM - Thread Starter
Member
 
motorcop's Avatar
 
Join Date: Jul 2003
Location: Los Angeles, California
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I spoke with Ken Swauger of Polk Audio yesterday. He acknowledged that there is a problem with the I-Sonic and that it had been traced to the manufacturer that substituted (apparently substandard) parts without authorization. I sent two of my three units in today for replacement and am hopeful that this will finally solve the issue.
motorcop is offline  
post #7 of 11 Old 06-19-2008, 11:34 PM
Newbie
 
rcxrc's Avatar
 
Join Date: Aug 2007
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I had mine for exactly 14 months. Last week I turned it on for the first time in maybe a month. The LED displayed screwy images for a couple of minutes, some loud humming then buzzing from the back, then the screen went out completely.

I never used the DVD / CD player. I played it perhaps only 100 hours during the time I had it (I work too much to be home to use it). It always had a problem keeping correct time (off 5 min/ month or so).

This really stinks. Warranty is 1 yr.

I will try Polk tomorrow and see if they are responsive. If not, it will have far and away been the worst purchase of my life. $650 down the drain (I paid $599 + tax).

It sounded good, while it lasted.

RC
rcxrc is offline  
post #8 of 11 Old 06-21-2008, 11:06 AM - Thread Starter
Member
 
motorcop's Avatar
 
Join Date: Jul 2003
Location: Los Angeles, California
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by rcxrc View Post

I had mine for exactly 14 months. Last week I turned it on for the first time in maybe a month. The LED displayed screwy images for a couple of minutes, some loud humming then buzzing from the back, then the screen went out completely.

I never used the DVD / CD player. I played it perhaps only 100 hours during the time I had it (I work too much to be home to use it). It always had a problem keeping correct time (off 5 min/ month or so).

This really stinks. Warranty is 1 yr.

I will try Polk tomorrow and see if they are responsive. If not, it will have far and away been the worst purchase of my life. $650 down the drain (I paid $599 + tax).

It sounded good, while it lasted.

RC


I'd be surprised if Polk didn't make good on this for you. They've been very responsive--replacing my three units several times, once at least a few months out of warranty.

The problem with complete failure seems to be some sub-standard capacitors.

I'm still disappointed that they have not been able to solve the electronic "ticking" that plaques the CD section. Also, I tried headphones with the unit for the first time recently. There is so much noise in the headphone section that it makes it unusable.
motorcop is offline  
post #9 of 11 Old 08-18-2008, 09:46 AM
Newbie
 
Vdubradio's Avatar
 
Join Date: Aug 2008
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
The PolkAudio Isonic has indeed been a blessing and a curse.

On the plus side the unit offers outstanding audio for its size and loads of features. And allows tone control to give you just the right sound for your ear.

On the negative yes a consistent issue has been identified with early units.

The best part is although this unit has had many issue polk stands behind it and does everything in there power to assist customer in finding a solution.

Weather its a new replacement or having the unit replaced with the Isonic ES2(substantionally better track record) they will find a way to help.
Vdubradio is offline  
post #10 of 11 Old 08-19-2008, 05:38 PM - Thread Starter
Member
 
motorcop's Avatar
 
Join Date: Jul 2003
Location: Los Angeles, California
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well, I'm not ready to give up on CDs. I go to great lengths sometimes to find original CDs, as opposed to MP3s or the like.

Has anyone ever managed to get an I-Sonic that doesn't "click" when playing CDs?
motorcop is offline  
post #11 of 11 Old 09-24-2012, 06:46 PM
Newbie
 
SSax's Avatar
 
Join Date: Sep 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I've had 3 replacements and after 4 years, the radio no longer works. Customer service denied any problems with the the model (isonic). Any suggestions? Thanks
SSax is offline  
Reply HD Radio

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off