My first TC SOUNDS DIY sub! ***LOTS OF PICTURES*** - Page 3 - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!



Forum Jump: 
Reply
 
Thread Tools
post #61 of 83 Old 01-07-2010, 08:09 PM - Thread Starter
Member
 
maintrain's Avatar
 
Join Date: Jan 2009
Location: GA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by maintrain View Post

On the webpage in that link in the first post, the author refers to an excel spreadsheet he used to calculate the mass needed for his passives. Maybe it will help someone else who's trying to figure this out.

http://www.danmarx.org/audioinnovation/passive.xls

@oachalon
maintrain is offline  
Sponsored Links
Advertisement
 
post #62 of 83 Old 01-07-2010, 08:13 PM
Senior Member
 
oachalon's Avatar
 
Join Date: Dec 2002
Location: mentor, ohio
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 12
maintrain, thanks for the help.
oachalon is offline  
post #63 of 83 Old 01-07-2010, 08:16 PM
AVS Special Member
 
mjaudio's Avatar
 
Join Date: Nov 2002
Location: Fontana, CA
Posts: 2,566
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 73
Quote:
Originally Posted by oachalon View Post

does anybody have a passive radiator calculator online, im too lazy to calculate by hand right now. All the links i found were dead. AE speakers used to have one but it looks like the link is dead as well.

I just use WinISD Pro, they have a PR option.
mjaudio is offline  
post #64 of 83 Old 01-07-2010, 08:19 PM
Senior Member
 
oachalon's Avatar
 
Join Date: Dec 2002
Location: mentor, ohio
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 12
so with a 6-6.5 cubic ft enclosure i would want to add about 1550g to the exodus passive radiators. that will give me 1850g each and tuning of around 17-18hz.
oachalon is offline  
post #65 of 83 Old 01-07-2010, 08:19 PM
Advanced Member
 
Kingdaddy's Avatar
 
Join Date: May 2003
Location: Fort Worth Texas
Posts: 889
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Nice job, good exicution!
Kingdaddy is offline  
post #66 of 83 Old 01-07-2010, 08:22 PM
AVS Special Member
 
mjaudio's Avatar
 
Join Date: Nov 2002
Location: Fontana, CA
Posts: 2,566
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 73
Quote:
Originally Posted by oachalon View Post

so with a 6-6.5 cubic ft enclosure i would want to add about 1550g to the exodus passive radiators. that will give me 1850g each and tuning of around 17-18hz.

I haven't run the numbers but that sounds about right.
mjaudio is offline  
post #67 of 83 Old 01-07-2010, 08:38 PM
Advanced Member
 
spanish68's Avatar
 
Join Date: Jun 2008
Location: S. Florida
Posts: 671
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
maintrain, a crossover of 60hz or below would work great with the TC 3k sub. Measure the sub in the PR box and see what you get, if your response is great to 80hz, that's where I would cross it at.
spanish68 is offline  
post #68 of 83 Old 01-09-2010, 04:20 PM - Thread Starter
Member
 
maintrain's Avatar
 
Join Date: Jan 2009
Location: GA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Holy &%$!

I cannot believe how good this thing sounds! Terminator Salvation soundtrack is ridiculous and this sub is LOUD! I can't turn the ep-2500 past 1/4 gain with out it completely overpowering all the other speakers. My wife was caught completely off guard during one of the action sequences and nearly jumped off the sofa! Back to the movie!
maintrain is offline  
post #69 of 83 Old 01-09-2010, 04:41 PM
AVS Special Member
 
jpmst3's Avatar
 
Join Date: Dec 2005
Location: Davidsville, PA
Posts: 8,545
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 97 Post(s)
Liked: 232
Quote:
Originally Posted by maintrain View Post

Holy &%$!

I cannot believe how good this thing sounds! Terminator Salvation soundtrack is ridiculous and this sub is LOUD! I can't turn the ep-2500 past 1/4 gain with out it completely overpowering all the other speakers. My wife was caught completely off guard during one of the action sequences and nearly jumped off the sofa! Back to the movie!

Sweet!

Glad you have the results you desire. Nice work!

______________________________________________
Joe = LFE Addict
Joe's LOWARHORN build
Dual LMS-5400 Ultra Endtables build
jpmst3 is online now  
post #70 of 83 Old 01-09-2010, 08:00 PM
Advanced Member
 
spanish68's Avatar
 
Join Date: Jun 2008
Location: S. Florida
Posts: 671
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 15
maintrain, what crossover did you use for the TC 3K? Did you do any frequency measurements? Yes, the TC 3k sub can go low and hits hard in the low bass when called upon.
spanish68 is offline  
post #71 of 83 Old 01-10-2010, 11:19 AM
AVS Special Member
 
mjaudio's Avatar
 
Join Date: Nov 2002
Location: Fontana, CA
Posts: 2,566
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 73
I am really happy to hear the performance matches the look of your great sub.

What sub were you using before?
mjaudio is offline  
post #72 of 83 Old 01-11-2010, 04:47 AM - Thread Starter
Member
 
maintrain's Avatar
 
Join Date: Jan 2009
Location: GA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by spanish68 View Post

maintrain, what crossover did you use for the TC 3K? Did you do any frequency measurements? Yes, the TC 3k sub can go low and hits hard in the low bass when called upon.

It's crossed @ 50hz but I haven't had a chance to do any measurements yet.

Quote:
Originally Posted by mjaudio View Post

I am really happy to hear the performance matches the look of your great sub.

What sub were you using before?

Audiosource SWfifteen. Doesn't even come close to sounding like this!


I now have a little hum coming from the audiobuddy pre-amp. Hum disappears when I bypass the pre-amp but I lose a lot of volume from the sub without it. I've read threads about grounding issues using a rca to xlr adapter. This is the one I'm using: http://www.parts-express.com/pe/show...number=240-438 . Would I be better off using a cheap ground loop isolator or running a 1/4 to rca adapter on the high impedance input?
maintrain is offline  
post #73 of 83 Old 01-11-2010, 03:48 PM
Member
 
zhillsguy's Avatar
 
Join Date: Aug 2009
Posts: 182
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 16
Quote:
Originally Posted by maintrain View Post
I now have a little hum coming from the audiobuddy pre-amp. Hum disappears when I bypass the pre-amp but I lose a lot of volume from the sub without it. I've read threads about grounding issues using a rca to xlr adapter. This is the one I'm using: http://www.parts-express.com/pe/show...number=240-438 . Would I be better off using a cheap ground loop isolator or running a 1/4 to rca adapter on the high impedance input?
Read this page and try building a cable according to the chart, #17:
http://www.rane.com/note110.html

Too many threads here on hum already.....give it a shot, it may cure the problem.

 

Cable_A.pdf 33.9052734375k . file
zhillsguy is offline  
post #74 of 83 Old 01-11-2010, 03:49 PM
AVS Special Member
 
mjaudio's Avatar
 
Join Date: Nov 2002
Location: Fontana, CA
Posts: 2,566
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 73
Hey Marcus,

Why would you use the audiobuddy pre-amp if you only have the gain turned up 1/4 of the way on the amp? You can rub the gain all the way up on your amp, I do and control the volume from either my pre-pro or Velodybe SMS-1.

You could try one of these to connect you receiver to the sub-amp:

http://www.monoprice.com/products/pr...seq=1&format=2

Just some suggestions as I noticed you commented on having the gain only 1/4 up on your amp before when watching a movie.
mjaudio is offline  
post #75 of 83 Old 01-12-2010, 01:14 PM
Member
 
Reaper737's Avatar
 
Join Date: Dec 2007
Location: South Texas
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Just wanted to say very nice build man, it looks and I'm sure sounds awesome.
Reaper737 is offline  
post #76 of 83 Old 01-18-2010, 04:36 PM - Thread Starter
Member
 
maintrain's Avatar
 
Join Date: Jan 2009
Location: GA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by zhillsguy View Post

Read this page and try building a cable according to the chart, #17:
http://www.rane.com/note110.html

Too many threads here on hum already.....give it a shot, it may cure the problem.

Yeah I read about that. I ended up buying a Sampson s-convert and that solved all my hum problems and gave me a stronger signal into the amp. I picked it over the art cleanbox seeing that I wouldn't have to mod it. It's working perfectly.

Quote:
Originally Posted by mjaudio View Post

Hey Marcus,

Why would you use the audiobuddy pre-amp if you only have the gain turned up 1/4 of the way on the amp? You can rub the gain all the way up on your amp, I do and control the volume from either my pre-pro or Velodybe SMS-1.

You could try one of these to connect you receiver to the sub-amp:

http://www.monoprice.com/products/pr...seq=1&format=2

Just some suggestions as I noticed you commented on having the gain only 1/4 up on your amp before when watching a movie.

I'm ditching the audio buddy. Truth is, I couldn't turn it up over 1/4 without picking up noise from the sat antenna cable. I didn't get noise when testing at work. All is well using the Sampson S-Convert and I'm using the avr sub volume control.

Quote:
Originally Posted by Reaper737 View Post

Just wanted to say very nice build man, it looks and I'm sure sounds awesome.

Thanks Reaper. I'm enjoying it more everyday.
maintrain is offline  
post #77 of 83 Old 01-18-2010, 06:10 PM
Member
 
zhillsguy's Avatar
 
Join Date: Aug 2009
Posts: 182
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 16
Quote:
Originally Posted by maintrain View Post

Yeah I read about that. I ended up buying a Sampson s-convert and that solved all my hum problems and gave me a stronger signal into the amp. I picked it over the art cleanbox seeing that I wouldn't have to mod it. It's working perfectly.


I'm ditching the audio buddy. Truth is, I couldn't turn it up over 1/4 without picking up noise from the sat antenna cable. I didn't get noise when testing at work. All is well using the Sampson S-Convert and I'm using the avr sub volume control.


Thanks Reaper. I'm enjoying it more everyday.

Glad it worked out for you, mt. Funny how everyone's mileage varies......I had to ditch my S-Convert, ends up it was amplifying all AC switching noises in my house beyond comfort level as described in my earlier thread:
http://www.avsforum.com/avs-vb/showt...969&highlight=
I ended up getting a MIC2200 to provide boost/eq....truth be told, I could have gotten by without it and am running everything at 0db level, no boost. My older Onkyo AVR provides enough output to the EP2500 as long as I keep my audio signal separate from any chassis ground (as in cable config #17). With chassis connected on the EP input side I get hum up the wazoo and a big signal loss. When I hook up my Yamaha powered mixer (unbalanced output) to the EP with no special cables (chassis tied to signal common via adapters) it works great. Go figure, you never know when interfacing "home" with "pro", trial and error is necessary.

BTW, great build!
zhillsguy is offline  
post #78 of 83 Old 02-12-2010, 08:02 AM - Thread Starter
Member
 
maintrain's Avatar
 
Join Date: Jan 2009
Location: GA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
minor update. i've changed amps. went from the ep2500 to and yamaha p7000s. I'v read threads that state the yamaha pxxxxs amps don't perform very well @ low freq but i am experiencing the opposite. the yamaha is giving me better performance <30hz and i truly do NOT miss that fan noise! Another thing, it's running 4ohms bridged and doesn't seem to have any problems running that load. I plan on spending more time with it this evening.
maintrain is offline  
post #79 of 83 Old 09-06-2010, 11:00 AM
Newbie
 
NcHalfrican's Avatar
 
Join Date: May 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Amazing build quality...love me some TC Sounds
NcHalfrican is offline  
post #80 of 83 Old 11-22-2011, 09:41 PM - Thread Starter
Member
 
maintrain's Avatar
 
Join Date: Jan 2009
Location: GA
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I can't believe it has been on over a year since I updated this page. I have a new video to post. Check it out: http://www.youtube.com/watch?v=dfu_B7kTC-o
maintrain is offline  
post #81 of 83 Old 11-25-2011, 07:27 AM
AVS Special Member
 
Exocer's Avatar
 
Join Date: Mar 2005
Location: The big apple
Posts: 1,864
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I admire your work! Excellent stuff. Inspires me to back into DIY!

Only time will tell what the future holds...so until then JAM LIKE THERES NO TOMORROW!
-Rob

My Natalie P project
Exocer is offline  
post #82 of 83 Old 11-25-2011, 06:33 PM
AVS Special Member
 
chrapladm's Avatar
 
Join Date: Mar 2010
Location: Adelaide, South Australia
Posts: 3,979
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 682 Post(s)
Liked: 246
Can you play this on your sub and tell me what you think?
http://www.youtube.com/watch?v=ZgcDxm1HI60

Either way awesome sub.
chrapladm is online now  
post #83 of 83 Old 02-05-2013, 11:13 AM
Member
 
brybo86's Avatar
 
Join Date: Oct 2008
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am jealous of those passive radiators. This sub looks very nice. I just have a couple questions. What made you decide to notch the wood for the binding posts? Also why not make the TC Sounds Logo straight across? Do you have any REW plots of the frequency response? Anyways, very nice sub.
brybo86 is offline  
Sponsored Links
Advertisement
 
Reply DIY Speakers and Subs

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off