Please help me resurrect my A5-350 subwoofer (complete!) - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 11 Old 05-28-2013, 11:01 AM - Thread Starter
AVS Special Member
 
Sonies's Avatar
 
Join Date: Jul 2009
Location: Chicago, IL
Posts: 1,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Dead amp in my A5-350 and no plate amps will either fit or provide enough power to power the 15" subwoofer. (and ED is out of business surprisingly rolleyes.gif )

I am still waiting for my multimeter to show up to see if the speaker is blown (anyone know how to do that? where to put the leads?)

, if its not I am just going to use a new standalone amp.

If it is blown I am going to see about replacing the driver with a TC Sounds LMS-R 15" DVC Subwoofer (hopefully the box will be a good fit)

First is there a quiet, standalone amp with RCA inputs under say 400 bucks that will power my 16.Ov.2 speaker, and if by some chance the speaker is blown, will it be enough to power the TC Sounds, LMS-R?

anyone own a Crown XLS 1500 Power Amplifier, and is it quiet enough for dedicated home theater subwoofer use?

Thanks in advance anyone that replies with some help biggrin.gif
Sonies is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 05-28-2013, 12:21 PM
Advanced Member
 
mtg90's Avatar
 
Join Date: Aug 2011
Location: Millbrook, IL
Posts: 757
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 125
If you have a working amp (can even be your AVR) just hook the driver up to that and run some sine waves through it at low levels. If it moves without making scratching noises then it is fine. You can also test it by placing a 9 volt battery across the terminals, if it moves the coil is still good. With the multimeter you are checking for impedance on the voice coil, you should see between 3-4 ohms when connected to the terminals if it is good. If it is dead either it shorts and you read close to 0 ohms (though I have seen cooked coils half shorted) or it opens up and you get no reading at all.
mtg90 is offline  
post #3 of 11 Old 05-28-2013, 12:33 PM
Advanced Member
 
Face2's Avatar
 
Join Date: Mar 2007
Location: Long Island, NY
Posts: 646
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 41
If you're proficient at using a router, you can replace the (assumably) dead eD amp with a 500w Yung plate amp.

As for the XLS1500, how close do you sit to the amp?

Mike
Face2 is offline  
post #4 of 11 Old 05-28-2013, 01:15 PM
Member
 
mrbrace's Avatar
 
Join Date: Sep 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey brother I have the same issue with the same woofer, just recently. Bought a 500W Dayton plate amp which is a 10 x 10 cutout and just took a saw to the back to cut it out and viola installed great. Best thing about it though is that their 1000W amp is the same cutout so I can always upgrade. The new amp is much better and the woofer is much louder.

http://www.parts-express.com/pe/showdetl.cfm?partnumber=300-807

if it is like my eD amp there was no load on it and it got incredibly hot in a short amount of time like 45 seconds or so..

A5-350 w/ 500W Dayton Amp
A6-5T5 Towers
A6-MTM Center
mrbrace is offline  
post #5 of 11 Old 05-28-2013, 01:43 PM - Thread Starter
AVS Special Member
 
Sonies's Avatar
 
Join Date: Jul 2009
Location: Chicago, IL
Posts: 1,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ok i'll check the speaker tonight.

I'll be about 10-12' from the XLS1500, will it be quiet enough? Will the ported cabinet be big enough and sound ok with the LMS-R 15"? I'm seriously considering just starting over but using the fairly well constructed box...

No router available, I'm in a condo so If i make a new hole I'll have to saw it myself like the poster above me.

Going to think about that dayton amp. Not the biggest fan of their stuff, nor do I trust a Yung amp to not die in two years or less... decisions!
Sonies is offline  
post #6 of 11 Old 05-28-2013, 03:44 PM - Thread Starter
AVS Special Member
 
Sonies's Avatar
 
Join Date: Jul 2009
Location: Chicago, IL
Posts: 1,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
ok the driver is fine... now i just need a standalone amp
Sonies is offline  
post #7 of 11 Old 05-28-2013, 04:14 PM
Senior Member
 
djarchow's Avatar
 
Join Date: Mar 2005
Location: Iowa
Posts: 457
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 25
From the pics I could find the amp looks like a rebadged Yung SD500-6 amp. They are $238 on parts express.
djarchow is offline  
post #8 of 11 Old 05-28-2013, 04:25 PM - Thread Starter
AVS Special Member
 
Sonies's Avatar
 
Join Date: Jul 2009
Location: Chicago, IL
Posts: 1,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I think im going with the crown XLS 1000 for$299

I'll let you all know how it goes in a few days
Sonies is offline  
post #9 of 11 Old 05-28-2013, 04:32 PM
Member
 
mrbrace's Avatar
 
Join Date: Sep 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ya please do I do plan on upgrading in the future but for my super small living room the 500rms works

A5-350 w/ 500W Dayton Amp
A6-5T5 Towers
A6-MTM Center
mrbrace is offline  
post #10 of 11 Old 05-31-2013, 09:58 PM - Thread Starter
AVS Special Member
 
Sonies's Avatar
 
Join Date: Jul 2009
Location: Chicago, IL
Posts: 1,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ok so I got the multimeter, hooked it up to the two wires coming out of the sub (bridged or something still) and it says 6.4 ohms... wtf? Its a dual voice coil sub so what does this mean?

Also, Im going to use the binding posts on the existing LT.500 amp instead of making a mess with MDF and extra work, just going to disconnect the wiring and use the binding posts from the upper right hand side of the sub amp
Sonies is offline  
post #11 of 11 Old 06-03-2013, 06:49 AM - Thread Starter
AVS Special Member
 
Sonies's Avatar
 
Join Date: Jul 2009
Location: Chicago, IL
Posts: 1,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
So basically the Crown XLS1000 amp I got works perfect.

Super quiet, smaller and lighter than I thought it would be, easy to set up (took literally 30 seconds), and has plenty of output.

I basically cut the wires from the inside binding posts of the LT500 amp, rewired the entire inside of the speaker (since the existing wiring was crap), hooked the speaker up to the binding posts on the inside (most difficult part lol) and screwed the plate amp back on.

Hooked up the LFE cable from my denon, to the crown, then made a 2 ended banana plug wire and hooked it up bridged via the directions and plugged the other end into the LT500 amp posts and VOILA!

Sounds great, had to turn up the gain to max, and turn the subwoofer channel up from how I had it before, but then I watched The Dark Knight Rises on blu ray and had to turn it down quite a bit as to not disturb my neighbors, Good thing its easy!


Would reccomend as a replacement for those looking for standalone solutions. Best part is you don't have to deal with the annoying auto-on/off crap from the LT500 now, you have a functioning button to use.
Sonies is offline  
Reply DIY Speakers and Subs

Tags
Elemental Designs A5 350

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off