amp help behringer ep2000 - Page 2 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #31 of 35 Old 06-02-2013, 04:33 PM - Thread Starter
Member
 
flexinator's Avatar
 
Join Date: Oct 2006
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
You'll never believe it. I'm a huge jerk. After this whole saga... i decided to use some new wires inside the box to connect the subs together (since they are wired in series). And boom. they are now hitting huge. I can feel the ground vibrate 2 floors up. I knew that they weren't huge subs, but i knew they would be louder than what i was getting. I do want to thank everyone for all the help. I learned alot about how to troubleshoot... but in the end its always something simple.

now its on to figuring out what kind of dimmer for my led rope lights won't make them flicker...
flexinator is offline  
Sponsored Links
Advertisement
 
post #32 of 35 Old 06-02-2013, 06:57 PM
AVS Special Member
 
bass addict's Avatar
 
Join Date: Dec 2003
Location: A padded room
Posts: 3,774
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 210
Quote:
Originally Posted by flexinator View Post

You'll never believe it. I'm a huge jerk. After this whole saga... i decided to use some new wires inside the box to connect the subs together (since they are wired in series). And boom. they are now hitting huge. I can feel the ground vibrate 2 floors up. I knew that they weren't huge subs, but i knew they would be louder than what i was getting. I do want to thank everyone for all the help. I learned alot about how to troubleshoot... but in the end its always something simple.

now its on to figuring out what kind of dimmer for my led rope lights won't make them flicker...

Good to hear you got it figured out. 99% of the time the biggest issues stem from the smallest problems.

I really like Smarthome dimmers. They work great on my stage, sofit, and riser rope lighting. Dim at multiple settings with no flicker. Only minor setback is the switches flow enough current even when off that the lights will never completely dim. Not really an issue for me but YMMV.

Achievement Unlocked

Psychotic Episode Averted

bass addict is offline  
post #33 of 35 Old 06-02-2013, 07:01 PM
AVS Special Member
 
Mrkazador's Avatar
 
Join Date: Jun 2005
Posts: 3,828
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 248

So what was wrong with the old speaker wire? Were they wired incorrectly?

Mrkazador is offline  
post #34 of 35 Old 06-02-2013, 07:21 PM - Thread Starter
Member
 
flexinator's Avatar
 
Join Date: Oct 2006
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
No it was wired correctly, I even checked the impedance(which was fine, so not a short)

I suspect that the end of it was corroded or something, the connecting wire didn't look to be copper. I re-wired it with fresh 12ga.

That box kicked for a few years in my car then lived in the basement for a few years...
flexinator is offline  
post #35 of 35 Old 06-03-2013, 07:37 AM - Thread Starter
Member
 
flexinator's Avatar
 
Join Date: Oct 2006
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
In case you wanted to see the faulty wire... here's a nice pic. I want to mention, when I originally bought the box, this wire was part of the original setup. It isn't a very nice wire, and looking at it now, I can't believe I never replaced it.
flexinator is offline  
Reply DIY Speakers and Subs

Tags
Denon Avr3312ci Receiver
Gear in this thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off