Joe's LOWARHORN build - Page 11 - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
Old 03-09-2015, 07:16 PM - Thread Starter
AVS Special Member
jpmst3's Avatar
Join Date: Dec 2005
Location: Davidsville, PA
Posts: 8,541
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 96 Post(s)
Liked: 231
Originally Posted by blah450 View Post
Oh. What a duh moment for me, Joe!
I guess I am losing it a little after the years have started to pile on...
Didn't even realize I had been subscribed to this thread a while ago and had even posted back in Dec 2013 after you had finished.

Have you left the LH crossed at 70 or 80 to avoid the ringing?
It happens!

I have always crossed my setup at 60Hz, long before horns were introduced, so it is not an issue for me regardless. However, you can EQ 90+% of it out with little effort.

Joe = LFE Addict
Joe's LOWARHORN build
Dual LMS-5400 Ultra Endtables build
jpmst3 is offline  
Sponsored Links
Old 06-28-2015, 01:11 PM
AVS Special Member
kgveteran's Avatar
Join Date: Apr 2004
Location: Rochester NY
Posts: 6,162
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 188 Post(s)
Liked: 97
Well, after 4 months any more input on the Horn ? Any suprises ?
kgveteran is offline  
Thread Tools

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off